No 3.5mm analogue audio output option, since latest update, Pi 3B

First of all, thanks for making great software that generally works well.
I write to identify an issue that has arose since the latest major update (2021.08-1).

Simply put, there is now to longer an option in the output output setting for the analogue 3.5mm jack.
There are just 3 near-identical HDMI options. I am running OSMC on a Raspberry Pi 3 Model B Rev 1.2.

Certainly the audio does output on HDMI, however I can no longer change it to the 3.5mm jack within OSMC settings. To return to the previous functionality would be welcome.

As an aside, my bluetooth headphones now connect properly from within OSMC, which is a welcome improvement. Currently no option for bluetooth audio output in the list either, however this can wait :slight_smile:

Thanks again for the great work you guys do!


You would need to add the following to /boot/config-user.txt


You would need to create a asoundrc file as explained in this thread

Thank you very much fzinken. This fixed the 3.5mm jack issue perfectly.

The armv7-bluez-alsa-osmc.deb didn’t install for me, however this is no big deal. Will wait for future updates.

Thanks again!

That should not be installed as a different version comes already with OSMC now

When testing in console:

root@rpibed:~# dtoverlay pisound
root@rpibed:~# dtparam audio=on
* Failed to read active DTB

I’ll try to add in config-user.txt and reboot in a few hours


I’m trying to get the 3,5mm analog audio output to work on RPi 3 again. It stopped after doing the big update a few days ago. Soundcard info just shows the following:

$ cat /proc/asound/devices
0: [ 0] : control
16: [ 0- 0]: digital audio playback
33: : timer

$ cat /proc/asound/pcm
00-00: MAI PCM vc4-hdmi-hifi-0 : MAI PCM vc4-hdmi-hifi-0 : playback 1

$ cat /proc/asound/cards
0 [vc4hdmi ]: vc4-hdmi - vc4-hdmi

Is it lost forever with this update, or is is possible to get it back? Would prefer to have dual output (HDMI+Analogue) at the same time.

Moved your post here as the topic was already discussed

1 Like

After altering config-user.txt, the sound now goes via audio jack (bcm2835 Headphones) to an amp, but it is distorted on mkv video file (not avi). You can hear crackles all the time, like people are talking through a bad mic…

also tried adding audio_pwm_mode=2 to no avail… probs outdated

playing mp3 and flac works without this issue

playing the same video/audio through hdmi does not give this issue

do I need to install some codecs?

1 Like

Thanks for helping me find the right thread, but I have to agree with moujik. Sound levels are extremely low. Movies are distorted and weird. Bluetooth connection and audio plugins work, but the sound levels are so low you have to boost the amp up to crazy levels.

I can work around it for now, using an output from the TV instead of the PI, but would prefer to get the 3,5mm working fully again, if possible.

Try to install alsa-utils and increase volume with alsamixer

sudo apt-get update
sudo apt-get install alsa-utils

I upgrade my Leila Build on RP3 with Matrix and I got the same problem.

I was no more able to choose HDMI + Analog (3,5mm).
I need to add dtoverlay=pisound and dtparam=audio=on in the txt co fig file.
Now I can choose bcm2835 Headphones and it works fine to listen musique (MP3 I presume) but the sound is horrible when I watch video (my mkv hollidays movies), I hear some crackles.

EDIT : I tried to install alsa-utils and the volume is very low (I must increase the volume on osmc at 100% and my amp at the maximum) AND the crackles are always audible.

Any solution ?

I have this exact same problem. Using a RPi3b with sound output via 3.5mm to an amplifier.
I updated to 19 and sound went. Adding those two lines to config.txt restored sound but it’s extremely crackly. Using Alsamixer shows the level was already 70%.

I guess I replied too fast. Sound for music, flac etc works fine. However I too am having the crackling issue on movies. Happens only for the speech, not background music?
Haven’t had any issues with volume.
Glad I’m not the only one. Let’s hope this can get properly fixed.

1 Like

Same here. Since the 19.1 update I’ve lost the analog sound. Got a rpi3B rev 1.2.
I changed the config-user.txt and added dtparam and dtoverlay. This made the
headphone appear in the system/audio menu, but no sound. alsamixer for headphone is at 100.

Checking config values fails:
sudo dtparam audio gives: * Failed to read active DTB

sudo dtoverlay -r pisound gives: * Overlay ‘pisound’ is not loaded

Another thing: in the kodi menu I see one extra entry, the hdmi-input from the TV (thus 2
times vc4-hdmi, one MAI and one SAM).

Anybody: How can I get the dual output (HDMI+Analogue) back?

I use osmc with hdmi for video playback from kodi. And I use raspotify through alsa to play music from the audio-jack.

Since the update the audio through the jack doesn’t work. I guess this is due to the same problem described here.

So I would also like the playback though jack back.

I confirm I get the same but audio is coming out of the jack - had to use alsamixer to pull up the volume to 100% so I could hear it on headphones.

I also get the crackling when playing Dolby Digital or DTS tracks.

I don’t think that’s supported now. You may be able to achieve it with some ALSA config voodoo (read about the multi plugin).

The topic seems to be solved so I created a new post here :

Well there seems to be a mix-up between ‘crackles’ and ‘no-sound’ here. The crackles problem might or might not be solved, but the no-sound problem most certainly is not.

Isn’t it the other way around? When I added the two extra lines to the /boot/config file then sound returned. But it’s still crackly.