No audio on Vero 4k+, fine on Rpi3B

I’m trying to figure out why a file’s audio plays just fine on my Pi 3B, but not my Vero 4k+. Info pegs it as “Undetermined - AAC Stereo - 2 channels”

Where do I start digging?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

This could be useful too.

Please read this post about correctly setting up your audio.

I just reviewed the log and it has stuff from six months ago up to today. I am probably over-cautious, but is there a way to limit the logs to my current settings and most recent session that exhibits the behavior? I don’t see any options for deleting/resetting/clearing logs anywhere in the UI.

Edit: I’m comfortable with navigating and running commands via ssh.

Reboot twice, will clear present and previous Kodi logs.

I’ve rebooted 5 times and the logs still include that. Do I need to uncheck send all logs and just select certain ones?

As per the “how to submit a useful support request” writeup you can edit your logs if they happen to contain something you wish to not be made public…

Sanitizing your logs

While generally the script tries to hide all passwords we know that certain people still are not comfortable with any information shared. If you are one of those first create the file locally, edit it and then upload it. To do so use:

grab-logs -A -C
nano /boot/uploadlog.txt
paste-log /boot/uploadlog.txt

If you upload a such altered log file please let us know so that we don’t wonder about possible gaps.

Exactly what is in the logs that is concerning you?

I only worry about IP addresses and any hardcoded logins and passwords considering I am using Samba shares. I don’t use any of those scary add-ons that get you banned, it’s more that if the extraneous stuff from July of last year can be ditched I’d rather it be ditched.

After skimming far too much of this thing I’m comfortable that it doesn’t have PII in there.

Thanks for your help.

My setup is Kodi to TV, TV to ARC input on 4k receiver, so I used the first set of configs on that audio page. The only change I had to make was upping the channels from 5.1 to 7.1, all else was already set as prescribed. Retried file just to be sure with no luck. :confused:

Does it not make more sense to connect Vero>receiver>TV so that you are not at the mercy of what audio formats may or may not be properly returned to the receiver by your television?

Also, as far as IP addresses in the logs, there is no concern with sharing addresses within your local network. They are likely the same addresses used by all of us within our private networks. Example, my lan addresses are all 192.168.1.x. But this is the purpose of our routers/modems, they firewall the rest of the world from being able to reach them.

Edit: I also think you should read the following section more carefully. It explains the limitations when using ARC.

Ok just to avoid confusion for any one else reading this. After 2 times rebooting the only log that has older information or shows dates from long time ago is the APT log which shows the package installations.

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz,  bit
Dobly_Digital+, 8 ch, 32/44.1/48 kHz, 16 bit

---------------------- Audio Cap END --------------- k3dRrf31

If your going to stay connected to your TV then try two channel, and disable DTS, DTS-HD, and TrueHD. It may be possible that the TV does not allow for passthrough of bitstream at all or requires you to manually set the input as bitstream to pass that though the TV. AC3 transcode can sometimes be a bit funny so you can try disabling that as well.

That being said I agree 100% with ActionA that it makes a lot more sense to plug the Vero into the AVR and then use your current settings except with AC3 transcoding disabled as it would serve no purpose when connected to a modern AVR.

You should also tweak your video so it will actually output 4k


We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

FYI, setting the recent items to such a high number normally has a negative impact on the responsiveness of the GUI.


I don’t believe ARC is the issue here as I tested by setting my TV to use it’s own a (taking my receiver out of the mix) and had the same issue. I think my next step will be hooking it directly to the TV with the Pi running OSMC (which plays with audio) and see if I still get no audio.

ARC factors in unless you have eARC, and it is not so much the ARC but rather what input your TV will accept and pass through. If you set the the Vero to two channels and turn off all passthrough I think you will find working sound. Getting a bitstream to go through a TV is where things can get a bit fussy.

This is indeed tricky.