No internet after december update...?

Hey alls.

I’ve had my Pi3 up and running with OSMC for a good while now. When I first set it up, I used openvpn with my PIA account and everything has been working as it should up until recently.

When I received the latest update (December), I could no longer access anything outside of my home network. It shows that I am connected in MyOSMC, however nothing works. I’ve tried both wired and wireless connections… no change.

I decided to do a clean wipe and start from scratch on my Pi with the newest version of OSMC. I went through the setup… install went smoothly. I setup openvpn the same way I have in the past using this method - How to Setup an OpenVPN connection to your PIA VPN on your Raspberry Pi with OSMC installed - YouTube

When I went to check my IP… it would time out every time. Skipped checking my IP address and loaded up some apps… no internet. Same as it was prior to the wipe.

I wiped everything again and set it up using an older version of OSMC… setup openvpn… everything works great. Tonight it auto updated and now I’m back to no internet.

What is the deal with the new update and openvpn or what is being changed to cause this? What do I need to do to correct it? Can’t seem to find anyone having this issue.


With the latest update a DNS leak bug was fixed so my gut feel is your problem could be the same as here [SOLVED] Recent update glitched outbound network access, kind of

Check what your /etc/resolv.conf gives you and if the nameservers mentioned in there answer to DNS requests when you are connected to your VPN

I pulled up the resolv.conf… I get -


I tried to ping both from my laptop and both time out.

Keep in mind… I’m very new to this so I may be doing it wrong. I’m not much of a command line guy so doing everything via text and not knowing paths, programs, etc… lol

Anyways… my laptop, gaming rig, and phone are all using the same VPN service without issue so I don’t believe it is a problem with my ISP or the VPN provider.

Does a ping to them works when you disable your VPN?

Also with your VPN active do:
ping does it work?
route and provide the output


Works… gets decent response times.

What would be the best way to copy what I’m seeing in the command line to here? It gets all jumbled up

After you paste it use the “preformatted” button looks like </>

How about ping with your VPN deactivated?

Maybe dumb… but how do I deactivate the vpn on osmc? I just followed the walkthrough to set it up… step by step. Not sure on how to disable it

osmc 1

Ok… disabled the vpn on my laptop and can now ping without issue.

Reactivated my vpn on my laptop… times out.

I just took a quick look at that video but I assume sudo systemctl stop openvpn@vpn.service

While to be honest as a quick fix most likely easiest is to replace your nameserver with

Ok means that DNS servers don’t like access from outside
So means you either use DNS server that your VPN provider provides you or public ones like

Will using a public dns take away from using the vpn in the first place?

If no… then how do I go about changing the nameserver where it will be consistent? I had read that it can revert back on reboot.

Well question is how did you configure your network? Are you using DHCP? Then you would need to correct it in your router. Otherwise in MyOSMC Network change the DNS server that would be persistent

Not using DHCP so I’ll change it through MyOSMC.

As far as security is concerned… will a public DNS server such as be an issue?

You are using a VPN! So your IP address suppose to be anonymous. Basically before hand with the DNS Leak “security” (if you want to call it that way) was more at risk

I don’t exactly know what a DNS does which is why I asked. I’ll change it here in a few and report back.

Thanks for the help!

Well to be honest if you don’t know what a DNS does you better should not use internet services that requires you to use a VPN

Looks like I’ve got some reading to do. Anyways, changing the DNS got me back up and running.

Now the question is why was there an issue. I tried several of the servers listed by PIA and none of them worked when I tried to ping them with my VPN running on my laptop…

However… my laptop is currently using the same IPv4 DNS servers that OSMC was setup with in the first place (IPv4 DNS Servers:,… my laptop is working fine (VPN active or not) but OSMC wouldn’t do anything with them with the VPN service running.

What would cause that?

Your Laptop has a DNS Leaking bug :wink: