No Picture on Screen

Good Morning,

Yesterday I took delivery of my Vero 4K +, previous to this I had been using a Raspberry Pi 4.

I set everything up and was extremely pleased until this morning, I had no picture on my TV when I selected the appropriate input.
I have a Sony XH950 TV and have never had any previous issues.
The Vero hadn’t lost power as the unit was still warm, it just wasn’t displaying an image on screen so I unplugged and plugged back in the HDMI cable and it appeared.
I turned off the TV then back on and the same thing happened, no image.
The next thing I did was to change the resolution settings in the Vero back to 1920 x 1080p @60 and for some reason that seemed to fix the issue, when I now turned the TV off and back on the image appeared on the screen.
But for me defeats the purpose of purchasing the Vero 4K as I can only set it at 1920 x 1080p.
Any help would be appreciated.

Best Wishes,


What resolution are you trying to set the device to?

Firstly, we recommend running the UI at 1080p and enabling Adjust Refresh Rate. We then automatically switch to 4K when necessary.

If you have issues with 4K output, then I’d recommend enabling 4:2:2 output in Settings → Display first as your TV may have issues.

Other than that, I’d suggest trying a new cable.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.