No RGB limited option? (in Kodi settings)

Hi!
I got a new TV and just read up on video levels so I wanted to set up everything correctly:
http://kodi.wiki/view/Video_levels_and_color_space
I set the RPi3 GPU to RGB full and the TV to Limited, but I don’t have a RGB setting in the Kodi options (should be under System -> Video Output? Level is obviously set to Expert)
Also I read about a bug with VAAPI and Intel on Kodi pre-17… that doesnt concern RPi3 though?
Where can I set Kodi to limited video levels?

Why would you set that in kodi if you already set it globally on raspberry?
Kodi does not interfere with decoding. The decoding is done on the videocore gpu.

Sorry, but thats wrong.

RPi Full + TV Full = Picture OK, but no 0-15 displayed (even with brightness turned up)
RPi Full + TV Limited = Everything too dark (still no 0-15 displayed)
RPi Limited + TV Limited = Picture OK, but no 0-15 displayed
RPi Limited + TV Full = Everything too bright (still no 0-15 displayed)

I tried all 4 combination with this test video: http://www.avsforum.com/forum/139-display-calibration/948496-avs-hd-709-blu-ray-mp4-calibration.html

Conclusion: Kodi is scaling everything from 16-235 to 0-255! (aka “Full”)
That’s why there should be a “use limited video levels” toggle in the System -> Video Output settings (yeah, I set it to Expert!) - but I dont have it on RPi3 + OSMC 2016.09-1 with Kodi 16.1

RGB mode can be set in config.txt. Pi is very different to Intel HW, and does not use VAAPI for decoding.

Are you talking about RPi config.txt -> hdmi_pixel_encoding? I’ve already set that, but isn’t that what would usually be the “GPU” side of things? Kodi is definitly scaling and I want to set Kodi to limited, but I don’t have the “use limited video levels” option that should be in the System -> Video Output options. (according to http://kodi.wiki/view/Video_levels_and_color_space and http://kodi.wiki/view/Settings/System_v16)

[quote=“shadow, post:1, topic:1115, full:true”]I do have expert settings level set. On my XBMCbuntu system the correct option is
system > video output > use limited colour range
I need that off on OSMC but can’t find it[/quote]
I just found this quote in an old topic.
Why is this option missing?

Has anyone checked Kodi 17 on RPi to see if the option is available there?

So I tried a Kodi 17 test build and… “use limited color range” is also missing!
Can we please get that option added back in?

You need to set it in config.txt. Then you can verify it with tvservice

I did that. The RPi hardware is set correctly. Kodi must be interfering. That’s why there should be that option in the settings.

Just to proof that RPi is set correctly. But Kodi still scales from 16-235 to 0-255. If the Video has BtB (0-15) and/or WtW (236-255) that information is lost.

Having the same issue here. The missing option within kodi itself is different from setting the actual gpu of the pi
Both the gpu and and tv are setup correctly, but because of this missing setting its crushing blacks really bad.

Would be a big help to get this option back. Or some hint as to where we could change this manually.

EDIT:

Tried changing this setting in kodi’s settings file manually, but it seems it it overwritten at start, so my guess is that it is done by osmc for some reason.

Did you stop Kodi before making the edit? This is necessary.

I did not before, thanks for the warning, but it did not work.

This is what i did:

sudo systemctl stop mediacenter

Then i changed:

<limitedrange default="true">false</limitedrange> -> <limitedrange default="true">true</limitedrange>

in the guisettings.xml

But upon reboot, it changed it back. Am i doing it wrong?

It is meant to be. 0-15 and 236-255 values in a limited range signal are illegal and should be clamped.

Why would non-Raspberry Kodi have the option “use limited color range” then?
I want Kodi Limited -> RPi Full -> TV Limited like described here: http://kodi.wiki/view/Video_levels_and_color_space

P.S.: I tried LibreELEC Kodi 16 and Kodi 17 and the option is missing on both of them too.
Another P.S.: Got an explanation here http://forum.kodi.tv/showthread.php?tid=269814&pid=2434038#pid2434038

Hi,

To calibrate properly a HDTV with à HD calibration disc it’s importants that TV could “see and show” blacker than black and whiter than white colors.
In order to do that, the full chain from reader (OSMC Kodi), GPU, TV must be setup correctly.
The correct setup should be done as explain in : http://kodi.wiki/view/Video_levels_and_color_space.
The only problem that make it impossible with OSMC is that (like Korrigan said) the option : system > video output > use limited colour range , dos not exist on the GUI.

I can understand that for some reasons developpers don’t want to put this option on the GUI but :
Is there a way for people who want to test this option to do it ?
Even if we have to edit guisettings.xml or any other settings files at our own risk?

After stop the mediacenter with :
sudo systemctl stop mediacenter

I tried to modify the guisetings.xml like this
<limitedrange default="true">true</limitedrange>
but It cames back after reboot to :
<limitedrange default="true">false</limitedrange>
So I tried :
<limitedrange>true</limitedrange>
It stays after reboot but it seems that it’s not working.
Is this the right method?
Do I have to write somethings in advanced settings ?
Or is it simply impossible to do ?

Ok after more time searching and trying to understand I think I hundersand (not sure :blush: )…
No need to set anything to full, TV is done for limited, that’s the point.
But : to calibrate TV’s brightness, some blurays or files contain BtB and WtW, and I read on : http://referencehometheater.com/2014/commentary/rgb-full-vs-limited/

What about Superwhite mode on a PS3 or PS4?
A: Superwhite enables YCbCr values over 235 (or 240 in the case of Y)
to be displayed < … >It doesn’t expand the dynamic range, it just allows
values greater than the usual peak to pass through.

popcornmix said :

It is meant to be. 0-15 and 236-255 values in a limited range signal are illegal and should be clamped.

Is there a way not to clamp them with a “Superwhite and superblack OSMC mode” :wink: ?

If I understand correctly he meant that OSMC looks at the video information (it should say if it has superwhite/black or not) and then sets the range accordingly.
I’m still not sure why the option to set it manually was ever removed though… (because I and some others would want to use it it seems)