No sound out via headphone jack

Hi there.
I’ve been searching the help comments and have to say I’m flummoxed.
I have the Vero 4k connected to a TV via HDMI cable - works a treat, with sound.
However, when I connect my little Creative T50 speakers to the Vero via cable to the headphone jack I still have the TV sound but can’t seem to get the sound to come from the Creatives. [I have checked I’m using the correct jack - the one near the HDMIport.]
I know this is a setting some where, but try as I might I can’t locate it.
Apologies for silly question.
Also, the Creatives do not detect the Vero, when its bluetooth is on and searching. But neither does a Raspberry Pi 3, I have been given…
Thanks for your time and patience.

Settings -> System -> Audio, need to be PCM for the analogue audio to work.

While I assume the Vero would need to detect the speakers and not the other way around, or are you trying to stream to the Vero?
Have you installed the a2dp test package?

Hello fzinken
Thank you for your reply. Much appreciated. I have the audio set to PCM, but still no sound via the creatives. The Creatives are working - I had them plugged into my laptop and they were working OK. And I have paired them to my linux pc via a bluetooth dongle. No problems. Music plays.
In respect of the bluetooth. I’m trying to stream to the Creatives from the Vero.
In the Vero, I have the blue tooth turned on. I have also tried to find the Creatives with the search function - no luck.
Usually, the Creatives detect a bluetooth connection, but if not there is a butt on the right creative one can press and that usually pairs the speaker, via bluetooth. It does not seem to work.
And no, I had not installed the A2DP test package…I will do so and report.
I meant to ask…How do I bring up a terminal for the Vero 4K? I can do that in Debian/linux…but is there a page ehre that explains?
Thanks heaps fzinken and Dev & Testing for your relies and patience.

You might need a special cable as the plug is a four pin combined plug.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Hello fzinken
Thank you again for your assistance.
I have done some sleuthing - and I think you are right about my needing a special cable.
I’ll try to get the bluetooth working, as per your advice, and also buy another dongle.
Will report on how I fare.
Thanks again for your prompt replies and also patience.

Why would you buy another dongle? Vero4k build in Bluetooth is know to work quite well

Hello fzinken
I installed Bluetooth audio streaming (A2DP). Selected that under the audio settings. And also ensured Bluetooth is turned on.
Creatives still not detected - but my ubuntu machine, that has a blue tooth dongle is.
Now, the sound through the TV, via HDMI cable, has a fast popping sound - rattatatttttt.
So, what do I need to do to remove the echo… and a2dp I just installed?
When I said I would buy a dongle, I was referring to the one mentioned in the post by Sam.
Thanks for your time and for replying.

Hi there.
I would like to report my experiences regarding the sound out of the Vero 4K.
I could not get bluetooth to work - I suspect part of the problem is the blue tooth implementation in the Creative speakers I use (T50) and the dongles I have. On another (Ubuntu, up to date) PC, one of the bluetooth dongles works with the Creatives (they detect the PC - sound plays perfectly), another does not.
I installed the bluetooth, as per instructions earlier in this thread. That did not solve the problem - the Creatives were not detected; and the Creatives did not detect and pair with the Vero.
A friend brought over a USB audio card - a Creative Soundblaster Play!2. The Vero detected it and after a little experimentation, Eureka! Although the sound is about 40% attenuated - I really have to crank them up, it is very clear. [A raspberry pi does not need so much amplification via the same USB sound card.] The sound is playing from a FLAC encoded file. Bach’s Cello Suites, through the little Creatives sounds superb, as does piano (Maite Aguirre, Granados, Spanish Suite) and the St George Quintet (Elegy for Rupert Brooke). I can’t believe the sound quality.
Thank you to fzinken, and the other commenters, on this thread and other threads.

That external dongle only needed for Raspberry Pi3’s as their internal one seems to having some issue. For Vero4k the internal dongle works fine even for A2DP.

I am quite confused about your mentioning “and the Creatives did not detect and pair with the Vero”. How would you pair from the Creatives to the Vero? I assume the creatives are an audio sink, so you always would pair from the Vero to the creatives and not the otherway around.
When paring from the Vero try using with or without pin. Also if all of that fails you can try from command line using bluetoothctl.

Hi fzinken
Thank you for your message.
With my existing Ubuntu PC, bluetooth dongle in place, bluetooth on and PC visible - the Creatives pair with it by pressing a button on the Creatives - bottom RHS. They will also pair with it (without having to press the button) if you go into the bluetooth menu controls on the PC, select search - and when the Creatives appear, double click. (They do have to be powered up for thos to work.) In both cases, no password is required.
With the Vero, when the bluetooth was turned on, it could not see the Creatives; using search, it did not find the speakers. And pressing the button on the speakers, when bluetooth was enabled on the Vero, did not produce a connection.
However, whenever a bluetooth dongle was in the PC, the VERO did detect the PC (but not its name - it simply called it: ubuntu-0) - and it did pair with it, but via a pin number.
I managed to work out how to remove the bluetooth software mentioned in an earlier post - and the popping disappeared. It is now very clear, via the USB audio dongle.
Thanks for reading.