No voices on movies with AAC audio

Hi,

I’ve problemes with movies using AAC audio. I can’t hear voices…soundtrack is OK but not voices…any idea ??

Please post logs so we may review how you have configured your audio settings.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Also if you have not already done so please see the following guide on how to configure your settings.

https://osmc.tv/wiki/general/audio-hardware-and-software-configuration/

My bet is you are playing 5.1 audio through stereo speakers.

No, Vero is plug in a Onkyo TX NR535 receiver…I got this problem only with AAC…

Ok, you’ll find my log here

For the settings, i have a TCL C815 series TV ans a Onkyo TX NR535 receiver. What is the best way to connect my Vero ? With a HDMI 2.0 or HDMI 2.1 ?
Is it necessary to activate ARC on my vero 4K or not ?

Thanks !

It seems from that log you have plugged your Vero into the TV and I guess the AVR is plugged into an ARC socket on the TV. With that, you will probably only be getting stereo sent back to the AVR.

However, you do have HDMI HPD lock on so what we see in the log may not be how it’s physically connected.

Try turning HDMI HPD lock off, connect Vero to AVR and AVR to TV. With that you do not need ARC.

If you want to use ARC you will have to change the channel setting to 2.0 as that is for PCM channels and that is all that connection type supports. Also you will need to remove passthrough for HD formats as those are also not supported. Your best approach here would be to read the audio hardware and software guide I linked to above which should be informative of how you should reconfigure your setup.

Additionally you video settings are not optimal. Please see the following…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like