[Obsolete] Instructions for Viewing Live TV

Yes it is, and working :wink:

HarryL, no overclocking.

I now have Live TV with tvheadend running since my last post three weeks ago. Mainly, with the following changes:

  1. tvheadend (v4.05) from the app store does indeed work!
  2. Purchase the mpeg-2 license from raspberry pi - consider it a must have even for the pi 2. If you’re getting a black screen trying to play a channel in Live TV, this will take care of it.
  3. Get a powered usb hub - highly recommended. This solved several issues for me. Notable, a reliable 1A power for the Pi and ample power for usb devices like the Hauppauge tuner.

Thomas

Hello,

I’m new to OSMC and also quite a newbie in working with Linux & co. I want to set up tvheadend on my Raspberry Pi 2 using a Edision Optimuss DVB-C/T Stick. The drivers are installed properly and the device is recognized according to dmesg.

After several trials for about 4 days I got the server running. But I could not link my created network to the right adapter. The adapter was shown as DVB-T and not C, although connected to a cable-network. I’m not sure, if this is a driver or tvheadend-problem. So I followed this instruction. But in the browser I will be asked for user and password repeatingly. I cleared the cache, but the problem keeps. I can’t login without entering user & pw. I’m quite desperate and don’t know, how to fix this problem.

I also don’t want to set up OSMC from new, because I fear I will loose all my settings and addons, even the Backup addon is installed. But when trying to restore on openElec only 5 video addons of about 50 were restored…

Below the error log:
http://paste.osmc.io/vumeyijavo

Any help would be appreciated!

Patrick

OK, I solved my initial problem. Found my old Raspberry Pi B+ and installed a fresh OSMC on it.

Installed the Tvheadend version from the OSMC store and the driver-problem seems to have disappeared. Now I got my 2 adapters shown (DVB-C and T) and could also link the network to the right adapter.

But on scanning or demuxing for channels I get FAIL-scan results and all kinds of error messages in the log like:

2016-01-19 17:44:24.138 mpegts: 506MHz in dvbc - tuning on Silicon Labs Si2168 : DVB-C #0
2016-01-19 17:44:24.143 subscription: 0007: “scan” subscribing to mux “506MHz”, weight: 6, adapter: “Silicon Labs Si2168 : DVB-C #0”, network: “dvbc”, service: “Raw PID Subscription”
2016-01-19 17:44:28.014 linuxdvb: Unable to provide BER value.
2016-01-19 17:44:28.018 linuxdvb: Unable to provide SNR value.
2016-01-19 17:44:28.019 linuxdvb: Unable to provide UNC value.
2016-01-19 17:44:29.000 mpegts: 506MHz in dvbc - scan no data, failed
2016-01-19 17:44:29.004 subscription: 0007: “scan” unsubscribing
2016-01-19 17:44:29.006 mpegts: 0MHz in dvbc - tuning on Silicon Labs Si2168 : DVB-C #0
2016-01-19 17:44:29.018 linuxdvb: Silicon Labs Si2168 : DVB-C #0 - failed to tune [e=Invalid argument]
2016-01-19 17:44:29.019 mpegts: 530MHz in dvbc - tuning on Silicon Labs Si2168 : DVB-C #0
2016-01-19 17:44:29.024 subscription: 000A: “scan” subscribing to mux “530MHz”, weight: 6, adapter: “Silicon Labs Si2168 : DVB-C #0”, network: “dvbc”, service: “Raw PID Subscription”
2016-01-19 17:44:34.000 mpegts: 530MHz in dvbc - scan no data, failed
2016-01-19 17:44:34.007 subscription: 000A: “scan” unsubscribing

and so on…

So, what could be wrong? I didn’t install any drivers at all, because the device seems to work properly.

I’m not an expert but perhaps the signal from the aerial is not strong enough to pick up any stations? I have to say that after several months of trying, with new set-ups and different hardware I’m still experiencing poor performance from a Raspi 2 set up with tvheadend. Typical issues I am experiencing on a regular basis are

Timeshifting doesn’t work
Video and audio trying to keep up with each other makes the output sound like an old stretched tape (if you are old enough to remember this sound)!
EPG issues,
Timer issues (won’t allow me to set a timer to record a program)
occasional lock-ups

I have spent several days trying to track down the issues with no luck, so when you get around this issue you may be faced with many more! Good luck anyway!

@Slartibartfast: Thank you for your reply!
For those who face similar problems or are interested in my issues, I contacted the tech support from DVBSky sending them also my dmesg | grep -i dvb which looks like this:

osmc@osmcRaspberryPi1:~$ uname -a
Linux osmcRaspberryPi1 4.3.3-3-osmc #1 PREEMPT Sat Jan 2 00:55:57 UTC 2016 armv6l GNU/Linux
osmc@osmcRaspberryPi1:~$ dmesg | grep -i dvb
[ 2.758236] usb 1-1.5: Product: DVB-T2/C USB-Stick
[ 7.957459] usb 1-1.5: dvb_usb_v2: found a ‘DVBSky T330’ in warm state
[ 7.957785] usb 1-1.5: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[ 7.957859] DVB: registering new adapter (DVBSky T330)
[ 7.959235] usb 1-1.5: dvb_usb_v2: MAC address: 00:cc:10:a5:33:0c
[ 8.030950] usb 1-1.5: DVB: registering adapter 0 frontend 0 (Silicon Labs Si2168)…
[ 8.097186] Registered IR keymap rc-dvbsky
[ 8.097855] input: DVBSky T330 as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.5/rc/rc0/input0
[ 8.097897] rc0: DVBSky T330 as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.5/rc/rc0
[ 8.097927] usb 1-1.5: dvb_usb_v2: schedule remote query interval to 300 msecs
[ 8.097954] usb 1-1.5: dvb_usb_v2: ‘DVBSky T330’ successfully initialized and connected
[ 8.098183] usbcore: registered new interface driver dvb_usb_dvbsky
[ 29.830582] si2168 3-0064: Direct firmware load for dvb-demod-si2168-b40-01.fw failed with error -2
[ 29.830804] si2168 3-0064: Direct firmware load for dvb-demod-si2168-02.fw failed with error -2
[ 29.830837] si2168 3-0064: firmware file ‘dvb-demod-si2168-02.fw’ not found
[ 29.901024] usb 1-1.5: DVB: adapter 0 frontend 0 frequency 0 out of range (55000000…862000000)
[ 29.925862] si2168 3-0064: Direct firmware load for dvb-demod-si2168-b40-01.fw failed with error -2
[ 29.925928] si2168 3-0064: Direct firmware load for dvb-demod-si2168-02.fw failed with error -2
[ 29.925948] si2168 3-0064: firmware file ‘dvb-demod-si2168-02.fw’ not found
[ 160.579104] usb 1-1.5: DVB: adapter 0 frontend 0 frequency 0 out of range (55000000…862000000)

So, it seems the drivers were NOT installed correctly and I loaded the dvbsky-firmware. But after several restarts nothing changed.

I’m waiting for the reply from DVBSky and I will try it on another antenna tomorrow to check if it’s the weak signal.

Many thanks so far!

The antenna would (most likely) need to be a full outdoor roof mounted thingy! I tried with the tiny whip antenna’s delivered with these USB tuners and all I could get was 1 or 2 very poor stations when I was outdoors or near an open window! (I live in a city on top of a hill and tv reception from the roof is good). Also, beware of antenna splitters, every 2:1 joint and you loose 50% of the signal!

YESSS! After I installed the missing drivers

  • dvb-demod-si2168-b40-01.fw
  • dvb-demod-si2168-01.fw
  • dvb-demod-si2168-02.fw

from here: http://palosaari.fi/linux/v4l-dvb/firmware/Si2168 and copied them into /lib/firmware I tried the second cable plug (no antenna) and used a powered USB-hub. Now I get the channels under services!
What a procedure. Now I will determine which constellation caused the problem and which issues the Pi will have on the long term. I will keep you informed.

Thank you for your advices!

@sam_nazarko might want to include those firmware files in the image?

On the list

Sam

Hi,
I am trying to set Live TV on my RasPi. I have followed the instructions but in the end when i look into TVheadend, there´s no device under TV Adapter tab. When i checked with lsusb command it shows me this device - Integrated Technology Express, Inc. IT9135 BDA Afatech DVB-T HDTV Dongle. So i have downloaded IT9135 firmware (dvb-usb-it9135-01.fw and dvb-usb-it9135-02.fw appeared in /lib/firmware) restarted RasPi but still no success.

https://www.amazon.de/gp/aw/d/B0035NFW8Y/ref=oh_aui_i_sh_pre_o0_img?ie=UTF8&psc=1

Anyone have this?

thank you thank you! been looking for a solution to this everywhere

I bought a Vero 4K and the DVB dongle from the store, do I need to follow all these steps also? I was under the assumption that I’d be able to set things up using just the Vero itself, that I didn’t need to do it on my desktop PC.

No you don’t need to follow all these steps as most is already taken care of. But you would need to install tvheadend server (from app store) and then to configure the channels you would need a browser (pc, smartphone, tablet,…)

I don’t have an option to enable it here. Any ideas?

You need Settings->Add-on browser->My Add-ons->PVR clients->TVheadend HTSP Client these days.

Ah, thank you

thanks for your nice sharing!

Glad you got it working but this thread is very old. Newer instructions here: Watching live TV with a USB DVB tuner or network TV tuner