[Obsolete] Instructions for Viewing Live TV


#22

I have deleted my previous post owing to the fact i’m an idiot and missed out lines but I am still unable to make

osmc@osmc:/usr/src$ tar zxvf dvbhdhomerun_0.0.15.tar.gz

dvbhdhomerun-0.0.15/
dvbhdhomerun-0.0.15/COPYING
dvbhdhomerun-0.0.15/kernel/
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_init.h
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_control_messages.h
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_control.h
dvbhdhomerun-0.0.15/kernel/do.sh
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_core.h
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_compat.h
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_data.c
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_data.h
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_debug.h
dvbhdhomerun-0.0.15/kernel/Makefile
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_fe.c
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_control.c
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_init.c
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_core.c
dvbhdhomerun-0.0.15/kernel/.cvsignore
dvbhdhomerun-0.0.15/kernel/dvb_hdhomerun_fe.h
dvbhdhomerun-0.0.15/build.txt
dvbhdhomerun-0.0.15/debian/
dvbhdhomerun-0.0.15/debian/dvbhdhomerun-utils.upstart
dvbhdhomerun-0.0.15/debian/README.Debian
dvbhdhomerun-0.0.15/debian/control
dvbhdhomerun-0.0.15/debian/watch
dvbhdhomerun-0.0.15/debian/dvbhdhomerun.lintian.override
dvbhdhomerun-0.0.15/debian/copyright
dvbhdhomerun-0.0.15/debian/rules.modules
dvbhdhomerun-0.0.15/debian/install
dvbhdhomerun-0.0.15/debian/rules
dvbhdhomerun-0.0.15/debian/changelog
dvbhdhomerun-0.0.15/debian/docs
dvbhdhomerun-0.0.15/debian/dvbhdhomerun-utils.udev
dvbhdhomerun-0.0.15/debian/dvbhdhomerun-utils.logrotate
dvbhdhomerun-0.0.15/debian/dvbhdhomerun-dkms.dkms
dvbhdhomerun-0.0.15/debian/control.modules.in
dvbhdhomerun-0.0.15/debian/dvbhdhomerun-dkms.preinst
dvbhdhomerun-0.0.15/debian/compat
dvbhdhomerun-0.0.15/old/
dvbhdhomerun-0.0.15/old/dvbhdhomerun.c
dvbhdhomerun-0.0.15/v4l-dvb/
dvbhdhomerun-0.0.15/v4l-dvb/hdhomerun/
dvbhdhomerun-0.0.15/v4l-dvb/hdhomerun/Makefile
dvbhdhomerun-0.0.15/v4l-dvb/hdhomerun/Kconfig
dvbhdhomerun-0.0.15/v4l-dvb/dvbhdhomerun_s2_liplianin.patch
dvbhdhomerun-0.0.15/v4l-dvb/readme_s2_liplianin.txt
dvbhdhomerun-0.0.15/v4l-dvb/readme.txt
dvbhdhomerun-0.0.15/v4l-dvb/make_links.sh
dvbhdhomerun-0.0.15/v4l-dvb/frontend/
dvbhdhomerun-0.0.15/v4l-dvb/frontend/.cvsignore
dvbhdhomerun-0.0.15/readme.txt
dvbhdhomerun-0.0.15/userhdhomerun/
dvbhdhomerun-0.0.15/userhdhomerun/thread_pthread.h
dvbhdhomerun-0.0.15/userhdhomerun/CMakeLists.txt
dvbhdhomerun-0.0.15/userhdhomerun/hdhomerun_tuner.cpp
dvbhdhomerun-0.0.15/userhdhomerun/hdhomerun_controller.h
dvbhdhomerun-0.0.15/userhdhomerun/conf_inifile.cpp
dvbhdhomerun-0.0.15/userhdhomerun/config.h.in
dvbhdhomerun-0.0.15/userhdhomerun/log_file.h
dvbhdhomerun-0.0.15/userhdhomerun/conf_inifile.h
dvbhdhomerun-0.0.15/userhdhomerun/thread_pthread.cpp
dvbhdhomerun-0.0.15/userhdhomerun/main.cpp
dvbhdhomerun-0.0.15/userhdhomerun/hdhomerun_control.h
dvbhdhomerun-0.0.15/userhdhomerun/hdhomerun_controller.cpp
dvbhdhomerun-0.0.15/userhdhomerun/log_file.cpp
dvbhdhomerun-0.0.15/userhdhomerun/hdhomerun_tuner.h
dvbhdhomerun-0.0.15/userhdhomerun/Makefile
dvbhdhomerun-0.0.15/userhdhomerun/hdhomerun_control.cpp
dvbhdhomerun-0.0.15/userhdhomerun/.cvsignore
dvbhdhomerun-0.0.15/patches/
dvbhdhomerun-0.0.15/patches/ashh65_use_select_userhdhomerun.patch
dvbhdhomerun-0.0.15/patches/ashh65_signal_handling.patch
dvbhdhomerun-0.0.15/patches/ashh65_select_sup_kernel.patch
dvbhdhomerun-0.0.15/patches/evalette-patch-dvb-5_5_api.diff
dvbhdhomerun-0.0.15/AUTHORS
dvbhdhomerun-0.0.15/.cvsignore
dvbhdhomerun-0.0.15/todo.txt
dvbhdhomerun-0.0.15/etc/
dvbhdhomerun-0.0.15/etc/dvbhdhomerun

osmc@osmc:/usr/src$ cd /usr/src/dvbhdhomerun-0.0.15/userhdhomerun

osmc@osmc:/usr/src/dvbhdhomerun-0.0.15/userhdhomerun$ make
-bash: make: command not found
osmc@osmc:/usr/src/dvbhdhomerun-0.0.15/userhdhomerun$

I have also tried to sudo it and still getting this
osmc@osmc:/usr/src/dvbhdhomerun-0.0.15/userhdhomerun$ sudo osmc@osmc:/usr/src/dvbhdhomerun-0.0.15/userhdhomerun$
sudo: osmc@osmc:/usr/src/dvbhdhomerun-0.0.15/userhdhomerun$: command not found
osmc@osmc:/usr/src/dvbhdhomerun-0.0.15/userhdhomerun$

HELP! :frowning:


#23

Sorry binaryangel0100 I’m not experienced enough to be able to help you. Hopefully one of the hdhomerun users will come along with some suggestions how to correct my notes. If not, perhaps a PM to HarryL would get you some help.

EMJB


#24

you need to install the dependencies…

  1. Build/install Tvheadend Server

As of 6/4/2015, I have been unable to get the App Store versions to work, so by courtesy of @HarryL have compiled & installed the latest github version using the following commands via putty & SSH {user = osmc, password= osmc}:

sudo -s

apt-get update

apt-get install git build-essential pkg-config libssl-dev dvb-firmware-osmc dvb-tools libdvbv5-0 liburiparser-dev liburiparser1 libavahi-client-dev zlib1g-dev libavcodec-dev libavutil-dev libavformat-dev libswscale-dev

adding libhdhomerun-dev libhdhomerun1 hdhomerun-config cmake to the last command for hdhomerun network tuners.


USB DVB-T dongle not correctly recognized
#25

This is a great post as it seems to get TV backend working on a RPi…however whilst watching TV seems ok I am experiencing issues which make it a bit unusable. I’m not too sure where the issues lie but I thought I’d post my thoughts here.

  1. TV headend timeshifting. I can not get this to work as (I think) it should.

    1.1) Pausing and Restarting timeshifting - This will cause the playback to halt (frozen picture no audio) after a few seconds. On searching this has been experienced by other users - the solution (a work-around) is to check the “Unlimited size” checkbox. The Max Size 1808 Mb greys out and you can pause and restart without error. I’m guessing the issue is with the osmc/kodi frontend as tvheadend seems to continue working throughout.

    1.2) FF or RW in timeshifting is unpredictable. Sometimes it does something, sometimes it freezes. I have found no solution.

  2. DVR - Recording seems problematical too.

    2.1) There does not seem to be any conflict resolution. For instance watching tv and a recording is scheduled - on my single tuner the tv just halts, and osmc reports “Disconnected from HTS tvheadend”. This is not what i’d expect of a PVR.

    2.2) On the Add timer I don’t seem to be able to add one (there is a sruck out circle to the left hand side of the words “Add timer” but when I fill in the details there is no save or create button at the bottom, thus no timer is created and no recording occurs.

2.3) I have added an external HDD (which was mounted automatically - great) I changed the location for recording under Configuration > Recording >Digital Video Recorder Profiles. It seems to work but I have had random disconnects with the front end reporting “Cannot stat (sic) the path” as soon as I change it back to /home/osmc the fault goes away.

Anyway after 3 dyas of several clean reinstalls (on a RPi B+) I’m ready to give up!


#26

so in the section pertaining to the HDHomeRun, you have a build of a sourceforge project for “DVB”… I’m in the U.S. and we use ATSC. So, the question is, do you (or anyone reading this) know if i need an equivalent ATSC “thing” in place of the aforementioned DVB “thing”?

And if anyone can explain what this “thing” is, i’d be greatful.

I know that the HDHomeRun unit itself requires a library of API functions (the libhdhomerun-dev package installation), but i’m confused about the dvbhdhomerun “package” (if that’s what it is)


#27

Are you sure it’s not a permissions issue? I ended up giving full permissions to all users for the recording and timeshift buffer folders and I haven’t had any issues (knock on wood).


#28

Hi everyone,

I am new with osmc and I followed all the instructions listed above. I successfully launched the TVheadend from my pc and configure a network from the configurations. I am now seeing all the muxes with scan status “PEND”. However, I am not able to see any TV adapter from the given list. There is no device and I could not figure out how to find my device.

Can you please help me on this?

Thank you,


#29

hi @talip ;-),

What tuner model/nr a you using, and if USB have you try’d using a USB HUB with it?..


#31

I tried following your instructions but get the following errors (step 5 (building tvheadend server):

osmc@osmc:/usr/src/tvheadend$ ./configure
Checking support/features
checking for cc execinfo.h … ok
checking for cc -mmmx … fail
checking for cc -msse2 … fail
checking for cc -Wunused-result … ok
checking for cc getloadavg … ok
checking for cc atomic64 … ok
checking for cc lockowner … ok
checking for cc qsort_r … ok
checking for cc stime … ok
checking for cc recvmmsg … ok
checking for cc sendmmsg … ok
checking for cc libiconv … fail
checking for cc libdvben50221 … fail
checking for py module gzip … ok
checking for xgettext … fail
ERROR: WARN: no gettext binaries found

I’m using OSMC RC3 0.9.9 (May 23 build). From the App Store, I’m able to install v3.9.0-10 but get this error: “Jun 24 15:04:38.009 linuxdvb: /dev/dvb/adapter0/frontend0 - failed to tune [e=Invalid argument]”. I’ve started with a new install of OSMC and then install/uninstall from App Store couple of time without success.


#32

i managed to get past the gettext error by installing it with command:
apt-get gettext

configure continues but still failing. Next item to error out is DVB scan files path fails. How to fix this? I tried many attempts and lots of googling but to no avail. I did however to succeed by installing another copy of tvheadend following an old thread “Live TV on Pi with Tvheadend (all running on one Pi) Updated - 24/9/12”:

cd ~
git clone https://github.com/tvheadend/tvheadend
cd tvheadend
./configure
make
sudo make install

It’s not all smooth though. I can run tvheadend with command:
tvheadend -C

and get to the web interface at http://x.x.x.x:9981. I can get through step 6 but in step 7, I do not get small message about loading channels so no “TV” added to top menu. Also, running above command, my pi freezes and I have to do a hard power off and on to restart.


#33

Hi Thomas

Can I suggest you try a fresh install. This time do not try and load tvheadend from within osmc and come straight to these instructions to load it manually. Also, to get the TV option to appear on the menu try adding the PVR service (step 7 above I think) a second time. It is bizarre but this is often required.

I have also found it useful to take a disk image of your install regularly (like taking a backup), so if you want to do a fresh install you don’t have to return to the beginning every time. This can save hours of frustration!

Unfortunately if you do get tvheadend working you may be a bit underwhelmed by the timeshifting function. It is very flaky which is not good as it is a core function that I like to use daily. Clearly, a great deal of hard work has been done by the OSMC/tvheadend software bods but the live TV function is not as slick as I would like it to be.


#34

Hi Slartibartfast,

I did a fresh install like you suggested. I now have everything working except still no live TV. I have tvheadend v4.1-307 running, configured, and Kodi showing some of my TV channels. When I click on a channel, the Buffering pop up message sometimes goes to 100% then Playing and sometimes 0%. Either way no live TV. See tvheadend log below:

I am not sure if I maybe got hardware, firmware, mis-configuration, etc. issues. I don’t have a powered hub at the moment. When I had it plugged direct to the pi it hung up system. I now have it plugged to my Dell U3014 no more crashes but not sure if I got enough power driving it. Also, appreciate if someone can tell me how to test my setup (e.g., wscan?)

Thomas

osmc@osmc:~$ tvheadend -C
2015-06-27 12:01:08.825 [ INFO] main: Log started
2015-06-27 12:01:08.920 [ INFO] config: loaded
2015-06-27 12:01:14.182 [ INFO] scanfile: DVB-T - loaded 43 regions with 729 networks
2015-06-27 12:01:14.187 [ INFO] scanfile: DVB-S - loaded 1 regions with 92 networks
2015-06-27 12:01:14.191 [ INFO] scanfile: DVB-C - loaded 16 regions with 51 networks
2015-06-27 12:01:14.192 [ INFO] scanfile: ATSC - loaded 2 regions with 14 networks
2015-06-27 12:01:17.874 [ INFO] linuxdvb: adapter added /dev/dvb/adapter0
2015-06-27 12:01:17.890 [ INFO] linuxdvb: adapter 0 setting exlusive flag
2015-06-27 12:01:17.943 [ INFO] dvr: Creating new configuration ''
2015-06-27 12:01:17.954 [ INFO] CSA: Using 32bit parallel descrambling
2015-06-27 12:01:17.965 [ INFO] epggrab: module eit created
2015-06-27 12:01:17.973 [ INFO] epggrab: module uk_freesat created
2015-06-27 12:01:17.979 [ INFO] epggrab: module uk_freeview created
2015-06-27 12:01:17.979 [ INFO] epggrab: module viasat_baltic created
2015-06-27 12:01:18.120 [ INFO] epggrab: module opentv-ausat created
2015-06-27 12:01:18.129 [ INFO] epggrab: module opentv-skyuk created
2015-06-27 12:01:18.135 [ INFO] epggrab: module opentv-skynz created
2015-06-27 12:01:18.138 [ INFO] epggrab: module opentv-skyit created
2015-06-27 12:01:18.173 [ INFO] epggrab: module pyepg created
2015-06-27 12:01:18.182 [ INFO] epggrab: module xmltv created
2015-06-27 12:01:18.247 [ INFO] epgdb: loaded v2
2015-06-27 12:01:18.247 [ INFO] epgdb: config 1
2015-06-27 12:01:18.247 [ INFO] epgdb: channels 0
2015-06-27 12:01:18.247 [ INFO] epgdb: brands 0
2015-06-27 12:01:18.247 [ INFO] epgdb: seasons 0
2015-06-27 12:01:18.247 [ INFO] epgdb: episodes 0
2015-06-27 12:01:18.247 [ INFO] epgdb: broadcasts 0
2015-06-27 12:01:18.281 [ NOTICE] START: HTS Tvheadend version 4.1-307~ga383bac-dirty started, running as PID:545 UID:1000 GID:1000, CWD:/home/osmc CNF:/home/osmc/.hts/tvheadend
2015-06-27 12:01:18.293 [ INFO] mpegts: 689MHz in OTA Antenna - tuning on Auvitek AU8522 QAM/8VSB Frontend : ATSC #0
2015-06-27 12:01:18.323 [ INFO] subscription: 0001: “scan” subscribing to mux “689MHz”, weight: 5, adapter: “Auvitek AU8522 QAM/8VSB Frontend : ATSC #0”, network: “OTA Antenna”, service: "Raw PID Subscription"
2015-06-27 12:01:18.359 [ INFO] htsp: Got connection from 127.0.0.1
2015-06-27 12:01:18.384 [ INFO] htsp: 127.0.0.1: Welcomed client software: XBMC Media Center (HTSPv8)
2015-06-27 12:01:18.387 [ INFO] htsp: 127.0.0.1 [ XBMC Media Center ]: Disconnected
2015-06-27 12:01:19.112 [ INFO] htsp: Got connection from 127.0.0.1
2015-06-27 12:01:19.117 [ INFO] htsp: 127.0.0.1: Welcomed client software: XBMC Media Center (HTSPv8)
2015-06-27 12:01:19.483 [ INFO] AVAHI: Service ‘Tvheadend’ successfully established.
2015-06-27 12:01:23.003 [ INFO] mpegts: 689MHz in OTA Antenna - scan complete
2015-06-27 12:01:23.010 [ INFO] subscription: 0001: “scan” unsubscribing
2015-06-27 12:01:23.020 [ INFO] mpegts: 647MHz in OTA Antenna - tuning on Auvitek AU8522 QAM/8VSB Frontend : ATSC #0
2015-06-27 12:01:23.047 [ INFO] subscription: 0003: “scan” subscribing to mux “647MHz”, weight: 5, adapter: “Auvitek AU8522 QAM/8VSB Frontend : ATSC #0”, network: “OTA Antenna”, service: "Raw PID Subscription"
2015-06-27 12:01:24.221 [WARNING] linuxdvb: Auvitek AU8522 QAM/8VSB Frontend : ATSC #0 - poll TIMEOUT
2015-06-27 12:01:28.003 [ INFO] mpegts: 647MHz in OTA Antenna - scan no data, failed
2015-06-27 12:01:28.010 [ INFO] subscription: 0003: “scan” unsubscribing
2015-06-27 12:01:28.020 [ INFO] mpegts: 731MHz in OTA Antenna - tuning on Auvitek AU8522 QAM/8VSB Frontend : ATSC #0
2015-06-27 12:01:28.043 [ INFO] subscription: 0005: “scan” subscribing to mux “731MHz”, weight: 5, adapter: “Auvitek AU8522 QAM/8VSB Frontend : ATSC #0”, network: “OTA Antenna”, service: "Raw PID Subscription"
2015-06-27 12:01:28.487 [ INFO] mpegts: 593MHz in OTA Antenna - tuning on Auvitek AU8522 QAM/8VSB Frontend : ATSC #0
2015-06-27 12:01:28.496 [ INFO] subscription: 0005: “scan” unsubscribing
2015-06-27 12:01:28.524 [ INFO] subscription: 0007: “127.0.0.1 [ XBMC Media Center ]” subscribing on channel “KFSF-HD”, weight: 150, adapter: “Auvitek AU8522 QAM/8VSB Frontend : ATSC #0”, network: “OTA Antenna”, mux: “593MHz”, service: “KFSF-HD”, profile=“htsp”, hostname=“127.0.0.1”, username=“127.0.0.1”, client="XBMC Media Center"
2015-06-27 12:01:33.003 [ INFO] mpegts: 593MHz in OTA Antenna - scan complete
2015-06-27 12:03:06.828 [ INFO] subscription: 0007: “127.0.0.1 [ XBMC Media Center ]” unsubscribing from “KFSF-HD”, hostname=“127.0.0.1”, username=“127.0.0.1”, client="XBMC Media Center"
2015-06-27 12:03:06.851 [ INFO] mpegts: 563MHz in OTA Antenna - tuning on Auvitek AU8522 QAM/8VSB Frontend : ATSC #0
2015-06-27 12:03:06.884 [ INFO] subscription: 0009: “127.0.0.1 [ XBMC Media Center ]” subscribing on channel “KPIX-TV”, weight: 150, adapter: “Auvitek AU8522 QAM/8VSB Frontend : ATSC #0”, network: “OTA Antenna”, mux: “563MHz”, service: “KPIX-TV”, profile=“htsp”, hostname=“127.0.0.1”, username=“127.0.0.1”, client="XBMC Media Center"
2015-06-27 12:03:11.000 [ INFO] mpegts: 563MHz in OTA Antenna - scan complete

2015-06-27 12:05:54.566 [ INFO] subscription: 0004: “127.0.0.1 [ XBMC Media Center ]” unsubscribing from “KSTS-HD”, hostname=“127.0.0.1”, username=“127.0.0.1”, client="XBMC Media Center"
2015-06-27 12:05:54.580 [ INFO] mpegts: 563MHz in OTA Antenna - tuning on Auvitek AU8522 QAM/8VSB Frontend : ATSC #0
2015-06-27 12:05:54.611 [ INFO] subscription: 0006: “127.0.0.1 [ XBMC Media Center ]” subscribing on channel “KPIX-TV”, weight: 150, adapter: “Auvitek AU8522 QAM/8VSB Frontend : ATSC #0”, network: “OTA Antenna”, mux: “563MHz”, service: “KPIX-TV”, profile=“htsp”, hostname=“127.0.0.1”, username=“127.0.0.1”, client="XBMC Media Center"
2015-06-27 12:05:55.771 [WARNING] linuxdvb: Auvitek AU8522 QAM/8VSB Frontend : ATSC #0 - poll TIMEOUT
2015-06-27 12:06:00.002 [WARNING] subscription: 0006: service instance is bad, reason: No input detected
2015-06-27 12:06:04.000 [ NOTICE] subscription: 0006: No input source available for subscription “127.0.0.1 [ XBMC Media Center ]” to channel “KPIX-TV”


#35

Hi Thomas

I’m not good with the logs - I don’t have the expereience to comment. However you seem to have got further this time at least!!

A couple of points on power for the Raspberyy Pi - how many devices have you got connected to the usb ports and how are you powering the Pi? It is all but essential to run a RPi from a dedicated 5V 2amp. It sounds like you might have been trying to run the RPi from a usb port on your computer. This is not recommended at all. Random reboots and usb disconnects are a symptom of a failing power supply. With the RPi 2 the designers have added a feature to show when the USB votage dips to an unacceptable level. When this happens you will see a raibow coloured small square box appear inthe top right hand corner of the screen.

My setup has 3 devices connected to the USB ports

  1. Wifi Dongle
  2. USB Dual tv tuner
  3. USB Disk drive (WD my passport 1TB)

I have managed to run a RPi 2 from a 5v power source and connect these 3 usb deviced directly to it BUT it is not easy and I had to make these modifications

The 1st modification was this

  1. Link to Hackaday post

ths is a hardware modification and requires some skill to do. Don’t attempt unless you are competant with a soldering iron!!!

  1. I found that the 5v lead from the power supply had a significant volts drop accross it. I therefore made my own very short lead with nice thick red and black wire.

I run my system from a solar/battery 12v supply hence the DC-DC converter on the right hand side of the photo. Hopefully you get the idea though.

Separate from the power supply issues have you been able to watch and live tv from within the browser window of your computer? Also have you loaded up the mpeg 2 licence inside osmc? Lack of this licence is characterised by sound but no video. This doesn’t sound like your problem but it managed to trip me up on my 1st install attempt!

Good luck in getting further…


#36

Hi Slartibartfast,

Thanks for showing me the cool hacks. I had my Pi B sitting on my shelf for a year and just started tinkering with it. I have always been an XBMC fan modding the original XBOX and trying to get Kodi (with Live TV) up running would be first thing on my mind. I would love to do the Hackaday power upgrade when I get a chance.

To further troubleshoot my Hauppauge WinTV-HVR-950Q:

  • Took 950Q and installed it to my Windows 7 PC. Fired up Windows Media Center and verified everything working. Observed blue light on unit when connected and green light if streaming live TV.
  • On the Pi:
  • lsmod - check firmware shows up
  • modinfo xc5000 - check driver version
  • dmesg - confirmed firmware running “[ 1490.110315] xc5000: Firmware dvb-fe-xc5000-1.6.114.fw loaded and running.”
  • noticed as I write this: “[ 1490.111748] usb 1-1.2.1: DVB: adapter 0 frontend 0 frequency 0 out of range (54000000…858000000)
  • femon -H - tuning status good reporting “status SCVYL | signal 71% | snr 0% | ber 0 | unc 0 | FE_HAS_LOCK”

I still have no live TV. After all the troubleshooting, I am thinking I’ve got something misconfigured somewhere. Oh, I tried playing from browser and nothing. That tells me it’s not Kodi.

As for power…
Hardware seems okay except the random system hang ups after awhile with “tvheadend -C”. Hang up probably due to using the 950Q on my Dell U3014 USB ports since I don’t have a powered hub at the moment. My Pi is powered by a 5V 2A power adapter with just the Lenovo Mini Wireless Keyboard attached.

Thomas


#37

Are you overclocking you pi?, i would recommend that you use an USB hub, i think the problem is power and you tuner… i have found my wireless keyboard use to much also like a few hundred mAmps.
.


#38

Ain’t tvheadend available in OSMC App store?
I installed it from there and it’s working fine.


#39

Yes it is, and working :wink:


#40

HarryL, no overclocking.

I now have Live TV with tvheadend running since my last post three weeks ago. Mainly, with the following changes:

  1. tvheadend (v4.05) from the app store does indeed work!
  2. Purchase the mpeg-2 license from raspberry pi - consider it a must have even for the pi 2. If you’re getting a black screen trying to play a channel in Live TV, this will take care of it.
  3. Get a powered usb hub - highly recommended. This solved several issues for me. Notable, a reliable 1A power for the Pi and ample power for usb devices like the Hauppauge tuner.

Thomas


#41

Hello,

I’m new to OSMC and also quite a newbie in working with Linux & co. I want to set up tvheadend on my Raspberry Pi 2 using a Edision Optimuss DVB-C/T Stick. The drivers are installed properly and the device is recognized according to dmesg.

After several trials for about 4 days I got the server running. But I could not link my created network to the right adapter. The adapter was shown as DVB-T and not C, although connected to a cable-network. I’m not sure, if this is a driver or tvheadend-problem. So I followed this instruction. But in the browser I will be asked for user and password repeatingly. I cleared the cache, but the problem keeps. I can’t login without entering user & pw. I’m quite desperate and don’t know, how to fix this problem.

I also don’t want to set up OSMC from new, because I fear I will loose all my settings and addons, even the Backup addon is installed. But when trying to restore on openElec only 5 video addons of about 50 were restored…

Below the error log:
http://paste.osmc.io/vumeyijavo

Any help would be appreciated!

Patrick


#42

OK, I solved my initial problem. Found my old Raspberry Pi B+ and installed a fresh OSMC on it.

Installed the Tvheadend version from the OSMC store and the driver-problem seems to have disappeared. Now I got my 2 adapters shown (DVB-C and T) and could also link the network to the right adapter.

But on scanning or demuxing for channels I get FAIL-scan results and all kinds of error messages in the log like:

2016-01-19 17:44:24.138 mpegts: 506MHz in dvbc - tuning on Silicon Labs Si2168 : DVB-C #0
2016-01-19 17:44:24.143 subscription: 0007: “scan” subscribing to mux “506MHz”, weight: 6, adapter: “Silicon Labs Si2168 : DVB-C #0”, network: “dvbc”, service: "Raw PID Subscription"
2016-01-19 17:44:28.014 linuxdvb: Unable to provide BER value.
2016-01-19 17:44:28.018 linuxdvb: Unable to provide SNR value.
2016-01-19 17:44:28.019 linuxdvb: Unable to provide UNC value.
2016-01-19 17:44:29.000 mpegts: 506MHz in dvbc - scan no data, failed
2016-01-19 17:44:29.004 subscription: 0007: “scan” unsubscribing
2016-01-19 17:44:29.006 mpegts: 0MHz in dvbc - tuning on Silicon Labs Si2168 : DVB-C #0
2016-01-19 17:44:29.018 linuxdvb: Silicon Labs Si2168 : DVB-C #0 - failed to tune [e=Invalid argument]
2016-01-19 17:44:29.019 mpegts: 530MHz in dvbc - tuning on Silicon Labs Si2168 : DVB-C #0
2016-01-19 17:44:29.024 subscription: 000A: “scan” subscribing to mux “530MHz”, weight: 6, adapter: “Silicon Labs Si2168 : DVB-C #0”, network: “dvbc”, service: "Raw PID Subscription"
2016-01-19 17:44:34.000 mpegts: 530MHz in dvbc - scan no data, failed
2016-01-19 17:44:34.007 subscription: 000A: “scan” unsubscribing

and so on…

So, what could be wrong? I didn’t install any drivers at all, because the device seems to work properly.