Official display not working in raspberry pi 4

Hi everybody,

I just flashed last OSMC version in my raspi4 and it’s only working with HDMI… No matter what I do.

Once I boot official display it’s working, showing splash image and later it switches to hdmi, the funny thing is the touch screen is working :neutral_face: .

If I switch sd card to another distro (arch, raspbian… ) it’s working flawless.

So any idea bout how to disable HDMI and use official 7" display (at this point my configs.txt are a complete mess?

Thx in advance.


There’s a bug which prevents headless (no HDMI) booting. You can resolve it by installing an update.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Hi sam,

thank you for your help. Updated with buster-devel, rebooted but same behavior :frowning: is there anything I should add (or deleted from config.txt) I changed many things there…

You shouldn’t need to customise config-user.txt at all, and you shouldn’t edit config.txt at all.

I tried to restore it, currently I have:


include config-user.txt

But still no luck.

Unfortunately I don’t have a Pi touchscreen to verify at my end.

Ok, somehow I ended in this link: [TESTING] Kodi v19 builds for Raspberry Pi 2/3/4 - #265 by grahamh


And changed that line in config.txt… Don’t know if it will help or what exactly I was changing but now the display is working…

I guess next upgrade could potentially overwrite my config.txt

Yes – it could.

You could put it in config-user.txt, but I don’t know if that option will supersede the config.txt option properly.