Official Pi Wifi dongle not working on Pi2/Stable

I recently purchased the Official Pi WiFi adapter, specifically this one and today I connected this to my Pi2 which is running the very latest Stable release of OSMC.

Just for good measure I rebooted after connecting the device and ran a further update using the command line:

sudo apt-get update -y --force-yes
sudo apt-get upgrade -y --force-yes
sudo apt-get dist-upgrade -y --force-yes

This did not find any new updates and the I then further rebooted the Pi2.

I then navigated to the OSMC Settings however the WiFi option was not visible, only Wired.

I then ran dmesg in ssh and can see, I believe, that the adapter is connected?

[    2.385372] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-bcm2708_usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:a2:b8:41
[    2.461408] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[    2.564320] usb 1-1.2: New USB device found, idVendor=0a5c, idProduct=bd1e
[    2.564353] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.564369] usb 1-1.2: Product: Remote Download Wireless Adapter
[    2.564385] usb 1-1.2: Manufacturer: Broadcom
[    2.564400] usb 1-1.2: SerialNumber: 000000000001

So I am now unsure how to proceed, do I need to manually install a driver for the Official Pi adapter?

Any help will be appreciated.

I believe that adaptor is not currently supported in OSMC (due to it having new vendor and device ID’s that are not recognised) but Sam intends to add support for it soon.

1 Like

Thank for the info.

Just out of interest, back in March Sam commented on this post to say that it would be supported in the next version. Since we have had a few versions since March, is it possible that it has been missed off? Or that we have a problem with it?

Can Sam confirm?

Thanks again!

Just to bump this - it’s still not working for me. Oversight or on-going problems with driver?

Support will come for this unit when Isengard is released as part of the July update. This is expected to be mere days away.


Hi Sam,

I have updated to Isengard, but unfortunately my adapter is still not working or being recognised.

Did it make the update? Or is something else wrong that I need to check.


You have not updated to Isengard… OSMC has not made Isengard available.