OSCM August 2021 update not installing

I tried updating my OSMC today without avail.
When I try updating manually via UI, for a fraction of a second after trying to download 1/4 components is shows “Connectivity issues…”

When trying downloading manually from the console using
sudo apt-get update
It gives:

Get:1 http://security.debian.org buster/updates InRelease [65.4 kB]
Get:2 Index of /debian buster InRelease [122 kB]
Get:4 Index of /debian buster-updates InRelease [51.9 kB]
Hit:3 Index of /osmc/osmc/apt buster InRelease
Reading package lists… Done
E: Repository ‘http://security.debian.org buster/updates InRelease’ changed its ‘Suite’ value from ‘stable’ to ‘oldstable’
N: This must be accepted explicitly before updates for this repository can be ap plied. See apt-secure(8) manpage for details.
N: Repository ‘Index of /debian buster InRelease’ changed its ‘Versi on’ value from ‘10.7’ to ‘10.10’
E: Repository ‘Index of /debian buster InRelease’ changed its 'Suite ’ value from ‘stable’ to ‘oldstable’
N: This must be accepted explicitly before updates for this repository can be ap plied. See apt-secure(8) manpage for details.
E: Repository ‘Index of /debian buster-updates InRelease’ changed it s ‘Suite’ value from ‘stable-updates’ to ‘oldstable-updates’
N: This must be accepted explicitly before updates for this repository can be ap plied. See apt-secure(8) manpage for details.

Sounds to me as they recalled the update, at least for my Pi 3.
Any ideas?

That did the trick. Thanks a lot!

1 Like