OSMC and Hyperion


At first I thought so as well. Sat-receiver an Vero have “native” support but console, BR-player, etc… don’t so I made one and haven’t regretted it. AML-grabber is buggy so the v4l-capture device has to cover for that until they fix it.


The “problem” is, I only use a Vero4k and no other device so it would be pearls in front of pigs to me to use this kind of setup… :-/
On the other hand, it kind off frustrates me, that the grabbed brightness is so dim…


I was wondering what your connection scheme is, could you maybe Tell me?
I am thinking about switching to a Hardware grabber :wink:


I’ve got following kit:
HDMI-splitter: 1 end to TV, the other to a convertor
HDMI-2-Analog convertor: this is the tricky part. I bought several cheap ($15) mini HDMI-2-AV convertors but all had issues: either showed a rainbow screen when no signal was received, or a blue screen. This type seems to work (https://image.dhgate.com/0x0/f2/albu/g1/M01/E7/C1/rBVaGVn2nH-ASFnPAAN0Flb4GeI765.jpg). Got it for about $30 iirc.
Next a Fushicai grabber. This one is connected to the Vero4k. You could also get a STK1160. Both should work (https://hyperion-project.org/threads/comparison-fushicai-utv007-vs-stk1160.194/)

That is for the grabbing site.

My LED-string (100 led ws2801) is connected to a Teensy+ also plugged into the Vero. I got this back when I was still using a RPI. Prefered blowing up a cheap Teensy I had lying around than an RPI :slight_smile: and it turned out to be a good choice when I got the Vero. Plug-and-play…

On the Vero I run a small script that checks which input is set on my AVR and switches hyperion to the prefered grabber: boblight for my sat-receiver, v4l-grabber for the rest but that could change easily if a stable AMLogic grabber becomes available.


New here guys… Ordered a Vera 4k recently and I do have a ambilight setup. I have a Pie 3b+ with hyperion working great. Reading this thread and given its pretty recent I assume use hissingshark’s build (https://github.com/hissingshark/hyperion-vero4k) is the best option ---- It is fair to say we should disable Vera automatic updates of OSMC? Not sure if there is a track record of monthly build/updates impacting some of these customized changes. Since PI and Vera have these hardware differences.


There have been a lot of updates so far this year. None have been a problem to us as far as I can tell. It was only the update to Debian Stretch at the end of last year that tripped us up because of the upgraded python version.

As the updates are to improve and SECURE the Vero4k I should think it better to keep the updates coming, and fix any issues as they arise.

I hope the installer works out well for you.


hissingshark – and all

new Vero 4k worked no issues… Here is what I did
sudo apt-get install git
git clone https://github.com/hissingshark/hyperion-vero4k.git
cd hyperion-vero4k
sudo ./install.sh
During the install use the Binary it worked straight out of the box

Post install when you make your hyperion config make sure you change your grabber manually. (if you dont you wont get lights during videos)
Your config file goes into /etc/hyperion I had write issues to this directory so I threw mine into /tmp and did a sudo cp /tmp/hyperion.config.json /etc/hyperion

Dont forget to set Hyperion to auto start during boot — systemctl enable hyperion

Also dont forget to go into Kodi and enable “Allow remote control from applications on other systems” its under service > control. If you want to use the “detect kodi” feature of hyperion so lights only play on certain events.

**hissingshark thanks for the binary build my friend. I had errors from source and this isn’t my specialty. So the binary helped a great deal. o7


Hi, i am trying to replace my raspberry 3 with hyperion and ws2801 ambilight with a vero 4k, it arrived yesterday and i am trying to set up the ambilight, i followed deresistance how-to (thanks for that and thanks hissingshark for the binaries). It works, but it flickers all the time. I use an arduino with adalight. The same arduino works on my windows Pc, and the same led setup works on the raspbbery pi, so i guess it has to do something with the vero. I played around with the grabber settings a bit (width, higth and interval) but no change. Also the startup sequence (all leds red, blue and green) from the adalight works without flickering. Also the leds seem to be darker than with the raspberry.

Does anybody has an idea what else i can try?


Bad ground connection between arduino, PSU and led strip ?


Ok i made some more test, and onnected the arduino to the old raspbbery and to my windows machine (with the ambibox software), in both cases i get flickering, so its probably the hardware, i will check the wiring and the ground connection, als penfold42 suggested, when i find the time.


Hey guys. I just got my Vero4K because my Raspberry was really underpowered for those high bandwidth files with crazy ass surround tracks.
Now I would like to run Hyperion.
I tried the provided installer, but I always get this error:
osmc@vero4K:~/hyperion-vero4k/config$ sudo systemctl status hyperion.service

● hyperion.service - Hyperion Systemd service
Loaded: loaded (/etc/systemd/system/hyperion.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2018-05-15 18:40:19 CEST; 2s ago
Process: 1985 ExecStart=/usr/bin/hyperiond /etc/hyperion/hyperion.config.json (code=exited, status=1/FAILURE)
Main PID: 1985 (code=exited, status=1/FAILURE)
Mai 15 18:40:19 vero4K systemd[1]: hyperion.service: Service hold-off time over, scheduling restart.
Mai 15 18:40:19 vero4K systemd[1]: Stopped Hyperion Systemd service.
Mai 15 18:40:19 vero4K systemd[1]: hyperion.service: Start request repeated too quickly.
Mai 15 18:40:19 vero4K systemd[1]: Failed to start Hyperion Systemd service.
Mai 15 18:40:19 vero4K systemd[1]: hyperion.service: Unit entered failed state.
Mai 15 18:40:19 vero4K systemd[1]: hyperion.service: Failed with result ‘exit-code’.

I tried the binaries, compiling myself and also added the grabber options. No luck.

Also I would like to run server and LED-output both on the Vero4K - I own all sorts of USB/UART adapters, so that should be possible, right? I mean this beast does have the power and I only watch 1080p content anyway. For testing I have a strand of WS281B LEDs at hand.

The system on the box is pretty much virgin - I just ran the updater, configured my settings, installed a handful of video plugins and spent the last 2hrs trying to start Hyperion :slight_smile:

What did I miss?


run this as root and see what error you get. probably an error in the configuration file.


Oh wow, my Linux skills are so terrible…
I missed to remove the .example from the config file’s name… :smile:

After changing the destination to /dev/null Hyperion now seems to start up:

osmc@vero4K:/etc/hyperion$ sudo systemctl status hyperion.service
● hyperion.service - Hyperion Systemd service
Loaded: loaded (/etc/systemd/system/hyperion.service; disabled; vendor preset: enabled)
Active: active (running) since Wed 2018-05-16 12:11:03 CEST; 3s ago
Main PID: 9489 (hyperiond)
CGroup: /system.slice/hyperion.service
└─9489 /usr/bin/hyperiond /etc/hyperion/hyperion.config.json
Mai 16 12:11:03 vero4K hyperiond[9489]: INFO: Proto server created and started on port 19445
Mai 16 12:11:03 vero4K hyperiond[9489]: INFO: Boblight server created and started on port 19333
Mai 16 12:11:03 vero4K hyperiond[9489]: QtHttpServer started on port 8099 “Qt Static HTTP File Server”
Mai 16 12:11:03 vero4K hyperiond[9489]: AMLOGICGRABBER INFO: [AmlogicGrabber::AmlogicGrabber(unsigned int, unsigned int)] constructed(160x160)
Mai 16 12:11:03 vero4K hyperiond[9489]: BLACKBORDER INFO: threshold set to 0 (0)
Mai 16 12:11:03 vero4K hyperiond[9489]: BLACKBORDER INFO: mode:default
Mai 16 12:11:03 vero4K hyperiond[9489]: INFO: AMLOGIC grabber created and started
Mai 16 12:11:03 vero4K hyperiond[9489]: KODICHECK INFO: Kodi Connected
Mai 16 12:11:03 vero4K hyperiond[9489]: KODICHECK INFO: switching to OFF mode
Mai 16 12:11:06 vero4K hyperiond[9489]: EFFECTENGINE INFO: effect finished

Any idea on how to attach a UART<>USB adapter for output?
Also opening port :8099 when Hyperion is running gives me “Requested file index.html couldn’t be found !” - I guess I am missing either the right URL or some files need to be installed?


I’m using a Teensy. Have a look here for more information: http://www.instructables.com/id/Teensy-Ambilight/

As for the web-interface, check the config for the rootPath. I’m using my own compiled version so no clue if these are also installed in your version.


OK I managed to make it work.
Thanks for the help!

I used HyperCon to generate a fresh config for me and It gave me the correct settings to get UPD in raw mode running.

Then I wrote an Arduino sketch to interface an ESP-01 to the test-strip and then just pushes the buffer out the the LEDs.

These are the important parts i think:

“device” :
“name” : “MyHyperionConfig”,
“type” : “udpraw”,
“output” : “”,
“rate” : 1000000,
“maxpacket” : 1450,
“protocol” : 0,
“colorOrder” : “grb”

and as the only grabber:

“amlgrabber” :
“width” : 64,
“height” : 64,
“frequency_Hz” : 1.0,
“priority” : 890

It works great with some movies, some do not work well (black borders seemingly) and some don’t work at all. I will check for strips now and read up on Hyperion’s features in the meanwhile :wink:


Please let me know how the amlgrabber is working for you. I had some problems with it (audio and video out of sync).


Will do.


It’s occasional but annoying enough I switched to a v4l-grabber I used for BR, Satbox even for the Vero.


It’s some time off but we can improve this for you.



That would be great. From what I read AML would have to provide some interface so grabbing is no longer done in user-space but in kernel-land. Is this the solution or is there another way?