OSMC can't access Windows shares

I just bought my Pi, installed OSMC, and I wanted to add windows shares (SMB) to the library.
I went to Settings\services\File explorer\add location.
If I just choose SMB from the list I see my Workgroup, i can see my computer name, but when i enter it OSMC offers to save location, but I cant do anything here, everytime i choose ok it sends me back to save location dialogue, I have to choose cancel to do anything else.
If I go add network location and choose browse, same thing happens.
I even tried manualy entering address, but I’m not sure how that should be done. On my Win10 PC I tried enabling manual IP address for TCP Ip 4, and tried the following:
In windows i disabled password protected sharing.
Please help.

If I remember correctly guest share (passwordless) is currently not supported.

Also not sure about the settings are you are in. Try to add a source eg videos

1 Like

Tried it through videos, same thing.
Also in add network location I tried entering a username and password i made on PC for my old AC Ryan.

The share needs to be configured to request a username and password, you can’t get around it by just specifying a user on the pc. Shares configured as “guest shares” won’t work.

I use some folder shared from my Windows 10 home to my Pi2… i can confirm there’s no work whitout a password setted on windows share and it’s also need to set correctly the shared folder to access for “All User” in “Security Tabs” on preferences of folder…

I solved it by installing LibreELEC. SMB shares work without a problem.

If that’s what works for you, good luck. Without a debug log, no one knows what your issue could be. It could have very well been a typo, as there don’t seem to be other recent reports of Samba shares not working.

All the information to diagnose and fix the problem can be found on our Wiki

Edit: I see you are saying that you didn’t want to configure a username and password for Samba. LibreELEC uses an older version of Samba which has a few vulnerabilities in it. When they update the package you’ll find yourself in the same position. We prefer to keep OSMC up to date and secure, but can understand that the risk to Samba is probably low in a home network which is why they haven’t updated it

No typo. Every way inside the GUI for SMB access didn’t work, even with the username and password. With the add source/SMB option it didn’t even ask me for ussername and pass.
I even tried to automount with console. I cant find the page I used for instructions. That also failed.
If you know the way to automount through console I would be grateful.

Search for fstab samba and you will find out how to do this.

Without a log, it’s very hard to tell why.

Tell me how to get the log. Thanks in advance

That question has been answered literelly hundreds times before, also the appropriate post is pinned: