OSMC changing resolution by itself?

Hi there!

Happy Vero 4K+ owner here, except for a few minor issues, the latest of which I’ve only discovered since upgrading my projector to a 4K model (Optoma UHD3200A, equivalent to UHD52ALV):

I have my general output in OSMC set for 3840x2160, as I find it provides the best looking image. My projector upscales all normal 1080p stuff to that resolution, but the Vero does a much better job, so I leave it there and everything is cool.
But the thing is, that right after watching a movie (be that either 1080p or 2160p), the system output resolution suddenly drops back to 1920x1080, sometimes changes the frame rate too.
Oftentimes when I then go into System to change it back to 3840x2160 (the difference in color and resolution is very visible), then it appears that OSMC still thinks that it’s in that mode, but if I change to 1920x1080, nothing happens. Change again to 3840x2160, then the resolution changes, and everything looks nice and smooth again …

I’m having a hard time figuring out whether my new projector is somehow forcing OSMC into another output resolution than the one I set (is it even possible??), or if OSMC is doing this by itself?
Either way, its quite annoying and seemingly random; Although usually it’s right after a reboot f.e.

Any suggestions, or anyone tried this?

Thanx in advance!

Please post debug logs showing what happens after re-boot and after watching a movie.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Thank you, Graham! Sorry, took me a while to get around to it, here is the log, hopefully:


The only thing I did was basically to set my desired resolution (3840x2160 at 60Hz) and then switch off my projector (Optoma UHD3200A) and receiver (Marantz NR1608). I then switched those back on again, without touching the Vero at all, and the resolution was now 1920x1080 …
This happens every time. Sometimes it still claims to be in 3840x2160, but if I refresh that mode, nothings happens. I then try refreshing at 1920x1080, still nothing, and if I after that try refreshing in 3840x2160, then it actually changes …

I’d be real happy if you can come up with some fix for this :slight_smile:

Thanx in advance!

PS!!: I just discovered that apparently just leaving both receiver and projector on and rebooting the Vero seems to provoke the same response. If I have changed the resolution to 3840x2160, after reboot it’s always 1920x1080 … :-/
I don’t know what’s forcing the Vero to change resolution like that …

It’s recommended to set resolution to 1080p and change refresh rate in settings player to Start/stop that way the GUI will be displayed at 1080p ( the textures aren’t 4k) and when you play a 4k movie the vero will switch to the correct resolution.


To add to what k1u2 posted…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Thanx for the input, although it didn’t really answer my specific question, but we’ll get back to that :wink:

I do understand the part about the UI not being for 4K, but in my case, setting the UI for 4K seems to be the only way to make the Vero upscale 1080p movie material for my 4K projector, which I prefer by far in terms of quality, because the projector is so much worse at upscaling 1080p than the Vero, both the UI and general video.
I can easily live with a more crappy looking UI upscaled from 1080p by the projector, but also with video is a no go for me.

So let me ask 2 questions:

1: All UI 4K optimization (or lack thereof) aside, can anyone tell me exactly why the Vero keeps switching resolution by itself, as explained above?

2: Alternatively, is there any way you can make the Vero upscale 1080p video to 4K, while still keeping the UI in 1080p?

Thanx so much :stuck_out_tongue:

Perhaps. @grahamh asked for the logs to gain insight into that issue. I’m sure he will chime in again when he gets the time.

Kind of. If you set your UI to 1080p 60hz and configure a whitelist with only the various 4k refresh rates then all HD and below video that is not matched to 60hz output will be upscaled to 4K. This is because the UI resolution is always included as part of the whitelist. If you have a whitelist and are playing a source that outputs to the UI resolution instead of 4K this can be switched during playback in the video options (this is only visible if you have a whitelist).

1 Like

Not really. Particularly strange is the resolution re-setting when you finish a video - your log doesn’t show that case, though. I suspect there’s a timing issue with the way the projector’s EDID is being read through the Marantz. I can sometimes reproduce what you’re getting with my AVR and TV but it’s a bit hit and miss. My TV wakes up the AVR with CEC. You may find the resolution is preserved better if you make sure the projector is turned on before the AVR.

Please try turning off Hot Plug Detect (System->Display->Lock HDMI HPD). Settings level needs to be Standard or Expert to see that. With that setting you will need to ensure your projector and AVR are both on when Vero starts up.

1 Like

Hmmm … I tried your suggestion with the whitelist, and it kind of works … but only kind of, and I suspect a bug might be buried here:
It’s true that the Vero is then upscaling 1080p material to 2160p, but the frame rate is somehow stuck at 60p, because it plays back 24p material with strong judder (even if my projector announces that it’s receiving 24p).
If I then change back to full 2160p output, UI and all, 1080p is again upscaled, but the frame rate is then correct and playback buttery smooth …

Perhaps I need to upload a log on this behavior?

Ok, the “Lock HDMI HPD” does have some effect, but sucks in practical reality, so I’m going to try other stuff.
I didn’t have time to experiment thoroughly with turning on the projector first and then the AVR after that, but I had it working at least once, and suspect that it might work … more on that later :wink:

HPD Lock isn’t your solution.

But some logs with it being a problem would be useful.

1 Like