OSMC Freezing when accessing SMB share on Win 10

NAS drive works brilliantly.

Yet for some reason sometimes SMB works fine (if not a blit sluggishly) Other times just browsing a folder freezes OSMC entirely only to return back to normal several minutes later.


Hope you can help :slight_smile:

First, you have a banned source, so you need to remove that.

Second, you are using Kodi based SMB mounts, it’s better to switch to using fstab mounts.

And you are using names on some of the sources instead of IPs. You may have better luck using IPs.

I have no clue what banned source I’m using. I haven’t messed with my system in quite a while. Turn on/browse/Play that’s what I usually do.

I created fstab following these instructions:

They are so jumpy I can’t watch anything.


Ps I also had an error while naming them. I fixed them but the old versions still show and I do not know how to remove them.

You need to update your sources to use the fstab mounts, you are still using the Kodi mounts. But, your fstab mounts don’t appear to be working

Jul 20 12:50:41 osmc kernel: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
Jul 20 12:50:41 osmc systemd[1]: mnt-Unwatched\x20Education.mount: Mount process exited, code=exited status=32

I noticed that you are also using nfs. If you can, switch all your mounts to using nfs instead of smb as it performs better. (and use fstab for nfs also)

And you still have a banned repository in your sources.xml. I can’t mention what it is but if you look at your sources.xml you will find it.

Do you know how to remove FSTAB mounts that I incorrectly inserted?

As far as I’m aware I cannot make my computer into a NFS so I have to use SMB or FSTAB. The problem is both of them take around 4 to 5 min to load the directory and the videos pause during playback constantly.

Currently the only way to get smooth playback is with NTFS or a USB stick.


Now I cannot play any movies on my NAS, only TV shows (not sure why that is). Only USB fully works. I’m not sure why things keep on getting worse with this :confused:

Please I hope someone out there knows what on earths going on here.



I would try adding a video cache:


Thanks Tom.

Ok that appears to have helped.

I went with example 4

“A safe setting for most devices with 1GB of RAM that should help most users “on the edge”. All protocols get cached, cache rate fills up pretty much as fast as possible, and cache size is about 133MB, using about 400MB of ram total.”


So far so good :slight_smile:


Glad to hear you are sorted. If you have any issues I would try with reducing the readfactor, I normally go between 4-6 and there shouldn’t be any need to go above 10.

Thanks Tom.