OSMC + HDMI CEC = Requiring activate


I have the latest version of OSMC running on my RBPi 3. I used to have a LG TV and everything worked great.

I’ve recently changed my tv for a Samsung 4k and now HDMI CEC is not working properly. If I want to use it I need to turn on the TV, switch to Kodi input and reboot RBPi. After it boots, CEC is working.

I have also found that if I execute the command “CEC Activate” through Yatse, the TV remote immediately starts working, without the need to reboot. It seems to me that this might be a software thing.

Does anyone have a clue on how could I “automate” this “CEC Activate” command so that I don’t have to rely on Yatse every time?

Thanks in Advance

Try this.


I’ve tried it but it didn’t work :sweat:

Any other ideas?



I have a similar problem with my Samsung 4K TV and OSMC (running on RPi 2). I worked out that the Samsung TV remote will only work with OSMC for a few second while a “echo scan | cec-client -s -d 1” command is running. Once the command has stopped, the TV remote will also stop controlling Kodi.


Can we get a debug log so I can see what’s going on?

Logs have been uploaded using My OSMC Log Uploader.

I tried again now. The TV remote works OK after a reboot until I switch to another source, once I switch back to OSMC the TV remote doesn’t work, except while I’m using cec-client from the command line.

You have to provide the URL that’s returned when you use the uploader.

Re-uploaded the logs. Steps performed

  1. enabled debug logging for libCEC
  2. rebooted OSMC
  3. OSMC booted OK, TV remote working
  4. switched to YouTube app (Samsung TV app)
  5. switch back to OSMC, TV remote working
  6. switch to YouTube (TV app), played a video for a few seconds
  7. switch back to OSMC, TV remote not working


There is no OSMC debug log here, so I can’t really investigate anything.

I’m not sure what LibreELEC has to do with things here but you are using two different versions of Kodi and in turn, libCEC, so it’s very hard to diagnose this problem.

You should move back to v16. And see the Wiki for info on providing a proper set of logs.

I re-ran the same steps with debug log enabled (sorry). New log is here http://paste.osmc.io/xehayihohu

I’m not running LibreELEC. I enabled verbose logging of the libCEC library in Settings->System->Logging->Specify ccomponent-specific logging.

Sorry – I’m mixing this up with a very recent thread where someone has a CEC issue but is running two different distros and two different versions of Kodi

Both you and the other user are using Samsung TVs which seem to be problematic lately. I can see logical address changes in your log but it’s hard to tell if this was when your problem occured, or if the problem occurred at all when you captured your log.

I don’t have a Samsung TV but all I can suggest is to wait for Krypton builds. These are already available for testing but come with little support. If the issue persists there then we can look further and at the very least collect all information and submit it as a bug report to the libCEC maintainers.

Did you re-install your PI after you switched from LG to Samsung? I assume not. Samsung does not have the best track-record for brand new tv’s and bug-free firmware. Perhaps a firmware update can solve your issue. Since you have a nice way to reproduce your issue you could also post this on samsung forums. I don’t know in which country you live but there are stories that samsung support can solve some of these sort compatibility bugs.

Are the system/input/peripherals/cec settings set to defaults?
In particular is “Switch source to this device on startup” (should be enabled).


on what firmware revision is your Samsung 4k TV? We had CEC problems with firmware 1470, but no problems since 1480. What version has yours?

Best Regards

PS: CEC problem with Samsung TV

Hi. The Samsung software version is 1160, I’m in Australia. I haven’t seen any references to this version before. The software recently updated a couple of days ago. Still no change to the CEC behaviour yet.

Yes, “switch source to this device on startup” is enabled.

No I didn’t re-install the Pi, I’m not too keen on doing that. I’ve seen others mention that powering down everything for 15 minutes will help - that would be my preference to try before a re-install.

Eventually helps this procedure:

And a second possible solution could be to change the device types (guide was for my pi3, but should be the same for pi2, I think), for me it was only a temporary solution, but eventually it’s worth a try:

Just found out what the issue was on my side:
My TV didn’t shut down on power off Kodi, but the remote was working. Everytime when i go to the CEC settings within the KODI after hitting OK, the Remote didn’t responded.

Setting the device type to 4 doesn’t helped. Then i noticed in the same files the value of “standby_devices” was set to “231”, which i guess means disabled. So i set this value to “36037” as per enum and the magic of powering off the TV works again.
Strange, that Kodi always showed that this setting was turned on.

To me, it seems that Kodi has troubles to write to those setting files. Hope that helps someone.