OSMC installation stuck formatting

This is totally unnecessary since the image write is done at a block level. Initial format type of the card is irrelevant.

Hi @ebeng,

Thank you for the suggestion, but it didn’t solve the problem.
I wrote the image to the SD Card using WIN32 Disk Imager, but the installation process still got stuck at “formatting device”.

Did you find a fix? Im having the same issue.

Hi,

No, I didn’t find a fix. I gave up :disappointed:

ohh damn… really want to get this fixed…

My Pi will boot but then gets stuck at Formatting Device… I have tried installing to USB and SD… power supply is official… sd card is legit…

Help please!?

Thanks
Gershy13

Which SD card you have?

Do you have another one at hand to try?

I’m not sure why you’d get a hang at formatting on a USB installation, as no partitioning of the SD is needed for this scenario, and it’s unlikely that both USB and SD are problematic.

However, if the Format succeeds, but then there is some problem beginning the extraction, then you may only see the Formatting Device message.

I would try another card.

Please don’t open identical threads.

Consolidated.

Hi all.
I had the same issue getting stuck on the formatting device stage. I tried changing gpu_mem to 32 but it just caused the Pi not to boot at all.

What worked was changing the config.txt settings order to as follows (using notepad++):

gpu_mem=16
disable_overscan=1
framebuffer_depth=32

I am using:

raspberry pi 3

16gb class 10 Samsung SD card (new genuine and verified) formatted to fat32 primary.

32gb USB 3 150MB/s Samsung memory stick (new genuine and verified). formatted to fat32 primary.

OSMC 2016.08-1 (image downloaded manually not via installer)

2.5A PSU

HDMI out

no internet connection

no other devices plugged in.

This shouldn’t be necessary at all.

How long did you wait for formatting? Some SD cards can take a while. It also seems like you may have been trying to install OSMC to a USB stick; partitioning can take a little longer here.

The install.log on the SD card will surely show the problem if it happens again.

Hi Sam

Yes it was a USB install.

First attempt:
No changes just let the installer do its thing. SD and USB formatted to fat32. left running for 30min.

second attempt:
No changes just let the installer do its thing. SD and USB reformatted to fat32. left running for 2 hours.

third attempt
just rebooted

forth attempt
just rebooted

fifth attempt:
reformatted USB only to fat32 left running for 20 minuets. (after this attempt and previous ones the usb drive had been stripped of any formatting after letting installation run)

sixth attempt
reformat USB to EXT4 and left running for 15 minuets.

seventh attempt
reformat USB and SD to fat32, downloaded disk image manually.

eighth attempt
reformat USB to fat32, downloaded disk image manually, changed gpu_men to 32, no boot.

eighth attempt
changed gpu_men to 64, no boot.

ninth attempt
changed gpu_men to 256, no boot.

tenth attempt
thoroughgoing toys out of pram… reformat USB and SD to fat32, downloaded disk image manually, changed gpu_men to 16 and placed at top of list, format was completed in 20 seconds rest of the installation took about a minuet.

There should be no need to change gpu_mem, and I can’t see how that would impact installation for you.

You also don’t need to pre-format your USB stick, as this is handled automatically by the installer.

The only thing we need is the log, which would be located on the SD card. If it’s running now though, you don’t need to upload it, as this is the first (of a seemingly isolated) report, so I don’t think there is a problem in general.

I had the same problem, stuck on “Formatting Device” several times. Then I wrote an old RaxpBMC image to the card, booted it and then again wrote OSMC on the same card. It worked! Using Win32DiskImager 0.95 on Windows 10.

I’m having the same issue trying to put the December release onto a card with my pi. Will try another image on that card

Are you using a USB card reader to do this? How big of a card and does the card reader support cards of that size? Or are you trying to use the built in card reader? Because that won’t work.

yes, 16gb card, and for sure it supports it same reader built the previous install on a 64gb card that I tried. I’m using a micro SD - SD converter in the USB reader

For the records, there is a issue with the installer and some SD cards, maybe because the OSMC installer is based on 3.18 kernel and it uses the old mmc driver.

Correct – we’ll update that soon enough.

5 months later - this is still broken for me. My solution was to reinstall an image from two years ago.

I think something else is wrong there.

Did you try with another SD card?