OSMC Installation via NFS Problems [Raspi 1B, Synology, NFS] [SOLVED]

Hi @ Community!

I have a Setup where I wanted to reactivate some old Raspberrys and wanted to test the performance and feasability to run osmc from my Raspberry Pi 1 Bodel B.
I Have a synology storage box with (nor multiple working and productive) NFS shares, so I created a new one under
My NFS permissions are:
rw, squash all users -> admin, security -> sys, async enabled
NFS Settings
NFS v4 enabled (but all others also)
rw packet sizes 32kb.
DHCP Reservation for my Pi
NFS Permission for said IP Address

Issue: Installation runs, but on reboot I get 4 lines of error:
3x mounting failures on /proc /sys /run plus
/bin/sh not found

When I look into the Folder on the storage box, it created only 3 (partially filled; later more) folders:

and look and behold, /bin/sh is not in the folder. (but some others are)
I have had the issue now with the current and 2 previous versions of osmc.
Also: In the filesystem.tar there is /bin/sh present. So there must be something wrong with the copy process, or the success condition during setup.

Does anyone know how to troubleshoot further? I could not find any NFS related topics here…
First thing I will continue with is a different SD card - but I have only little hope, because the symptoms are three times the same, and it would be a coincidence thet it stops every time at the same three folders.

Best Regards,

I suggest taking a read through these:


Thanks Tom.

Thanks @Tom_Doyle, skimmed through, but to no avail.
It seems like I am the first one experiencing the issue.

What I did apart from this:

  1. searched the files for my nfs connection strings like “my-ip” and “volume1”
  2. searched the files for for the previously configured IP from the installer “”
  3. Suspecting that I should not use dhcp networking - even though it’s a feature from the installer.

It’s just odd, that some files in /usr/bin get copied, but not /bin/sh for example.

Will also test for manual network, and smaller package sizes.


Unfortunately the installer always said "installation successful.
Even though the files were not copied successfully.
Idk, if that should raise an issue / bug.

Manual network didn’t do anything.
Package sizes also.

Reverted back to my previous defaults.

Had a suspicion, that my nfs settings were not optimal for the specific use case of osmc, and changed my squash back to no mapping at all in my syno box.
Installation runs much longer now (as expected), seeing a fully populated directory tree and seems to be more viable in the end.

TL;DR: don’t squash your roots on nfs installs.

Will report back if it runs afterwards.

Thanks for pointing me there @Tom_Doyle even though the “exact” issue wasn’t there - it gave me pretty valuable hints to troubleshoot.


1 Like

Installation ran through.
Now stuck at sad face with a mounting and avahi error during startup.
So there must be something wrong still.
Double-checking permissions.

Error 1 Solved via:

TL;DR: don’t squash your roots on nfs installs.

Error 2 Fixed.
Found this one:

Manually set my permissions to 555 on the NFS box on /path/to/nfsroot and kodi came up without errors.

Changing skin threw me a sadface afterwards. Still debugging. (Edit: no further issue as stated below.)

It was no error, only the OOB first-run-assistant killing my first moves on the interface.
Seems like everything is resolved.

If anyone comes across these errors an a synology box, this might be helpful.
If I’ll come across more issues, I’ll keep this updated - otherwise this might be closed in a few days time.



I imagined booting and running via NFS would perform better than running from a SD / SD+USB but 100MBit/s is bottlenecking hard.
Killed the Installation - moved on to have more fun with local SD and a remote DB.
Still getting good mileage from an older Pi1-ModelB for 1080p videos.