OSMC Release Candidate 2 is here

here is a new one. Forgotten to enable debug within kodi on the last one


18:44:39 T:1804878880 DEBUG: osmc_settings: False 18:44:39 T:1786258464 DEBUG: OSMC REMOTES scriptmoduleosmcsettingremotes.run received: pos0: <OSMCSettingClass(Thread-30, started daemon 1786258464)> 18:44:39 T:1786258464 ERROR: Exception in thread Thread-30: Traceback (most recent call last): File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner self.run() File "/usr/share/kodi/addons/service.osmc.settings/resources/lib/CompLogger.py", line 61, in wrapper func(*args, **kwargs) File "/usr/share/kodi/addons/script.module.osmcsetting.remotes/resources/osmc/OSMCSetting.py", line 153, in run self.GUI = remote_gui.remote_gui_launcher() File "/usr/share/kodi/addons/script.module.osmcsetting.remotes/resources/lib/remote_gui.py", line 131, in __init__ local_confs = [construct_listitem(self.active_conf)] + local_confs File "/usr/share/kodi/addons/script.module.osmcsetting.remotes/resources/lib/remote_gui.py", line 56, in construct_listitem with open(conf, 'r') as f: IOError: [Errno 2] No such file or directory: '/home/osmc/lircd.conf' 18:44:39 T:1863316512 DEBUG: PushCecKeypress - received key b duration 72

RC2 greatly improves compared to RC1 in terms of usability using the Vero device. The result is that Vero now is number 1 and the Pi2 is , well, number 2.

Thanks Sam

I upload logs ever time it happens.

You have to then provide us with the URL that is given on your screen after you’ve uploaded the logs.

Looking forward to the new version! I don’t know if this release has changed the update process, but if not I hope you won’t mind a couple of thoughts:

  1. The manual update is slightly less communicative in its on-screen messages than I would want. At times there’s a gap between a first set of updates being downloaded (with accompanying message) and then a new set following on. In that gap it’s not always clear where the overall process is at, whether it’s finished or whether it’s failed. In an ideal world, it would be nice if the status updates reflected the overall progress and indicated ultimate success or failure.

  2. Is there a reason the Update functionality lives in the My OSMC section (app?) rather than the settings? I guess in a world of background updates, it will pass unnoticed, but it’s odd that it lives outside the settings area. Indeed, I’d personally rather the OSMC app’s features were put in settings where appropriate, or featured as a first order heading in the case of the Appstore, if the plan is for it to grow into its own ecosystem.

  3. Speaking of the My OSMC section; the 9 icon layout is counter-intuitive to navigate with a remote, features icons that are impossible to decipher absent their labels, which only appear when the icon is selected, and doesn’t seem like it will scale beyond 9 sections. For what it’s worth, I’d rather it reflected the flat, text-based minimalist approach of the Skin as a whole.

edit: 4) Also, is there anywhere where I can see what version of OSMC I’m currently running? It doesn’t seem to appear in System Info, which lists the Kodi version, or the My OSMC app.

Rest assured, these are trifling concerns in comparison to the list I could put together of things I love!

It looks like the remote module is crashing because you have a custom lircd.conf selected (/home/osmc/lircd.conf) but the file doesn’t exist.

Try copying one of the lircd.conf files from /etc/lirc to /home/osmc/lircd.conf and see if the remote module then opens and lets you choose the correct profile.

I’ve passed the details of this bug onto the addon developer and it should be a fairly easy fix.

The reason is simply that the OSMC settings are written as a Kodi addon, and Kodi doesn’t provide any way for us to add an addon within the standard Kodi Settings menu.

I think it is possible (I’m not a skin developer) to fake it by customising the skin, but this would only work for the OSMC skin and not for any other skin that the user might switch to, and is likely to break for future versions of Kodi and keep needing tweaking to keep it working with newer Kodi versions. (poor maintainability)

Not ideal, but until Kodi provides a standardised Skin independent way of adding addons within the Settings menu there isn’t much alternative.

It would hinder the modularity of the addon

Today it found a 95mb update that changed everything to the best yet.

Thinking i might not have run RC2. (After that RC2 update i lost the remotecontrol icon In the OSMC menu?)

Which is Strange. I know i choose RC2 (for pi2) thru the windows installer. I even double checked before installing.

I run extra long movie thru WiFi, no problems.
I run several TV series episodes thru WiFi, no problems.
I run update, installed some subtitle things. No problems.
I streamed tv channel. I have not needed to reboot and no more 1-2 minutes before doing requested things.

Looking foreword to see if it will be even more smooth in RC3. =)

If you ran updates on RC1 today you are now on RC2 - you will have all the same OSMC packages as a fresh RC2 install.

hmmm its weird that its crashing due to a custom lircd.conf. I have not actually changed anything from the defaults within the app as I am using my TV remote with CEC

However I will try and copy that file over and post back results

Can we please continue the support requests in an appropriately titled thread created in the appropriate sub-forum?

A version release announcement thread is not intended to be used for support requests!

Same as @spudy12, the remote app. doesn’t open anymore.

Worked fine on RC1, on RP2 .

I updated from RC1 without any issues.

I also did a fresh OSMC RC2 install on a new RPi2 on wireless. It went very smoothly and I have encountered no problems so far.

Kind thanks to Sam and the team for your continued work!

The App store TVheadend version is not working… read more about it in other treads like here:

Thanks. It’s more clear ;).

The following packages were automatically installed and are no longer required:
Use ‘apt-get autoremove’ to remove them.

can I use autoremove for this package and for others?
maybe OSMC can do this after every major update?


I see the update icon but how do I update my system? Do I have to go into program and do a manual update? Restarting doesn’t seem to work.

CC @Karnage