OSMC Release Candidate 2 is here

The reason is simply that the OSMC settings are written as a Kodi addon, and Kodi doesn’t provide any way for us to add an addon within the standard Kodi Settings menu.

I think it is possible (I’m not a skin developer) to fake it by customising the skin, but this would only work for the OSMC skin and not for any other skin that the user might switch to, and is likely to break for future versions of Kodi and keep needing tweaking to keep it working with newer Kodi versions. (poor maintainability)

Not ideal, but until Kodi provides a standardised Skin independent way of adding addons within the Settings menu there isn’t much alternative.

It would hinder the modularity of the addon

Today it found a 95mb update that changed everything to the best yet.

Thinking i might not have run RC2. (After that RC2 update i lost the remotecontrol icon In the OSMC menu?)

Which is Strange. I know i choose RC2 (for pi2) thru the windows installer. I even double checked before installing.

I run extra long movie thru WiFi, no problems.
I run several TV series episodes thru WiFi, no problems.
I run update, installed some subtitle things. No problems.
I streamed tv channel. I have not needed to reboot and no more 1-2 minutes before doing requested things.

Looking foreword to see if it will be even more smooth in RC3. =)

If you ran updates on RC1 today you are now on RC2 - you will have all the same OSMC packages as a fresh RC2 install.

hmmm its weird that its crashing due to a custom lircd.conf. I have not actually changed anything from the defaults within the app as I am using my TV remote with CEC

However I will try and copy that file over and post back results

Can we please continue the support requests in an appropriately titled thread created in the appropriate sub-forum?

A version release announcement thread is not intended to be used for support requests!

Same as @spudy12, the remote app. doesn’t open anymore.

Worked fine on RC1, on RP2 .

I updated from RC1 without any issues.

I also did a fresh OSMC RC2 install on a new RPi2 on wireless. It went very smoothly and I have encountered no problems so far.

Kind thanks to Sam and the team for your continued work!

The App store TVheadend version is not working… read more about it in other treads like here:

Thanks. It’s more clear ;).

The following packages were automatically installed and are no longer required:
rbp2-image-3.18.9-5-osmc
Use ‘apt-get autoremove’ to remove them.

can I use autoremove for this package and for others?
maybe OSMC can do this after every major update?

Yes

I see the update icon but how do I update my system? Do I have to go into program and do a manual update? Restarting doesn’t seem to work.

CC @Karnage

Hi. I’ve been getting much more under-voltage warnings on RPi2 after installing this release. Does this release (firmware?) somehow need more power than the old one? (Old one = not sure if it was an RC1, I lastly installed alpha4 from scratch and then applied updates.)

You need a fresh install, Alpha4 CANNOT update to RC1 and above cleanly

Thanks, I did a fresh install to RC2, so I’m comparing RC2 to Alpha4. Maybe it’s just my feeling, so I’m wondering if there could be such change in firmware or what that could cause this.

Alpha 4 on Pi 2 accidentally had the cpu underclocked which would use less power than normal. So yes RC1/RC2 will require more power than Alpha 4 because of this, so if you are seeing the low voltage warning more frequently then your power adaptor is marginal.

The Pi 2 is very demanding of power adaptors (more so than earlier Pi’s) I had to buy one of these power adaptors for my Pi 2 because none of the adaptors I had for my Pi 1 B and Pi 1 B+ or the one which came with my Pi 2 would run it without the low voltage warning flickering up constantly. (In fact one adaptor would not even boot Kodi successfully but works perfectly on my other two Pi’s)

With the above adaptor I no longer see any power warnings on my Pi 2.

This is nice. I have been away for two week and not checking this site either. Now I came home, osmc told me updates available. It took some time to update. In the mean time I learned new RC was available. After uodate finished I checked and voila - I am on RC2 ! Great, this is how it should work.

Great work, thank you.