OSMC Release Candidate 2 is here

I see the update icon but how do I update my system? Do I have to go into program and do a manual update? Restarting doesn’t seem to work.

CC @Karnage

Hi. I’ve been getting much more under-voltage warnings on RPi2 after installing this release. Does this release (firmware?) somehow need more power than the old one? (Old one = not sure if it was an RC1, I lastly installed alpha4 from scratch and then applied updates.)

You need a fresh install, Alpha4 CANNOT update to RC1 and above cleanly

Thanks, I did a fresh install to RC2, so I’m comparing RC2 to Alpha4. Maybe it’s just my feeling, so I’m wondering if there could be such change in firmware or what that could cause this.

Alpha 4 on Pi 2 accidentally had the cpu underclocked which would use less power than normal. So yes RC1/RC2 will require more power than Alpha 4 because of this, so if you are seeing the low voltage warning more frequently then your power adaptor is marginal.

The Pi 2 is very demanding of power adaptors (more so than earlier Pi’s) I had to buy one of these power adaptors for my Pi 2 because none of the adaptors I had for my Pi 1 B and Pi 1 B+ or the one which came with my Pi 2 would run it without the low voltage warning flickering up constantly. (In fact one adaptor would not even boot Kodi successfully but works perfectly on my other two Pi’s)

With the above adaptor I no longer see any power warnings on my Pi 2.

This is nice. I have been away for two week and not checking this site either. Now I came home, osmc told me updates available. It took some time to update. In the mean time I learned new RC was available. After uodate finished I checked and voila - I am on RC2 ! Great, this is how it should work.

Great work, thank you.

It sounds like you upgraded from Alpha 4 ? If so please note that you cannot update from Alpha 4, if you try, some components of the OS will not upgrade properly.

RC is the earliest version that you can upgrade to later versions from.

I second this, I’ve just bought the same adapter. Was using a 2a rated supply from my nexus 7 with no problems in the uk, stable voltage on the pins on my pi. 5.1v minimum under load. Bought a pi2, stable on that too. Didn’t measure pin voltage but no rainbow squares. Moved to Spain, 220v instead of 240v. Nexus charger is now marginal, charges the nexus fine, rainbow squares on pi2 but not original pi. Official pi charger works a treat on both. It’s amazing how sensitive the pi is to marginal power supplies, maybe the pi should be sold with psu for a few more quid to stop all these problems :relaxed:

I don’t know how you came up with Alpha 4, I did not mention it anywhere. I was on RC 1 and I just pointed out how smoothly upgrade went.

Thanks a lot for the answer. That would explain it all.

Just upgraded to RC2 on my RPiB+ and immediately get a message on every restart that says “Search Error No Results” and it just sits there. I don’t know what it’s searching for. One time it also showed that there was an error connecting to twitter. And the buffering seems to have gone downhill. It might just be this stream that I’m watching but it seems that it just doesn’t buffer enough. Earlier I even got an error message saying that I ran out of cache space so I created an advancedsettings file and added the following.

    <advancedsettings>
      <network>
        <!--- The three settings will go in this space, between the two network
tags. --->
        <buffermode>2</buffermode>
        <cachemembuffersize>0</cachemembuffersize>
      </network>
    </advancedsettings>

Any help would be appreciated.

Provide logs.

I dont know of anything we’ve released that tries to connect to twitter, or post search results on start up.

I hope you know what you are doing and you use a harddisk to write the cache to. If you do that on the SD Card you will have extended the wear-and-tear dramatically.

Where do I find the logs?

I hadn’t thought of the additional wear and tear on the sd card. I’ll set that to 20MB and see if that helps

https://osmc.tv/help/wiki/logs

Ok, so the Twitter crap is coming from some tvaddons addon. I’ll need to figure that out:

10:05:42 T:2809455648  NOTICE: No Twitter Results, URL = http://www.twitter.com/search?q=from:%40TVADDONS%20lang%3Aen&f=realtime
10:06:04 T:2893603872  NOTICE: Previous line repeats 15 times.
10:06:04 T:2893603872   DEBUG: script.module.osmcsetting.updates :  - blurp 763 - Home.xml
10:06:05 T:2809455648  NOTICE: No Twitter Results, URL = http://www.twitter.com/search?q=from:%40TVADDONS%20lang%3Aen&f=realtime
10:06:54 T:2893603872  NOTICE: Previous line repeats 36 times.
10:06:54 T:2893603872   DEBUG: script.module.osmcsetting.updates :  - blurp 763 - Home.xml

As for the rest of the log file, do you want me to put it all here or use the upload feature in OSMC/kodi? I see a few warnings and a couple of ERROR lines, but I think the message I’m seeing is coming from some SQL that is running trying to get some album information (though that’s just a guess)

RC2 still doesn’t seem to wait long enough for the network to start (on my RPi 2, at least!) before starting Kodi. How do I change it to wait longer?

Did you enable “Wait for network” in the networking GUI ? If so it waits until the network is up, up to a maximum of one minute before giving up and loading Kodi anyway.

What “up” means depends on your network configuration:

Ethernet Static IP - The Ethernet link is up.
Ethernet DHCP - The Ethernet link is up, the DHCP server has responded and given us an IP address and the interface has been configured with this address.
Wifi Static IP - the Wifi network is associated (connected)
Wifi DHCP - the Wifi network is associated (connected) and the DHCP server has responded and given us an IP address and the interface is has been configured with this address.

It does not check for internet connectivity, only local network connectivity.