OSMC Remote on Ubuntu 18.04

I used the rf remote and usb dongle briefly when i first bought the vero4k, and it worked fine.

After a few weeks i moved to using my ortek vrc-1100 on the vero so i could benefit from the extra buttons.

So the osmc remote and dongle hasnt been used for several months.

I’m now re-purposing an old x86-64 machine…installed ubuntu 18.04 and setting up as a retro gaming machine on kodi. I would like to use the osmc rf remote and dongle on this machine.

I managed to get it working via eventlircd but the left key seems to stick and repeat indefinately until i press other keys.

At first i thought it was to do with the way i’d set it up on ubuntu.

However, to try and debug the issue i’ve now tried using it back on the vero4k+ and i see the same behaviour.

If i run evtest against it then i see 100’s of events for the left key flooding the console.

I dont see the blue light flashing at the front of the remote when this happens, so not sure if the usb dongle has developed a fault. Any thoughts?

Further to this…with the left key event repeating indefinately i tried taking the battery out of the remote…it continued to repeat indefinately, so it seems to not be a physical issue with the left remote button.


Looks like you’ve seen: OSMC remote for Kodi on Linux - Play/Pause button not working then.

Try Hold Home and OK and to repair the remote and try the receiver in another USB port if you’re able.


I’ve successfully re-paired the remote a few times but no change.

I’ve also tried switching to the other usb port on the vero4k+ which previously had the ortek dongle inserted, but again no change.

I’m forgetting about the ubuntu box for now, and just trying to get the remote working again on the vero4k+

What I’ve found is that most (but not all) of the buttons, when pressed, will trigger their own correct action, followed by indefinately triggerring the left action. Seems to affect all buttons except play/pause, stop, volumeup & volumedown.

Have you checked the remote (especially the left button) for any dirt under the key?

Yes that was also one of my first thoughts. I pulled back the directional buttons last night and everything looked clean…hardly surprising since its been sat in a cupboard for months.

As mentioned, once it goes into an infinate left keypress cycle i can actually take the battery out of the remote and it will continue with the infinate left key presses. This makes me wonder if the usb dongle is faulty.

Not necessarily. Do you have another cell nearby?

I only have one Vero4K+ and thus I only own one OSMC RF remote and USB dongle.

The Ubuntu machine is located in a bedroom upstairs, and the Vero 4K+ is located downstairs in the living room. The exact same behaviour occurs on both devices.

When it starts with the never-ending left clicks…if I press some of the directional keys a few times then the repeating left click stops (can take several button presses).

The never-ending left clicks then don’t start again until I press one of the buttons on the remote… as mentioned this will trigger the correct action (x1), followed by indefinitely triggering the left button action. This is the case for all buttons except play/pause, stop, volumeup & volumedown.

If I run evtest when it’s doing the never-ending left clicks then it floods the console with messages to say that a left button click was received.

So as you can imagine, its basically unusable :wink:

Any other thoughts for things I can try?

I could try to capture the behaviour in a video if it would help?

Though I’m now thinking of just buying a cheap IR remote for my Ubuntu machine… especially if the returns procedure for the OSMC remote would entail shipping costs (it’s possible to pickup a cheap I/R remote for about a fiver). I was hoping to save a fiver by re-purposing the OSMC remote, but this is starting to look like more hassle than it’s worth :frowning:

By cell – I meant battery.
I can send you a new dongle. Send me a PM with your details.

Pretty sure I’ve got a spare lying around so will try with a different battery tonight

I’ll PM you should a different battery prove fruitless

Yep tried with a brand new battery and still the same problem. Will PM you @sam_nazarko with details for shipping the replacement

Cheers. I will send you a new receiver in the morning.


@sam_nazarko massive thank you. New IR dongle arrived today and working perfectly.

I dont know of any other companies that wouldn’t have insisted on me returning the faulty dongle and paying for the postage.

1 Like

RF :slight_smile:

You tried things; you’ve been very patient and you know your stuff and have helped improve OSMC in the past. You’re a brilliant customer. I’m glad we’ve managed to resolve things for you.

Shit happens. Shouldn’t be on the customer.

As always – any problems, let us know.


1 Like