OSMC with Noobs, no wifi


#1

Greetings, good folks!

I, too, have this annoying little problem.
There is one thing that seems a wee bit different with my difficulties than others:
I am running OSMC, as installed via NOOBs alongside Raspbian.

The good news is: I can freely and easily connect to my router with Raspbian every time.
The Bad news: No Wifi Love with OSMC.

I have tried the solutions above with no luck.
connmanctl installed, as well as usbutils.
Cat6 cable direct to the router so I can use Putty to connect and run those updates (including the update for OSMC itself to the most current version.

Perhaps I am simply missing a module for the Wifi itself that’s not the same code as the RPi3B (it’s previous iteration).
If there’s any info to that effect that can “easily” fix this, I’m quite open to its application!

Thanks in advance!


Could not connect to Wi-Fi
#2

Hi,

I’ve moved your post, as the original topic was year old and you mentioned yourself the issue was slightly different. Please could provide logs, so we can see if we can work out whats going on; details can be found here:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.


#3

Thanks for the friendly redirect, Tom!

The link you provided is dead (404 message page with the Pirate Bird) so I think someone may have moved it on you.

I am currently reinstalling NOOBs with Raspian and OSMC from the v2.8.2 repository in hopes that it has something functional within.
My previous installation used the v2.7.1 and may have been behind the times.

Once done, I’ll let you know if anything has changed.

In the mean time, if you have an updated link with instructions for gathering the Logs you’d like, I’ll read it and post once I have data to fill it with :slight_smile:

Again, quick summary: Raspberry Pi v3 B+ (the latest release). RPi3B+ Reference Info
Pi board is mounted in an “eleduino” aluminum case (I have had excellent luck with them) and powered by a CanaKit 5v 2.5A power supply.

NOOBs v2.8.2 as source OS, on a 32GB PNY “Turbo Performance” HC-I, UHS-3 MicroSD Card

  • Adding in Raspbian and OSMC with the Data Partition
  • Added in the Wifi info during install process (the image is supposed to have all the repositories…)

Also of note: I will be following the instructions from here to get Netflix up and running on this box. I also have purchased both Codecs and will add them appropriately to both Raspbian and OSMC.

So, wish me luck in my re-installation, and I’ll be back with info as I get it!
~Val


#4

Hi,

Sorry about the 404, its being looked in to, try this link instead:

These have been known to cause issues in the past, you are better off with an offical pi power supply.

netflix:

Post 4 has the current instructions, the whole thread is worth a read, as various issues have been fixed.

good luck with your reinstall.

Thanks Tom.


#5

Thanks for the Luck!

Sadly, there is still no Wifi Love to be found…

Re-install is complete, and the Raspbian is OK with Wifi, but not the OSMC.
With the Cat6 connected, I can run the updates and connect with Putty, so networking itself is not Borked, just the Wifi.
I have gone to the My OSMC and selected the following logs to upload:

  • /boot/config.txt (Pi only)
  • OSMC Packages
  • System Journal
  • Network Interface Configuration

Next, I have hit the "Upload Selected Logs Now… I have no idea where they go, but I have done so. Hopefully, this will land somewhere you will be able to find it easily.
Note: It looks like they went to “URL: https://paste.osmc.tv/biwuduvapu
The logs are there now. Hopefully that’s enough for you to work with.

I am probably missing something entirely too obvious here… I’ll blame my age, and move on :wink:

So far, all I have done with OSMC is add in the Codecs in My OSMC and try to connect a few times with the Wireless settings, enabled and uploaded the logs, then powered down.
The trippy directions for Netflix will have to wait until I get the Wifi up. After all, I may have to reinstall again, and I don’t want to go through all the steps too soon.

Please let me know if there’s anything else you will be needing for follow-up!

Thanks again!
~Val


#6

Hi,
:
Well it can see the wifi interface, so could please follow the instructions from this post:

And post any errors here.

Thanks Tom.


#7

Thanks for the reference links!

Just a quick note to let you know I’m a VERY Busy Guy this weekend, and it may be a bit before I get a chance to follow the directions and post more info.

Be safe out there!
~V


#8

Sorry for the delay, but here’s what’s going on so far:

I boot up and enter OSMC.
From my desktop system (not the Pi) I SSH in with Putty.
When I run the connmanctl command, I get the following:

Error getting VPN connections: Unit connman-vpn.service not found.connmanctl>

Now, I run the commands as listed in order. Upon trying to use the connect command with my Router, I get prompted for the network key, the the following:

Agent ReportError wifi_b827eb785898_426c61636b47617465_managed_psk
connect-failed
Agent request cancelled by ConnMan
Error /net/connman/service/wifi_b827eb785898_426c61636b47617465_managed_psk: Operation aborted

Next, I went into the OSMC menu option, and Logs, and sent the logs for Kodi Log, /boot/config.txt (Pi only), and OSMC Packages out to:
URL:https://paste.osmc.tv/ozupapejon

Then, I tried within the OSMC menu to connect to my router, entered the key, and the login attempt failed as well.
I re-sent the same assortment of logs again to:
URL:https://paste.osmc.tv/ufopotanaf

If you have more suggestions, I’ll follow them as best I can.

Thanks for the follow-up! I really want to use my newest Pi to it’s full potential.
I am also guessing that not too many folks have tried to the newest Pi as an OSMC unit, or there’d be more info and threads like this one out there :wink:


#9

We’ve got over 100k users so far of the Pi 3 B + based on stats, if that’s the model you’re referring to. We don’t know how many use WiFi or Wired. My guess is a lot of those users updated because of wired performance improvements.

I also tested the Pi 3 B + WiFi for a couple of months before it’s announcement.

Actually screenshotting or copying the full CLI output might be useful.


#10

Hi,

I think Connman is not liking some of your wifi settings on your router, could you check the following:

The Authentication method: wep, wpa1 or wpa2 (suggest using wpa2/wpa2 personal)
WPA Encryption: tkip or aes (suggest using aes)

Changing to wpa2/wpa2 personal and aes shouldn’t affect other wifi devices on your network, they should still be able to connect.

Thanks Tom.


#11

Thanks for the feedback, Tom!

OK, checked my router (A D-Link DIR-867 HW:A1 FW:1.00). currently running with WPA/WPA2-Personal.
No insights in my settings for the WPA Encryption, so I am unsure what it’s set to.
I do have my WPS-PBC Status: as Enabled.

I liked my older routers better. So much more control.
I’ll have a look into getting the CLI output again and post that when I get the chance tonight.


#12

Hi,

A quick google search has produced this:

https://eu.dlink.com/uk/en/support/faq/cameras-and-surveillance/mydlink/settings/router/how-do-i-secure-the-wireless-signal-of-my-dir-series-router

WPA2 Only - uses aes encryption which is ideal.

Thanks Tom.


#13

Apparently, this router does not have the option available for WAP2 Only (even in the Advanced Settings).

I’m going to assume it’s not going to be an issue.


#14

Hi,

for a quick test if you disable the wifi password (wpa/wpa2) are you able to connect?

Thanks Tom.


#15

Disabled the authentication.

Although I was able to connect, the “test” I performed was to run the Updates.
This produced errors and “certificate” issues that prompted me to “report these issues to the forums”.

After the reboot, I will fish out the logs and upload them, followed by re-enabling my Wifi protection.

If this little box absolutely HAS to be wired, that’s not the worst fate in the world. I just feel, if it has Wifi, it should work without having to just through too many hoops just to get online.

Rebooting after the updates has resulted in the My OSMC service being unable to launch and a sad face screen. Retrying has it up now. Also the unsecured Wifi is up as well. Slow as molasses, but it seems to be working at least…

Uploading the whole log set: URL:https://paste.osmc.tv/pegebohogi

And wifi resecured 'cause I feel naked with password protection off…


#16

Hi,

Wouldn’t worry about this too much, its just a skin helper issue, I thought it was fixed with the OSMC skin. Will get that looked in to.

I think this may your router:

If your router isn’t offering a choice between aes and tkip, its probably using tkip; this isn’t good.

If you can used wired I would, or consider upgrading router.

Thanks Tom.