OSMC's August update is here with Kodi 17.4 - OSMC

OSMC's August update is ready with a wide range of improvements and fixes to keep your OSMC device running in tip-top shape. Kodi 17.4 has been released with a variety of fixes, and OSMC now ships with this version.

This is a companion discussion topic for the original entry at https://osmc.tv/2017/08/osmcs-august-update-is-here-with-kodi-17-4/

Thanks again for the hard work.

My CI adapter is still missing after the August update. (“TVHeadend Build: 4.2.2 (2017-08-18T16:24:52+0000)”) When I toggle the details for TVHeadend it shows dvben50221 = no and I assume this should be yes for the CI to show up.

Package: armv7-tvheadend-app-osmc
Origin: OSMC
Version: 4.2.0-3
Essential: No
Depends: dvb-firmware-osmc, dvb-tools, libavahi-client3, avahi-daemon, zlib1g, liburiparser1, python-minimal, libhdhomerun1, bzip2, liburiparser1, gzip
Maintainer: Sam G Nazarko
Priority: optional
Section: video
Filename: pool/main/a/armv7-tvheadend-app-osmc/armv7-tvheadend-app-osmc_4.2.0-3_armhf.deb
Size: 7483376
SHA256: 717cbc0db730c8de643918da3d7ef69bc54a66f59815c6aed3e31d59c84dede9
SHA1: fd89d48425ede0822a22e0af089546d44bafba2c
MD5sum: 15c89bc31be050f6690c70e574e472cf
Description: TVHeadend for OSMC
Description-md5: 15e7cbc797ddd8df9e0bea00d126027e
Architecture: armhf
Installed-Size: 24175

Ooops - missed something out, and I didn’t have a CI device to test. More difficult than I thought…

Everything working well so far on the Vero 4K, so well that I just ordered another Vero 4K :wink:

1 Like

The update doesn’t work.
Osmc always reboots,and the bad smiley appears after each reboots.
I have a raspberry pi 3.
What I am doing now?
Thanks for your help

The news announcement is not for reporting issues!
Open a new thread and follow these instructions.

Unfortunately I don’t think we’re able to add CI support at this time.

Thanks for letting me know. Would be great if you could evaluate the decision again some time down the road.

After updating to kodi 17.4 my osmc can’t find my wireless network (Vodafone).

Anyone knows about this issue?

The news announcement should not be used to report individual issues. Suggest to open a new thread with detailed report. Also there was basically no package installed with the August update that would impact wifi connection.

Is there any reason why the August update is not available in the OSX installer?

I downloaded a fresh copy of the installer last night to create a new card for the raspberry pi 3 in English but the best update it offers me is July. I created the card using July and then updated to August via a manual update on the raspberry but it would have been easier if the August update was available on the installer to begin with.

Could understand if it was the beginning of the month and the update was new out but we are well into September now.

Keep up the good work your team does an amazing job!!

Well not directly related to the installer. The installer just goes to Download - OSMC to check for the latest image which is the June one.

Reason that there is currently no August image is most likely just time. As it takes time and resources to create all the images and as you may have seen here on the forum Sam is busy fixing people’s problems


I understand the eagerness to grab the latest image. They will be available shortly. As always, we add a delay to the release of images to ensure that they are first well received by users. However with this update things have been compounded by the fact that we are migrating infrastructure to support Debian Stretch.

I’m travelling for a few days but you can expect new images shortly.

Updating from an older version will give you the exact same results as installing the very latest image. Our focus is on supporting the very latest installs and ensuring continuity.


What am I missing? I went to download images and only see July 2017 images.

I moved your post here as the answer is just right here

Thanks. I’m having the issue where installation hangs at ‘Formatting Device’. Was hoping the newer image might have the same problem.

Try another SD card.
There are no changes to the installer; so there won’t be any solution for such an issue in the next image.


Wanted to follow up. I tried a handful of sd cards and all failed. All were 2gb. I thought it might be a power supply issue because I’d lost the original any wasn’t able to find one that was rated 2.5+

Finally I bought a new SD card and it installed. But since I’m doing a USB install I wanted to use a 2gb sd card. What worked for me was to install using the new SD card. After the install and subsequent first boot and setup, I powered down and cloned the partition from the larger working card to the smaller sd card. That seems to be working great and gives this 2gb card something to do.