Password is asked to get files on network windows smb

After installing todays update i get prompted to give username and password to get files from my pc. I have no password set on the pc to read or write files. How to get rid of this ? I have tried to reinstall the network, both wired and wireless with no result.
When using my raspberry there is no need for password and all works OK.

I must say I am rather disappointed with my new vero 2 and the difference with my raspberry 2 is not that significant that motivate the cost. Little better wireless and ability to watch 265 viedeofiles.

There was an update to fix a number of security issues in the Samba library. You can read more about it here: OSMC Security Update for OSMC 2016.04-1 and earlier - OSMC

If you update the Raspberry Pi, it sounds like you will experience issues on that device too. These changes are not exclusively for the Vero.

Have you tried the solution in this post: Can't reach my SMB shares after the last OSMC update! - #5 by maker3?

I am sorry to hear that. You should find the Vero 2 significantly faster than the Pi. H265 video decoding is important to some people, and will become more relevant as more videos are encoded in the format. We also have an imminent Android release which will let you use Apps like Netflix on your device.

Yes I have tried it and it didn´t work. Still prompted for username and password.

What to do next???

I believe you need to create an account with a username and password


God knows I have tried!
As I have no password on my windows PC , and I don´t want it, how to do then?
I have used smb for years on my raspberry´s and now vero2 with no problem.
Meanwhile I have used UPnP , but it is a bad solution.
Now I have put my vero 2 on the shelf awaiting a fix for the password problem and am sticking to my old raspberry Pi2 which is not upgraded with the latest problem maker.

You can see SMB Shares - Cannot Browse After Update.

You can create another account with a password, but hide this account, so your main account doesn’t need one.

I will work on a solution.

Thanks for that!

Now, a month later, are we near a solution?

The changes to require a password are now required due to security issues in Samba. This is unlikely to change in the future after discussing this with the Samba maintainers


Since I´m not a specialist on windows network installation, and God knows I have tried to get the required password in order without success, it would be a good help to get a step by step instruction how to do, so I could use my new Vero2 with the latest updates.


Everything you need should be here:

and here: How to Make Yourself an Administrator on Any Windows System

Let me know if you need some pointers. You can create the hidden account first, then you can follow ‘maker3’'s advice on how to add permission for your share.

Either read what Sam posted or check this out