Pi2 won't shutdown or reboot from UI

Ah thanks! Should have RTFM. :slight_smile:

Thanks for all the help and great work! :slight_smile:

Have a look at this thread for a discussion of hard mounts versus soft mounts in NFS:


IMO soft mounts are more suitable for mounting media shares, where if the sever goes down you don’t mind if playback of a video aborts and returns control to you, rather than causing a complete freeze until the server comes back.

Agree fully.

Hi all,

I have updated to the new version (OSMC_TGT_rbp2_20150315.img.gz) and this problem is back.

This is my fstab:

ratocloud.local:/nfs /mnt/RatoCloud nfs  x-systemd.automount,soft,retrans=2,noauto,noatime,nolock,nfsvers=3,intr,tcp,actimeo=1800 0 0

This is my screenshot when I’m trying to reboot:

Is this a regression bug?

Apart from that, really nice work guys with this release candidate. :slight_smile:

This problem was causing me serious issues but at least I now know that it was my autofs mounted NFS shares. I have lowered the autofs timeout so they get unmounted faster for if I forget to manually unmount first before a reboot.

Hopefully a proper fix can be made sometime.

As far as I’m aware, the problem of NFS shares not being unmounted properly before reboot/shutdown was fixed a long time ago.

If you’re still having a problem with this we need some more details. You say you’re using autofs to mount NFS - can I ask why, when systemd has it’s own auto-mounting service built in ?

There is no guarantee that autofs is fully compatible with systemd. Please provide your exact mount options and configuration, and if you can get a screenshot of the issue on shutdown that would also be helpful.

I never knew about systemd having its own auto mounting since my distro for all other systems doesn’t use it, it is new to me. I’ll look into how it works and maybe switching to that. I will not be home for awhile to test but the only autofs config I had was the basic adding of “/net /etc/auto.net” to auto.master with no specific configuration of the server itself. That just mounts anything exported when you go to /net/“hostname”

To use systemd’s automounter you just add your nfs share as a standard /etc/fstab entry, but add the following two options:


It automounts the share on first access and will automatically unmount during shutdown.

I may have to try that on one system for my main server, but leave autofs on also because it’s way more dynamic for when talking portable Pis out or other computers visiting my place on a temporary basis since no pre configuration for a host is needed

Here is my screen when trying to reboot after about 4 minutes of waiting after this roughly every couple minutes it repeats the last line and it has been 40 minutes without finishing and I’m about to just pull the power.
Up to “reached target shutdown” was immediate then 2 minutes later the next 6 lines showed up the 2 minutes later was the last line repeating every couple minutes for 20 minutes then nothing it has sat for 20 minutes
You can see that it tried unmounting before stopping the connection service but it also only says one line when 3 where mounted since the servers home directory (/home/xbmc) and two other partitions (/home/xbmc/{media,non.media}) would of been mounted at the same time.

I really would prefer to get this working then the static fstab entry

Edit: When do services get stopped. I just tried a test on a running system by running " ls /net/htpc" then with nothing actually accessing any of the files I tried manually unmounting any nfs share and got blocked every time. The I did a systemctl stop autofs and then they were gone. Maybe stopping the autofs service earlier could fix the shutdown.