Playback improvements for 4K HEVC UHD content

14 posts were split to a new topic: Without providing diagnostic data in the form of logs, your argument doesn’t help

Moved post to new topic

If there was a product out there which can play every 4K HDR content at every bitrate with every common network configuration and with HD audio passthrough I would say, yes, the Vero 4K could do better. But there isn’t (that I know of) and I see that Sam and the other guys are working hard to fix the remaining problems like this one or the flickering HDR content issues on LG TVs I’m personally having.

Pretty sure that all this stuff is fixed in the months to come and then this will finally be the perfect media player. And it’s already at 90%.

1 Like

I’ve watched many of my 4K rips and they’ve played beautifully with the only exception of the minor freeze in The Mummy Returns. And this will be fixed with this buffers change. I’m really happy with the Vero and the teams responses to fixing issues

1 Like

I have tried this fix because of issues with Gods of Egypt (buffering/slow/stuttering). It’s better, but the issue is still present unfortunately. Put the paramater to 10 to fix issues with skip forward.

To be complete: The file is playing fine from USB. I am using ethernet to connect to my Windows server (smb sharing). shares are connected with IP address directly, so no DNS translating.

This is likely a throughput issue and not what this fix was intended for. This was designed to fix specific freezes with certain movies (john Wick 2, Serenity for example) which seems to have been successful.

I would try mounting over NFS if you can, and using fstab instead of Kodi’s mounting options. I use NFS via fstab and watched Arrival on Sunday and it was flawless. Not sure how the bitrate compares to Gods of Egypt but there was no issue in terms of playback for me.

EDIT: Pretty similar bitrates for the video tracks on both which is all I checked against.

I will get the movie Arrival and test if it works oké at my configuration also. The error I get in a popup is “Source too slow. Read rate too low for continuous playback”. So you are probably right.

To be honest… I don’t want to change the way I connect to my movie share with 500+ movies and a lot of watched status in a central MySQL database which is shared with 6 Kodi implementations.

Exporting and importing of the database creates all kind of issues with local files and I am also using Kodi configurations wich aren’t based on osmc.

Currently I am using smb. I thought this is a fast option also?
Never had this issue with the Intel NUC which was using a gigabit ethernet port. Based on the forum I thought the slower ethernet standard of Vero 4K shouldn’t be any problem for 4K, but it might be an issue after all?

My advice is to get a USB to gigabit Ethernet adapter, something using the AX88179 chipset. They’re cheap.

Now this isn’t strictly necessary, the ethernet port on the Vero 4k is fast enough, but it’ll give you a bit more bandwidth to help out. Double what you strictly need for UHD playback.

If you’ve got a number of kodi clients already setup that may cause problems if you need to tinker to get better throughout. If nfs isn’t an option what about mounting the smb shares through fstab? that should give you the best smb performance, the client within Kodi isn’t well optimised.

You also might want to look at trying an iperf test to see how well your network is actually performing. The gigabit port might have enabled buffer free playback on your nuc, but that could be masking connection problems. In that the gigabit throughput might be pushing data fast enough to hide any dropped connection etc. this is what was happening on my network, I needed to replace an older switch.

With my adapter I can play all UHDs free of buffering problems using the in built kodi smb client (although normally I use nfs via fstab), but seeking and skipping is slower than mounting via fstab. Plus I spent some time making sure my network was performing as optimally as possible.

1 Like

Thank you for the advice.
I have a USB ethernet adapter which I will try if I can’t solve the issue with fstab for smb shares. Need to look into the forum to sort out how this works.

I found also some information about a cache option into the advanced.xml. Is this also helpful?


Would you mind elaborating why that chipset and not others like the realtek?

Simply because that’s what was recommended to me on this forum last year. Can’t quite remember why, Linux support and reliability I think. I get a solid 180/190 Mbit/sec with no drops on mine.

Ok cool. I have an Anker on the way to try and it’s realtek based. I’ll report what I get with it.

I can max out my 100 connection and hit 180ish on wifi in iperf. Oddly enough I found that any smb version other than smb1 in fstsb was only able to do 30-50ish on wifi. Wired was fine. Maybe smb2+ is more chatty and the increased latency bogged it down. (I had file permissions issues with smb1 going to a freenas cifs share)

A post was split to a new topic: Buffering issues with 4k File

I tried yesterday the Linksys USB3GIG and it works instantly.
Not sure if I will keep on using the LAN to USB, but will be testing for sure if it sort out some throughput issues I am having.

Does anyone know if with Kodi 18 SMB will perform better?

Hi Sam,

Never had any issues so far with any of the 4k files I threw at my Vero. I watched one yesterday though that seems to produce little but frequent and noticeable stutters.

I’m now going to test the improvements and report back.

EDIT: Stutters are still there. PM’ing you the details of the file so hopefully you can reproduce.

At some point in time performance with Kodi v18’s internal SMB mounting will likely improve as modernisation (VFS related) improvements are made.

I was having the same stalling/jerking/etc. problems playing certain 4K HDR content. The best (worst?) example was the documentary “TimeScapes”.

Initially, I was using the vero’s internal wifi, on a 5GHz band (too much interference on the 2.4 band). Then I tried an external wifi access point (attached to the vero via ethernet). That resolved all problems immediately.

I mention this because I had the same, but worse, problem with my RPi 3 (not with 4K content of course, just 1080p). When I used the external wifi, instead of the internal wifi, I had no more problems with transmission. I even tried a $7 USB wifi dongle, and that still worked. But not the internal wifi.

Just wanted to mention this.

Other than this, the vero works great.


What dongle dongle did you use?

Has the issue with pirates of the caribbean and gog2 atmos soundtracks been fixed where they dropout for a long time and at some points crash?

Is there a report of this somewhere?