Playback improvements for 4K HEVC UHD content

I will get the movie Arrival and test if it works oké at my configuration also. The error I get in a popup is “Source too slow. Read rate too low for continuous playback”. So you are probably right.

To be honest… I don’t want to change the way I connect to my movie share with 500+ movies and a lot of watched status in a central MySQL database which is shared with 6 Kodi implementations.

Exporting and importing of the database creates all kind of issues with local files and I am also using Kodi configurations wich aren’t based on osmc.

Currently I am using smb. I thought this is a fast option also?
Never had this issue with the Intel NUC which was using a gigabit ethernet port. Based on the forum I thought the slower ethernet standard of Vero 4K shouldn’t be any problem for 4K, but it might be an issue after all?

My advice is to get a USB to gigabit Ethernet adapter, something using the AX88179 chipset. They’re cheap.

Now this isn’t strictly necessary, the ethernet port on the Vero 4k is fast enough, but it’ll give you a bit more bandwidth to help out. Double what you strictly need for UHD playback.

If you’ve got a number of kodi clients already setup that may cause problems if you need to tinker to get better throughout. If nfs isn’t an option what about mounting the smb shares through fstab? that should give you the best smb performance, the client within Kodi isn’t well optimised.

You also might want to look at trying an iperf test to see how well your network is actually performing. The gigabit port might have enabled buffer free playback on your nuc, but that could be masking connection problems. In that the gigabit throughput might be pushing data fast enough to hide any dropped connection etc. this is what was happening on my network, I needed to replace an older switch.

With my adapter I can play all UHDs free of buffering problems using the in built kodi smb client (although normally I use nfs via fstab), but seeking and skipping is slower than mounting via fstab. Plus I spent some time making sure my network was performing as optimally as possible.

1 Like

Thank you for the advice.
I have a USB ethernet adapter which I will try if I can’t solve the issue with fstab for smb shares. Need to look into the forum to sort out how this works.

I found also some information about a cache option into the advanced.xml. Is this also helpful?


Would you mind elaborating why that chipset and not others like the realtek?

Simply because that’s what was recommended to me on this forum last year. Can’t quite remember why, Linux support and reliability I think. I get a solid 180/190 Mbit/sec with no drops on mine.

Ok cool. I have an Anker on the way to try and it’s realtek based. I’ll report what I get with it.

I can max out my 100 connection and hit 180ish on wifi in iperf. Oddly enough I found that any smb version other than smb1 in fstsb was only able to do 30-50ish on wifi. Wired was fine. Maybe smb2+ is more chatty and the increased latency bogged it down. (I had file permissions issues with smb1 going to a freenas cifs share)

A post was split to a new topic: Buffering issues with 4k File

I tried yesterday the Linksys USB3GIG and it works instantly.
Not sure if I will keep on using the LAN to USB, but will be testing for sure if it sort out some throughput issues I am having.

Does anyone know if with Kodi 18 SMB will perform better?

Hi Sam,

Never had any issues so far with any of the 4k files I threw at my Vero. I watched one yesterday though that seems to produce little but frequent and noticeable stutters.

I’m now going to test the improvements and report back.

EDIT: Stutters are still there. PM’ing you the details of the file so hopefully you can reproduce.

At some point in time performance with Kodi v18’s internal SMB mounting will likely improve as modernisation (VFS related) improvements are made.

I was having the same stalling/jerking/etc. problems playing certain 4K HDR content. The best (worst?) example was the documentary “TimeScapes”.

Initially, I was using the vero’s internal wifi, on a 5GHz band (too much interference on the 2.4 band). Then I tried an external wifi access point (attached to the vero via ethernet). That resolved all problems immediately.

I mention this because I had the same, but worse, problem with my RPi 3 (not with 4K content of course, just 1080p). When I used the external wifi, instead of the internal wifi, I had no more problems with transmission. I even tried a $7 USB wifi dongle, and that still worked. But not the internal wifi.

Just wanted to mention this.

Other than this, the vero works great.


What dongle dongle did you use?

Has the issue with pirates of the caribbean and gog2 atmos soundtracks been fixed where they dropout for a long time and at some points crash?

Is there a report of this somewhere?

Someone did post on the forum about it some point, I was hoping it would get looked at too.

I’ve got a sample that shows the issue.

It’s easily reproducible. I’ll up the sample after work.

Heres the Kodi and MyCE reports on it:

EDIT: However having looked at the recent replies on the MyCE thread it appears it may be isolated to just the two discs and possibly bad mastering on behalf of the studio. Still… they work on stand-alone players so it may be worth looking at if it’s an easy fix.

Not ideal but you can just set Kodi to Decode instead of passthrough for these films and the audio won’t drop.

Try the latest staging repository updates. We have some fixes for passthrough drops.

That doesn’t work for Atmos or DTS:X, you need bitstreaming for it.

Tried to play the german Jigsaw 4K UHD today and the buffer was empty several times while playing the movie, had to pause and wait several seconds for the buffer to fill up to watch the movie without stuttering.
The overall average bitrate of this movie is 81.1 Mb/s.

And no, it’s not a storage problem.

Hi Marc,

Just to confirm a few things:

  • This is a regression, and worked before?
  • You have confirmed that playback from local storage is OK

Can you please provide a Kodi debug log so we can look in to this further?