Playback improvements for 4K HEVC UHD content

Someone did post on the forum about it some point, I was hoping it would get looked at too.

I’ve got a sample that shows the issue.

It’s easily reproducible. I’ll up the sample after work.

Heres the Kodi and MyCE reports on it:

EDIT: However having looked at the recent replies on the MyCE thread it appears it may be isolated to just the two discs and possibly bad mastering on behalf of the studio. Still… they work on stand-alone players so it may be worth looking at if it’s an easy fix.

Not ideal but you can just set Kodi to Decode instead of passthrough for these films and the audio won’t drop.

Try the latest staging repository updates. We have some fixes for passthrough drops.

That doesn’t work for Atmos or DTS:X, you need bitstreaming for it.

Tried to play the german Jigsaw 4K UHD today and the buffer was empty several times while playing the movie, had to pause and wait several seconds for the buffer to fill up to watch the movie without stuttering.
The overall average bitrate of this movie is 81.1 Mb/s.

And no, it’s not a storage problem.

Hi Marc,

Just to confirm a few things:

  • This is a regression, and worked before?
  • You have confirmed that playback from local storage is OK

Can you please provide a Kodi debug log so we can look in to this further?



No, I never played this movie before, but several other 4K HDR UHDs with a rather high bitrate.
I did not play it locally yet. I may test it again with an USB gbit adapter in the next few days and run a debug log.

You could try the latest staging improvements first.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Failing that, we’ll need more information.

Seen this movie last month, have an USB gigabit adapter connected and no stutterings occured.

Yeah, I think it’s because of the 100MBit LAN. I removed my GBit adapter as I didn’t find anything that didn’t play as I got my Vero. But now I may install it again and leave it there.

Sam, this thread had some info on the ATMOS audio dropout issue being addressed on PC.

How do we get those fixes? :slight_smile:

(Second-to-last post)


We don’t use LAV filters, so the issue probably isn’t the same.
I’ll take a look.


The issue as it happens is the exact same with the Atmos dropouts.

Sorry – perhaps I phrased it poorly.

The symptoms may be the same but I don’t think the cause is the same.
We will look at it more closely – but from the commit I’m not sure it is applicable.

It is however being worked on,



OK will wait and see what you guys come up with. Thanks!

Are there any updates with the Atnos dropouts - its making a lot of Disney films hard to watch.

Not just yet. We were working on HRA improvements first

A post was split to a new topic: Vero hangs after a day in idle

Is this still a thing in 2020? The thread seems to be pretty old.

Is what still a thing? This thread is dead for 2 years. That would probably be a relevant clue.