Playing a huge .iso

40GB is a standard BD ISO size and should just play fine.
We’d need to see some logs to see why it didn’t play.

Thanks, I’ll try again. But how long should I reasonably expect it to be “working…” ? I would expect it wouldn’t be instant. But I must have waited > 1 min (maybe > 2).

What are you trying to play? Menus or the main title?

It shouldn’t take more than a few seconds to load.

Thanks. Still forcing quit after a min or so of trying to play that file. (btw trying to “play” to the menus I guess – hasn’t loaded anything) Here’s the log.

Here’s the error. “udf://nfs%…” ? Is that right?

2020-05-01 18:37:31.795 T:3747611360 DEBUG: CBlurayCallback - Error opening file! (udf://nfs%3a%2f%2f192.168.0.202%2fVolumes%2fSelamat%2fVideo%20%5bSelamat%5d%2fFeature%20Films%2fStar%20Wars%20Silver%20Screen%20Edition%20v1.6%20-%20ISO%2fStar_Wars_SSE_TN1_v1_6.iso/BDSVM/00000.svm)

In other unrelated, probably insignificant but curious issues:

• looked thru “manage dependencies” and there are a whole bunch of orphaned addons from OSMC. Any idea about that?

• after one reboot in testing the above, there is an exception related to OSMC updates (script.module.osmcsetting.updates) in this log. That log also shows attempts to open the .iso file in question, but debug mode wasn’t on. So it doesn’t show the same error.

• in both those logs, there appear to be errors related to accessing files with “/extrathumbs” at the end of path. I’m assuing that relates to some syntax in advancedsettings.xml (related to excluding from scan). I had experimented with that before and failed to achieve what I wanted – something about the name of the Extras folder – but have forgotten now. Is it important?

These aren’t full OSMC logs, so hard to tell

Sam

those are kodi logs. i’ll post thru the log uploader (and I am assuming here that’s what you mean), but i assumed that wouldn’t show anything because i have to force reboot first. that’s why i was uploading kodi.old.log.

OK here’s via the log uploader.

https://paste.osmc.tv/idegivujif

The log uploader grabs both kodi.log and kodi.old.log. If you think there might be something in the system logs you could upload the logs before you reboot by ssh’ing in and typing grab-logs -A at the terminal.

https://paste.osmc.tv/idegivujif

Do the extrathumbs/ directories exist?
If so – it looks like there are some potential connectivity issues here.

Sam

no those directories do not exist. please see what i said above. that has something to do with scanning for “extras” content, and is defined in advancedsettings.xml incorrectly. So it’s looking for nothing. However I assume it would look for that same nothing when browsing other directories.

There’s no connectivity problem. everything else can be accessed and played fine. (thankfully)

I’ll come back to the udf://nsf thing mentioned above too. Looks like 2 different file protocols there. I know what nfs is of course. but udf? is it trying to access a mounted .iso? (i don’t know how playing an .iso is supposed to work)

edit: just tested playing this on Mac VLC. Would not play on VLC because it’s encrypted and needs AACS libraries. Found those libraries and installed them, and it plays perfectly now. Does OSMC need those too? (I’d presume not, or already has…)

Hi Sam, et. al. I tried this again, after commenting out a line in the advancedsettings.xml file related to those “extrathumbs”. (That’s a future project to figure out.) Still in there I see, but seems this Kodi.log.old has more details about opening the .iso file in question.

Here’s the log of this attempt.

At the risk of bumping again, anything other ideas here based on the last logs?

Also still curious about the orphaned dependencies mentioned above. Unreated, but wonder if I can/should delete them.

I didn’t look in to it too much yet because the ISO is not a commercial rip and doesn’t appear in any legitimate form. I’m not sure if it could simply just be an issue with the way it was created.

Can you reproduce the issue with another commercial ISO?

I will try, but I need to get one first, so will report back on that later. But TBH, I’ve not much interest in keeping the size of bluray ISOs around. this one is “special”. And it did test playing on mac VLC just fine once I installed the AACS libraries. I dont’ understand that stuff, just following directions. The first thing to know is just is OSMC supposed to support these AACS encrypted .isos at all?

To play an AACS encrypted ISO, you’ll need to install the keys in to OSMC. Then it will work provided there is a key for your title.

See Vero 4k+ External bluray / AACS - #2 by sam_nazarko.

That is much more clarifying. TYVM.

How do we know if this ISO is really AACS encrypted though? It’s got the file structure mentioned above. It wouln’t play on Mac VLC until I installed the AACS libraries. However, it does play on Mac VLC, with that library installed, but without the keydb.cfg installed. (I had obtained one, but just removed it to test this.)

I installed that same keydb.cfg file as directed on OSMC (and of course it doesn’t have a key for this disc anway). Test playing with same results – eternal “Working…”.

I hope that info gives some clue to what I could do here.

Edit: I wonder if there is a need to mount this .iso first, and if this thread about udisks2 not being installed has any bearing?

I don’t believe that this should be an issue.

Hard to tell without the file.
Do you have another commercial Blu-ray to test with?

Sam

Yeah, I have a few commercial blu-rays. But this probably a dumb question, but how would you “play” a physical BR on Vero? Or are you suggesting I rip one to an .iso on the Mac and try that?

You can use a USB BR drive or a iso, Kodi will play either. If the iso was made without a program that stripped the copy protection then the keys are required the same as they would be with a physical disk.

I’m a bit confused on how this particular file would have protection included as it was not released commercially though. Do you have a usb drive large enough that you could try playing it locally just to rule the network out? Normally I think there might be a recommend to try to converting it with something like makemkv but I saw on some forum posts that people who were are to play the iso fine were not able to get this particular file to convert successfully.

To wrap this up, it seems that this is likely to be a problem with the way this particular bluray disk was authored. It’s not a commercial disc, and isn’t encrypted, but it contains a structure that confuses Kodi (has an AACS folder), and so it’s not really OSMC specific.

In the end, I used MakeMKV to extract the MKV files, and abandoned trying to play it as a bluray. That suited my purposes well enough, though the bluray menus and presentation is really well done.

Copying the files from the mounted ISO into a folder, minus the AACS (encyption) folder, did not work. It played the intro sequence, but got hung up in a couple different places thereafter and crashed. Log for the curious.

In the process, I learned about what’s required to play commericial blurays on OSMC/Kodi. (See sam’s post above, with link.) In theory, the right libraries are already installed by OSMC. WIth a properly installed and current keydb.cfg file for the keys, Kodi should be able to play a bluray .iso file.