Potential graphical glitches and freezes fix

@sam_nazarko. Just followed this again, exactly. This time did nothing post patch/upgrade instructions other than browse around default menus (not actually selecting anything). No mapping, no add-ons, just pure stock osmc on vero2. After a couple of minutes the screen froze, everything became fuzzy, pixels flaring all over, and despite just navigating around default osmc screen loud screeching sounds across audio.

Took it to mother in laws house, connected to her Sony (we have only Samsung TVs here), her cables, on top of the tv bench (full air exposure), etc… Same exact thing.

Now this happens consistently within a short time period. Anything else you want me to try and grab before I box it up for a month or so?

Hi, (sorry for my english),

Clean install (2016.02-4).

  1. 18°C (Montréal)
  2. Device is on table
  3. Confluence (less freez)
  4. No.

Now on 4.1, Problems appear to be solved. Will let you know if they begin to resurface. Nice job squashing these bugs!

Only issue so far is an occasional random audio pop while navigating menus

Oh Crud… Just froze, complete with pixel flares, locked image, quickly fuzzing image, and audio popping about 1 hour 15 min into our movie :frowning:

1 Like

Please provide relevant logs demonstrating the issue.

On the other devices when a log was needed the device was responsive, or at least could be accessed via SSH.

How the heck do I provide a log when the only way to obtain it is to hard boot the device once the problem occurs?


Sam, would you like me to crack the unit and try adding heatsinks to anything? I do not know if this is an issue or not, but willing to try if you want me to

Well if you upload logs it will also upload kodi.old.log which depending how “hard” the crash was will include some info on what might have gone wrong.
But it would definetly help to enable debug logging first (you can disable the onscreen part of debugging).

No, I don’t advise opening the device and trying to add a heatsink. It’s unlikely to be that, particularly if just playing content.

I would suggest you wait for the new images to be made available (couple of hours) and try a fresh one from that. Particularly if you had difficulties updating in the 1st place, as this may have caused some corruption

Sam

@ActionA & @fzinken
Well that did not take long: http://paste.osmc.io/okidoquzuz

When the image froze, the Vero2 crashed within about 2 seconds to a full off system. No SSH, no image/sound at all. Solid black. No recognized video by the TV.

Hard booted, uploaded log.

@sam_nazarko
Ok, I will NOT crack open the case then. I will attempt a fresh install tomorrow

2016.04.01 First 2 installs failed and never made it past initial install settings (screen crashing / freezing). Swapped to Vero 1 PSU, used windows installer to prep disc rather than usual linux, swapped to a different Sandisk SD card. First install failed, second succeeded. Manually mapped a single video share (rather than restoring from a backup). Played a different movie, failed within two minutes. First boot back up failed during OSMC splash screen. Third boot up failed playback within 10 minutes.

Did you try my suggestion of a different PSU? The Vero 1 will work fine.

I’m curious as to why these issues have cropped up suddenly

Sam

@sam_nazarko

I have indeed tried the Vero1 PSU Sam with no joy. The current clean install is on the Vero1 PSU and it still glitches up (although the audio pops while navigating the menu are no more!)

When I first received the V2 it did not get past the initial install screen upon the first boot. Attributing this to growing pains I gave it a couple days then installed the updates from the installer… it took a few times locking up along the way before it appeared stable. Over the next two weeks or so we watched a handful of movies – at first we had a couple of lock ups while not in use (I was guessing it to do with the previous CEC implementation)… and then the lockups became more frequent. At this point I came to the forums and found this thread.

Over the last 2 weeks the glitching has become more frequent. About a week ago I thought maybe it had something to do with restoring from a backup, but no joy. Even a stock install with NO restoring from backup, no mappings, etc at all would glitch out.

Installed 4.1 and other than some audio pops everything was again looking really good. Spent a chunk of time restoring from the backup, testing add-ons (pandora, ustvnow, ted), playing music, navigating menus, checking short movie blurbs. All looked OK. Watched the first full movie on the install and a bit over an hour it locked up again.

Now it seams to fail out within a short period of time consistently.

:frowning:

Newest image, did a factory restore. Problem still shows up (this time at the 11 minute mark of the movie).

http://paste.osmc.io/elanatinit

1 Like

Okay – you’ve waited long enough (I appreciate your patience). It’s time to get the device back and send a new one out.

Sam

Can you try with absolutely fresh Kodi and just streaming from the NAS with no add-ons whatsoever? @Guy’s box dies almost immediately, but I find it strange yours goes funny after a period of time.

I just want to remove as many variables as possible

Sam

@sam_nazarko
Vero1 PSU.
Fresh Install using brand new 8 GB SD card picked up at the local store just for this test.
First boot post install failed before I could map.
Hard boot
Mapped main video share
Video failed less than 5 minutes in
Hard boot
Vero2 PSU, different TV (using RP2’s HDMI & Ethernet cables), Video failed about 20 minutes in
Place back onto original TV with Vero1 PSU.
Failed during OSMC splash screen

1 Like

G’day Sam,

I’ve completed a fresh install to the latest version. The lockups and crashes after 5-10 minutes usage have still persisted as per previous reports. The attached log occurred after the last crash whilst attempting to scrap my library and not during video playback.
http://paste.osmc.io/eromawiviw

The main difference since the update is that it now locks up (no ssh or other inputs respond) as opposed to the full graphical glitch. End result is still the same though. and can only be resolved by powering down for an extended period.

1 Like

I notice in your log a lot of CEC errors, assuming you don’t use CEC to control the device, does it still crash if you disable CEC in Settings->System->Input->Peripherals->CEC ?

If that does not help, try putting the following line in /etc/rc.local (before the exit 0) then saving and rebooting:

echo 0x0 > /sys/class/amhdmitx/amhdmitx0/cec_config

Note, I’m not actually sure if this echo line will disable cec now that we’ve switched to libCEC in the most recent update and I don’t have a box at hand to test, but give it a try. If it does not help remove the line again.

@sam_nazarko
What else would you like me to try with the Vero2 Sam?

@sam_nazarko

At what point do we call it enough messing and move with an RMA (Order #398)??

Thanks