Problem mounting NTFS partition from USB HDD

I just tried it now using a different USB HDD, a Verbatim one, also with a Windows made NTFS partition and it auto-mounted at startup, it worked perfectly out of the box, and it saw all the media files, I was able to play them without problem using the Kodi interface. So does that mean that the drivers for the ADATA are broken or what?

I have a feeling it’s related to this message:

Oct 13 08:47:45 osmc udisks-glue[378]: Device /dev/sda1 did not match any rules. 

A search for this message always pointed back to the OMC forum, so it seems to be an OSMC-specific message.

This post, from Sept 2015, says that the message “means that the file system type could not be determined by udisks”. Perhaps @sam_nazarko can cast his mind back and recall what situations might cause udisks to be unable to determine the file system type.

That said, could you try this quick test. Reboot with the ADATA disk disconnected, plug it in, wait 20-30 seconds and run df. If it’s not shown as mounted, then try manually mounting it:

sudo mkdir /mnt/test
sudo mount -t ntfs-3g /dev/sda1 /mnt/test 
1 Like
osmc@osmc:~$ sudo mount -t ntfs-3g /dev/sda1 /mnt/test
Error reading bootsector: Input/output error
Failed to mount '/dev/sda1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.
osmc@osmc:~$ df
Filesystem     1K-blocks    Used Available Use% Mounted on
devtmpfs          377240       0    377240   0% /dev
tmpfs             382360    9968    372392   3% /run
/dev/mmcblk0p9  12693824  832144  11193828   7% /
tmpfs             382360       0    382360   0% /dev/shm
tmpfs               5120       0      5120   0% /run/lock
tmpfs             382360       0    382360   0% /sys/fs/cgroup
/dev/mmcblk0p8     80642   34816     45827  44% /boot
/dev/mmcblk0p1   1641536 1546784     94752  95% /media/RECOVERY
/dev/mmcblk0p5     30701   11450     16958  41% /media/SETTINGS
/dev/mmcblk0p6     69553   22192     47362  32% /media/boot
/dev/mmcblk0p7  14983556 4254400   9944980  30% /media/root
tmpfs              76472       0     76472   0% /run/user/1000

While neither might be entirely true, there’s clearly something about the disk that OSMC doesn’t like and, as you’ve discovered, the problem lies with this particular disk.

If you have the means to copy off all important data, I’d recommend that you do so and then reformat the disk. If it’s going to be used only on OSMC, I’d recommend you use the ext4 file system and format it on OSMC. If it needs to move between Windows and OSMC, then format it on a Windows system and stick with NTFS.

I formatted the entire HDD under W10 as NTFS with the Default allocation size and tried it again, and still no success. The console mount still gives the same NTFS inconsistent error message.

It might be a cable-related fault but, unless you can test with a substitute cable, I think you’ll just need to accept that this particular disk is unlikely to work with OSMC.

1 Like

One other thought. You could always try to format it on OSMC using the ext4 file system. You never know…

sudo mkfs.ext4 /dev/sda1

It didn’t work. It gave a few I/O errors and then hung on creating journal.

So it’s either a cable problem or a real harddrive issue (while that would be strange as it works on your WIN PC). So if we exclude both of that first points just would leave it to an incompatibility with your USB drive and OSMC.

@andreas.vitikan Could you try the drive with a reduced volume size, i.e. just start with the half of the “usable” size of the disk?

Use Window’s “diskpart clean” or a “sudo dd if=/dev/zero of=…” on OSMC to wipe the disk’s first few MBytes before setting up partition and volume, again.

Idea: I’ve had a WD Element hdd some time in the past where the disk USB controller reported 32 GB more capacity than available/usable in real. Dependent on the used IO stack some OS tries to touch the capacity end of hdd as well, since mirrored bootsector, $MFT using NTFS, etc.

Just try, then running out of ideas and you should not waste more time with this piece of hardware.