Problem with 4K@80mbps over the GIGABIT LAN

Whats the mediainfo for the file?
Please see the mediainfo section in How to submit a useful support request - General - OSMC

How are you sharing SMB or NFS?
How are you accessing from via Kodi or have you mounted via fstab?

Here the mediainfo
http://paste.osmc.io/etoroziwuj.vhdl
The shares on pc are SMB via fstab

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main 10@L5.1@High
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 1 h 50 min
Bit rate                                 : 65.1 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels

That won’t be a problem on 100Mbit Ethernet.
Some cache settings / using fstab might be needed though.

Sam

The first thing to note is that the overall bit rate of 72.1 Mb/s is an average speed for video and audio combined. Ttat’s the same as 9 megabytes per second being streamed.

Kodi has a video read-ahead cache where it tries to grab a few seconds (or more) of future video/audio data to allow for things like network slowdowns and, importantly for this discussion, to allow for transient increases in the bitrate (remember that 72 Mbps is an average figure).

By default, I have a feeling that the lates version Kodi only allocates 20 Mbytes of memory to the read-ahead cache but half of that it allocates to caching the video stream and half it allocates to the audio stream. So we’re down to 10 Mbytes for the video cache. Then for technical reasons it only uses 75% of that 10 Mbytes for read-ahead, which is 7.5 Mbytes. As you can see, we’re now running on fumes as far as video caching is concerned if your video is streaming at 9 Mbytes per second. Just 2-3 seconds or so at 120 Mbps will deplete the read-ahead cache.

So you need to ensure that your cache is reasonably sized. On the Vero4K you can set it to 512 Mbytes and it won’t touch the sides. Plus, as Sam says, use fstab to get the best throughput within the limitations of your network.

Thanks to all.
I’ve no idea how to do the following:
“you need to ensure that your cache is reasonably sized. On the Vero4K you can set it to 512 Mbytes”
and
" Some cache settings / using fstab might be needed though."

If I can help i’ve grabbed a log where there is a buffering and after some seconds the audio go out
https://paste.osmc.tv/nibunukafa

In the next update we’ll be changing the cache defaults to be more optimised for those playing higher bitrate content. This is a fantastic guide for how to set up Samba via fstab: New Vero 4K / slow network performance - #4 by TwentyWasHere

Sam

Thanks but I’ve already set SMB via fstab: in that post I’ve not found how can I set the cache to 500mb

Edit ~/.kodi/userdata/advancedsettings.xml. The file won’t exist yet.

Add

<advancedsettings>
<cache>
<buffermode>1</buffermode>
<memorysize>52488000</memorysize>
<readfactor>5.0</readfactor>
</cache>
</advancedsettings>

This will be included by default in the next update

Thanks.
One more question: since I already have the file with inside

<advancedsettings>
<videolibrary>
    <recentlyaddeditems>65</recentlyaddeditems>
	<importwatchedstate>true</importwatchedstate>
    <importresumepoint>true</importresumepoint>
</videolibrary>
</advancedsettings>

I must write
like that

<advancedsettings>
<videolibrary>
    <recentlyaddeditems>65</recentlyaddeditems>
	<importwatchedstate>true</importwatchedstate>
    <importresumepoint>true</importresumepoint>
</videolibrary>
</advancedsettings>
<advancedsettings>
<cache>
<buffermode>1</buffermode>
<memorysize>52488000</memorysize>
<readfactor>5.0</readfactor>
</cache>
</advancedsettings>

or like that

<advancedsettings>
<videolibrary>
    <recentlyaddeditems>65</recentlyaddeditems>
	<importwatchedstate>true</importwatchedstate>
    <importresumepoint>true</importresumepoint>
</videolibrary>
<cache>
<buffermode>1</buffermode>
<memorysize>52488000</memorysize>
<readfactor>5.0</readfactor>
</cache>
</advancedsettings>

ThanksPreformatted text

I assume the second one is the version you shall use.

2 Likes

The second one.

Thanks.
Unfortunately the problem is still there.
I fear that it is a problem of the file since I’ve checked it with VLC and found
that in the moment where the video start to play no smooth (and audio goes out and then return) the bitrate peak to 125000kbs and also to 134000kbs
Then it seems that files with an average bitrate around 70000kbs doesn’t play smooth on the LAN… for me a quite bad problem.

<memorysize>52488000</memorysize>

Er, that’s 50 MB, not 500 MB.

I’m glad it wasn’t just me… :wink:

You need to add another zero to the cache memory size.

THANKS !!!
Added a zero and problem solved!
Many thanks to ALL !!

Hi, new Vero 4K user here.
I am also struggling to play smoothly my 4K 70 - 80 Mb/a bit rate files from WD My Cloud. Nas is attached via fstab, cache is bounced to 500 Mb.
It’s not extra smooth.

We’re investigating some possible areas of improvement to the Vero4K’s read/caching mechanism that might help out with high bitrate files.

2 Likes

fingers crossed you find solution, I too have listed issues - now use my my nvidia Shield solely for the 4k playback which is fine.

bought the Vero - without realising it only had 100Mb ethernet - as I had hoped for all-in-one solution because the shield doesn’t do proper resolution / colour space switching

if you release a Vero mk2 please add gigabit ethernet :slight_smile:

How are you streaming these files (i.e. protocol)?
Mounted in Kodi or via fstab?

Hi
Via nfs fstab.