Problems with sound and pic after set up

I have looked through but don’t seem to be able to get any answers that would relate to my teething problems, but if some one knows a previous chat please let me know and i will go read up.
I have just received my vero 4k+, very happy with the box and looks like it will be great once i can set it up fully but two issue. The first problem is sound, connected to my pioneer receiver i can not get digital surround, true DTS or Dolby 5.1, from the box via the optical cable and can only get PCM surround ( which is not as good) if i use only the HDMI and disconnect the optical. I have tried various changes tot he audio settings and nothing seems to make any difference.
The second issue is picture, i can not get 1080p from files that i know are 1080p and even the Vero states the files is 1080p only 720p is being transmitted.
I have tried also HDMI connection direct to the TV cutting out the Amp and it still says only 720p.
my previous box was cable of upgrading 720p to 1080p but for this set up i have made sure i try full 1080p files, although i am sure i read in the support that Vero upgrades.
thanks for the help.
Cliff

I believe this wiki should help you to get the correct setting.

This is quite odd, check out belows recommended settings (while they should not impact 1080p they also don’t harm.
But to understand what the problem might be I suggest you upload logs via MyOSMC -> Log Uploader and share the URL here.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Hi fzinken, thanks for such quick responce. i shall follow the audio link. Meanwhile, i found the problem with the picture, the pioneer receiver HDMI, seems wont carry 1080p so i reconnected direct to the TV and then went back in to Vero to change the output settings which while I had tried on the amplifier and that would not work it has allowed me to change the setting if directly connected to the TV.
thanks again

Hi fzinken
thanks for the link for the audio but having followed this it does not work. connecting the optical out from vero to my Amp’s optical in provides only stereo sound and no DTS or dolby digital, my previous 10 yr old iomega does provide DTS via the same cable so i find this very odd. I would be left using HDMI to the AMP to get some sort of surround sound which then means taking a lower resolution picture and even then the HDMI is only providing PCM, not true DTS or dolby digital.
Perhaps i am missing something here but it does not seem logical that the sound from vero should be a lower quality than the ten year old media box i am replacing?
thanks again for the help
Cliff

So, you have strictly followed the appropriate chapter " When using the S/PDIF output of your OSMC device for audio" in link https://discourse.osmc.tv/t/audio-hardware-and-software-configuration/82441 ?

Especially the last sentence to disable sync playback to display is important otherwise passthrough is not possible at all.

In case the problem persists playing AC3 through the optical cable we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

  • please, also tell us the exact brands and models of your AVR/TV combination

Thanks for your understanding.

OSMC skin screenshot:

1 Like

Just so we are speaking the same language, PCM will not be lower quality than DTS or DD - I’m guessing what you are hearing is stereo only - to get 5.1 sound you either need to

  • turn passthrough off, use HDMI for audio and set the audio channels to 5.1 or
  • turn passthrough on, use TOSLink and set audio channels to 2.0, or use HDMI

720p is certainly unexpected - logs and a desciption of your AVR and display should enable us to sort that out for you.

Thanks for the help. So the disable sync playback to display is clearly already the default setting as it is not enabled and i have not adjusted this. As for the skin i have not added or changed anything since i got the box so assume this would be the basic OSCM. Im a novice so i thought (wrongly) i would simply set up the basic sound and picture before looking at the more detailed stuff. I will try to follow the log thing you are asking but seems a bit complicated.
in regard to the equipment the amplifier is Pioneer VSX-AX4AVi-G THX set up 6.1 surround, and a Pioneer Plasma TV.
traditionally all boxes and feeds have gone through the amp and then a HDMI out to the TV.
in the case of VERO i have connected the HDMI to the TV in order to get 1080p but the optical feed to the Amp provides ONLY stereo regardless of what setting i change in the Audio.
I can assure you i have changed both audio channels between 2 and 5.1 and pass through using all various options.
I can revert to putting the HDMI via the amp which will provide PCM surround but then i have to accept 720p picture because each time i try to change this in the Vero settings it refuses to allow me to set above 720p.
as you have requested i will try and sort out this log reporting option to get you more detailed info. and if i am able to understand it send you details of both set up options.
thanks
Cliff

I would suggest to connect the Vero to the AMP and AMP to TV as you had originally and the just simple go to MyOSMC - Log Uploader and share the URL. That would give us a first info of the capabiltites the AMP reports.

Check this, seems it had problems with 1080p but there might be a firmware update available

1 Like

okay, so i have enabled debug logging, i rebooted twice. i also did the log thing twice as thought i did it wrong first time.
URL: https://paste.osmc.tv/zajoyesimi (this is after i rebooted)
URL:https://paste.osmc.tv/igalaquxav (before i rebooted)

tried the sound and picture via HDMI through the Amp after rebooting to reproduce and same thing. PCM surround, it is not DTS or Dolby and while the surround sounds great with PCM because it comes through as PCM i am not allowed to make other adjustments such enhance the sound with THX and Neo 6 settings etc. This surely should be coming through as DTS if that is what the file is.
The issue about 1080p seems as mentioned by fzinken, a firmware update was made and i never got this, obviously the Amp is a bit old now and the firmware is not one listed on pioneers web site, i have emailed them and await a responce but this could take some time.
thanks again

You have typos in the urls you posted but the settings you currently have…

Dolby Digital (AC3) capable receiver: true
Enable Dolby Digital (AC3) transcoding: false
Audio output device: ALSA:default
Number of channels: 5.1
Output configuration: Best match
DTS-HD capable receiver: false
DTS capable receiver: false
Dolby Digital Plus (E-AC3) capable receiver: false
Play GUI sounds: Only when playback stopped
Allow passthrough: true
TrueHD capable receiver: false
Adjust display refresh rate: Off
Sync playback to display: false

Should be changed to the following…

Dolby Digital (AC3) capable receiver: true
Enable Dolby Digital (AC3) transcoding: true
Audio output device: ALSA:default
Number of channels: 2.0
Output configuration: Best match
DTS-HD capable receiver: false
DTS capable receiver: true
Dolby Digital Plus (E-AC3) capable receiver: false
Play GUI sounds: Only when playback stopped
Allow passthrough: true
TrueHD capable receiver: false
Adjust display refresh rate: On Start/Stop
Sync playback to display: false

Regarding your display it is only reporting support for 1080 60hz in interlaced format which is why it is not allowing you to select that. If your AVR and TV both support 1080 in progressive there is a way to force the output.

thanks darwindesign, perhaps you missed that bit where i said i am a bit dim…novice…how do i make those changes?

So the AMP reports following supported modes>

480p60hz
576p50hz
720p50hz
720p60hz
1080p24hz
1080i50hz
1080i60hz

So setting the GUI to 1080p24 or alternative 1080i60 should work (assuming that your TV can do that modes).
Can you connect directly to the TV and upload logs again to verify?

settings>player>video for the refresh rate
settings>system>audio for the audio settings

You may have to enable advanced or expert view in the settings to see everything.

so this is the bit where id like to give you both a hug, not allowed of course or buy you a beer.
so thanks for the audio settings by getting in to advanced i could change them as you advised and this worked. NOW knowing the amp has this issue with 1080p i reconnected, as you said, the HDMI back tot he plasma ( which i know handles 1080p and put the optical cable back in the vero to the Amp, now i have a 1080p pic and DTS 6.1 neo surround.
in case i am going mad below is the log following my changes.
https://paste.osmc.tv/epozapulus
thanks for the education and most important your patience with me

You can click on that link yourself. If it doesn’t display the logs for you, it doesn’t display the logs for us either. That being said, if it is working, then you very likely have your settings correct.

sorry to bother you but following the above audio adjustments i have enjoyed great sound but during the last 24hrs i have been looking at the different skins and adding and have switched between others skins back to OSCM, and some how i have lost sound completely. I have double check that the settings are all as you gave me, i have rebooted and checked for updates. I have disconnect cables and reattached. I can now only get sound via HDMI to the TV if a switch off passthrough, if i leave this on as before i have no sound at all on the AVR and only crackeling noise on the TV. this is very odd have i messed up something in OSCM and should i be looking too reinstall?
sorry about this.

In the bottom left corner, make sure settings are still set to ‘Expert’ so that you can see all of the possible audio configuration options; then verify they are the same as before.

Changing the skin should not change audio settings, however.

thanks Sam, done this and just double checked again. no sound via optical to AVR at all and just distortion to the TV via the HDMI, only way i can get sound is to switch passthrough off and then sound will come out of the TV via HDMI. really odd, is it possible i have changed something else while try to add files my library and screwed something up?

If you upload some new logs, we can see if audio settings have changed

Cheers