PVR IPTV Simple Client/Live TV XMLTV Guide Bug?

Hey guys,

I have done a apt-get update && apt-get dist-upgrade on my RPi3 recently…to keep it updated.

I noticed after doing this that when i press the guide button on my remote, it comes up blank with no XMLTV and channel icons.

I have Schedules Direct XMLTV subscription and this was working flawlessly and bringing up XMLTV listings when i pressed the button or selected the Guide option in Live TV.

I believe it may be a bug.

Thank you.


debugging logs, may shed more light.

Thanks Tom.

Thanks Tom,

Just tried to follow the link and it says server not found?


I’d not set the link up probably in my post, I’ve edited my post. Try clicking it again.

Thanks Tom.

i have just run grab-logs -A

Logs are available at:



    May 09 08:24:05 osmc mediacenter[322]: ImportError: No module named site
    May 09 08:24:08 osmc mediacenter[322]: *** Error in `/usr/lib/kodi/kodi.bin': malloc(): smallbin double linked list corrupted: 0x07f443d0 ***

    May 11 15:38:54 osmc mediacenter[322]: ImportError: No module named site
    May 11 15:38:59 osmc mediacenter[322]: *** Error in `/usr/lib/kodi/kodi.bin': free(): invalid pointer: 0x75de6ebc ***

It seems your setup is missing, site.py, this could be the result of data corruption. I would backup your settings, an reinstall osmc to sdcard. If issue persists you may need to replaced the SD card.

Thanks Tom.

I have already done this once before.

Are you saying the sd card is responsible for my XMLTV listings not showing up through the guide option?

i am trying a 2nd micro sd card now.

Will report back with results in around 10 minutes.

Same thing is happening in regards to the Live TV Guide, it still shows up blank sometimes, then…1 hour later, it displays correctly.


Can you please provide a new debugging, from the new sd card. So I can investigate further.

Thanks Tom.



22:12:36.844 T:1149236208 WARNING: COMXImageFile::GetCodingType progressive images not supported by decoder
22:12:36.888 T:1149236208 WARNING: Previous line repeats 1 times.
22:12:36.888 T:1149236208  NOTICE: LoadJpeg: unable to load http://thetvdb.com/banners/posters/111051-3.jpg
22:12:39.350 T:1048572912 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:12:39.460 T:1031795696  NOTICE: CVideoPlayerAudio::Process - stream stalled
22:12:39.490 T:1048572912 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

It seems rendering of images for epg, is being passed to the CPU, as the GPU can not encode it, This is normal; but for some reason its currently timing out. This is either issue with the plugin or a recent change in the osmc april update.

Could you please re-image osmc with march’s update (you can select this with the installer.) And confirm if your are still seeing the same issue.

Thanks Tom.

Hey Tom,

Thanks for being so helpful so far.

I can confirm that i have already run the last 2 versions since i have come across this and my issue is not there.

I think it may be an issue with the april update.


I’ve flagged with the developers. Sorry I can be no further help, as I’m just an osmc user; like your self.

Thanks Tom.

Hey Tom,

Thank you very much. You have been very helpful and i appreciate it.


@mattg13, did this get fixed with any subsequent update? Did you move to the August update yet? Can you still select a channel and view Live TV through TVHeadEnd? (I cannot… says no free tuners even though the HDHomeRun addon can show Live TV through the tuner).

@Tom_Doyle, looks like i have the same issue. My log files are at https://paste.osmc.tv/jiyilakame. If you wouldn’t mind, can you confirm mine issue is the same?

14:36:23.486 T:1724904432 WARNING: COMXImageFile::GetCodingType progressive images not supported by decoder
14:36:23.556 T:1724904432 WARNING: Previous line repeats 2 times.
14:36:23.557 T:1724904432  NOTICE: LoadJpeg: unable to load http://img.hdhomerun.com/tmsimg/assets/p191261_b_h3_aj.jpg
14:36:23.563 T:1430844400 WARNING: COMXImageFile::GetCodingType progressive images not supported by decoder

seems to be yes

Well, this is a deal breaker for me. I had to give up Win Media Center b/c Rovi took over the guide managment from zap2it and screwed me up. I need my Live TV especially now that American Football season has started. I’ll try another Kodi-based RPi option and see if it’s a issue with Kodi and/or tvheadend or specific to OSMC. I’ll keep y’all posted.

Edit: Well, I had an old SD card with OpenELEC 6.0.3 (I can’t readily find what version of Kodi this was built from) running Tvheadend 4.0.8 and i can at least add the adapters, muxes and services and tune to them with the channel lineup. I haven’t setup EPG (Guide) yet as that is a royal pain in the arse. It seems there is an 8.0.4 stable release as of June. It is built off of Krypton. I’ve been fighting with OpenELEC trying to backup the system with their backup/restore addon and i can’t figure out how to force an update. Once it updates to the new version, i’ll let you guys know how it worked out. I’ll also try and get the EPG stuff going and report on that.

Edit 2: So updating to 8.0.4 broke Tvheadend! I should have googled it before i attempted it. It seems there is an incompatibility now due to some shared libraries, namely libssl.so.3x. I have no idea if this is the same issue plaguing us here or not… that is beyond my level of expertise.

Edit 3: Tried a fresh install of OpenELEC (OE) 8.0.4 (Kodi 17.?) and Tvheadend still didn’t work (can’t connect to [IP]:9981). Tried a fresh install of OE 7.0.1 (Kodi 16.?) and at least i can connect to the Tvheadend backend via browser. Interestingly enough, the Kodi web interface changed to Chorus 2 at Kodi 17. This seemingly requires that you add the :8080 at the end of the IP address of the Kodi machine. Even after realizing this, I couldn’t connect to Kodi via browser at [IP]:8080 with OE 7.0.1 (Kodi 16) but could on OE 8.0.4 (Kodi 17). Both use Chorus 2 but something there changed.