Raspberry pi 3 OSMC chromium

I REAAALLLLYYYY Need to get a working web browser on my raspberry pi. It is currently running OSMC and i though i could get chromium on there? Is it possible to get it running and add it to the main menu?

I have googled this and can’t seem to find an answer. I have tried apt-get chromium but I get an error saying that it doesn’t exist or something!

This is as close that you can get in OSMC right now:

This will give you a chromium, but it wont play netflix, amazon prime or other DRM sources. And it runs “outside” of kodi.

I am currently trying this but when i run the command I get this error

converted 'https://raw.githubusercontent.com/zjoasan/x11-osmc/master/install_x11.sh' (ANSI_X3.4-1968) -> 'https://raw.githubusercontent.com/zjoasan/x11-osmc/master/install_x11.sh' (UTF-8)
--2017-04-05 19:09:31--  https://raw.githubusercontent.com/zjoasan/x11-osmc/master/install_x11.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)..., 2001:8002:e22:f002::f5ff
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)||:443... connected.
GnuTLS: A TLS fatal alert has been received.
GnuTLS: received alert [0]: Close notify
Unable to establish SSL connection.

Try http instead of https, seems like there is a problem with the ssl layer.

I Just dragged it onto my pi using ftp and then ran the command using ssh.

Nothing will break if i do that right?

Should be okey

How do I add chromium to my OSMC Home menu?
How can I tell if i installed it correctly? I installed it and then did a system update.

you have to enable the plugin, then someone with more kodi skills can tell you how to add a “Addon” to home manu. If enabled it will be under “Programs”, you wont be able to trigger chromium direct from kodi, it starts X-windows and then you start chromium from there. That said you wont be able to launch Chromium with a link to a webpage from Kodi

I have tried everything but I can’t seem to find chromium at all. I can’t find it in programs on osmc and when i go into console i had a look around and i can’t seem to find chromium at all…

Where is it installed to?

Okey this is how you should do:

Goto Settings, Add-on browser, My add-ons, Program add-ons, X11 launcher and enable the plugin.

When you have done that, you got an icon under programs, a “X with a penguin peeking up”, click that and you get a desktop, where you will find a chromium icon.

Hi Joakim_s

I installed lxde with chromium based on your instructions, but not able to launch Chromium. Lxde starts fine and I’m presented with the desktop and I also see the web browser icon in the bottom left corner. However, when I click the web browser icon it the screen quickly flashes red and nothing else happens.

Any suggestions that I could try to get Chromium to work?


Below there is instruction how to install chromium from ubuntu, since debians latest chromium seems to be bugged.