[RC] - Added WIFI adapter support requests - Official topic

Two adapters failing here wirh RC3, working with alpha4

Mediatek 802.11.n 150Mbps usb wireless adapter
Vid 148f
Pid 760B
Chipset RT2870

Ralink Technology, Corp. RT5370 Wireless Adapter
Vid148f
Pid 5370
Chipset RT5370

Are these no longer supported, or just temporarily missing?

Full debug logs please.

The RT5370 chipset is definitely supported. I’m not sure about the other one.

Hmm, tricky that. I can’t ssh in as the wifi doesn’t connect, and if I connect an ethernet cable, connman uses that, so no attempt to initialise the wifi. I don’t have a keyboard to plug in, can I put anything in config.txt or cmdline.txt to force a log?

You can turn on debug from system settings, and then shutdown, and boot with ethernet disconnected. This will create a log with the startup bits in.
You can then turn off debug (optional), shutdown and reboot with ethernet connected and get the old debug (kodi.old.log) which has those bits in.
I’ve probably made that over-elaborate, but you’ll get the gist
Derek

ok, managed that :wink:
Nothing apparetly useful in the kodi logs, the only comms related entry is…
00:05:24 T:1672729632 DEBUG: OSMC UPDATE COMMS: Comms started

dmesg for the 5370 says…
[ 2.431681] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[ 2.549078] usb 1-1.4: New USB device found, idVendor=148f, idProduct=5370
[ 2.549110] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.549127] usb 1-1.4: Product: 802.11 n WLAN
[ 2.549143] usb 1-1.4: Manufacturer: Ralink
[ 2.549158] usb 1-1.4: SerialNumber: 1.0
[ 4.741716] usb 1-1.4: reset high-speed USB device number 4 using dwc_otg
[ 4.852515] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 detected
[ 4.874694] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 5370 detected
[ 4.890849] ieee80211 phy0: Selected rate control algorithm ‘minstrel_ht’
[ 4.893237] usbcore: registered new interface driver rt2800usb

dmesg for the 2870 says…
[ 2.431577] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[ 2.542544] usb 1-1.4: New USB device found, idVendor=148f, idProduct=760b
[ 2.542582] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.542600] usb 1-1.4: Product: 802.11 n WLAN
[ 2.542616] usb 1-1.4: Manufacturer: MediaTek
[ 2.542632] usb 1-1.4: SerialNumber: 1.0

Are people having any strange problems getting the Edimax EW-7811UTC working reliably? It does seem to work some of the time, but hangs a lot during the scan of media when Kodi starts up, or drops off the wifi now and again. very random. I’ve updated to RC3 which doesn’t seem to have helped. Also using a good 3A power supply with the RPi2 with only a USB iR adapter, which if I unplug doesn’t help either. I also tried enabling the extra USB power Pi setting and using a powered USB hub which didn’t help either.

I’m wondering if my Edimax EW-7811UTC is faulty, however does seem to work more reliably near the router, although it’s not that far from it in the Lounge (one floor down vs one room away). I wondered about trying the EW-7811USC as this has a high gain antenna, but I’m not sure if this needs another driver or would help anyway?

Plus it works in my PC fine, and I get very good speeds ~20-25MB/s! with it in the same place in my lounge.

Or have I got a slightly different version of the EW-7811UTC, so the driver doesn’t quite match or something?

I believe this wifi dongle is draft ac, so maybe I need to try a final ac dongle. Which are supported/tested?

Here is my output… is something wrong the fact it says it couldn’t open device?

Bus 001 Device 004: ID 7392:a812 Edimax Technology Co., Ltd
Couldn’t open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x7392 Edimax Technology Co., Ltd
idProduct 0xa812
bcdDevice 2.00

Let me know how to provide more detailed logs if that would help.

Thanks

Bit more info on this problem. If I ssh onto my RPi2 as root I don’t get the “Couldn’t open device, some information will be missing” message when running lsusb -vvv…

Bus 001 Device 004: ID 7392:a812 Edimax Technology Co., Ltd
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x7392 Edimax Technology Co., Ltd
idProduct 0xa812
bcdDevice 2.00
iManufacturer 1 Realtek
iProduct 2 Edimax AC600 USB
iSerial 3 00e04c000001
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 60
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 6
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 2 Edimax AC600 USB
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x84 EP 4 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x05 EP 5 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x06 EP 6 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x87 EP 7 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0040 1x 64 bytes
bInterval 3
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x08 EP 8 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x09 EP 9 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Binary Object Store Descriptor:
bLength 5
bDescriptorType 15
wTotalLength 12
bNumDeviceCaps 1
USB 2.0 Extension Device Capability:
bLength 7
bDescriptorType 16
bDevCapabilityType 2
bmAttributes 0x00000002
Link Power Management (LPM) Supported
Device Status: 0x0001
Self Powered

I’ve also noticed the led on the dongle is flashing continously, crazily, all the time, even when it’s not trying to scan my media drives (SMB) or play anything. So much so, I think this sometimes locks up my 5Ghz wifi network that it’s connected to (some of the time at least). This clearly isn’t normal!

My router is a good one - Asus RT-AC66U and firmware up to date.

Is there any other commands I can use in ssh to see whats going on? It’s bizare that ssh type activity is fine though. Can I install the wifi driver myself? Not sure how though…

I turned on debug logging, got some big logs. Shall I upload them somewhere for review?

Please help!

Thanks

Edimax EW-7811UTC AC600 Wireless works in 2.4GHz mode. It doesn’t detect 5.0Ghz mode at all.

I think there were discussions around this that concluded that adapter was 2.4Ghz only.

Sam

No, it’s not: I’m using it with my RPi2, it connects to my AC router over 5GHz (AC), utilizing 433MBit (at best, usually 390MBit, 1x1 MIMO) and runs rockstable for hours and hours using OSMC RC3…

I have an Edimax EW-7811UTC and it does work on 5Ghz on OSMC RC2/RC3.

There is no way (without installing additional wireless tools) to force it to always connect on 5Ghz if you have the same SSID for both bands though.

But if like me you have a different SSID for each band you should be able to connect to the 5Ghz SSID without problems.

root@osmc:~# sudo apt-get install usbutils
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package usbutils

This is RC3 on a Pi B. The dongle I’m attempting to use is an rtl8191 300M of some kind. “Realtek RTL8192EU Wireless LAN 802.11n USB 2.0 Network Adapter”, according to Device Manager.

sudo apt-get update first?

P.S. check PM, you need to change your nick, potentially offensive.

Bus 001 Device 007: ID 0bda:818b Realtek Semiconductor Corp.
Couldn’t open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.10
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x0bda Realtek Semiconductor Corp.
idProduct 0x818b
bcdDevice 2.00
iManufacturer 1
iProduct 2
iSerial 3
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 53
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0xe0
Self Powered
Remote Wakeup
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 5
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 2
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x84 EP 4 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x05 EP 5 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x06 EP 6 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x87 EP 7 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x0040 1x 64 bytes
bInterval 3
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x08 EP 8 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0

Same here on Pi B with OSMC RC3. I tried compiling the provided driver, as well as the one you linked, but I’m Linux ignorant. I used:

sudo sh install.sh

This gave me MANY MANY MANY messages like:

/clean: Cannot change ownership to uid 400, gid 401: Operation not permitted

I eventually end up with some:

unexpected operator

and of-course:

Authentication requested [root] for make driver:
install.sh: 48: [: unexpected operator
bash: make: command not found
##################################################
Compile make driver error: 127
Please check error Mesg
##################################################
osmc@osmc:/media/E431-C359/V4.2.2_7585.20130524$ Compile make driver error: 127
-bash: Compile: command not found

Mine connects to my AC router over 5GHz (AC), utilizing 433MBit (at best, usually 390MBit, 1x1 MIMO) but DOESN’T run rock stable at all…

What router do you have?
What PSU are you using?

I’ve got a good router - Asus RT-AC66U and this dongle is 100% perfect on a Windows 7 PC in the same location.

Thanks

I’m using an AVM Fritz!Box 7490 (Germany here), said Edimax 600AC USB stick, RPi2 and a Samsung Tablet PSU (EP-TA10EWE, output 5,3V@2A) which occasionally gives me that coloured square in the top right of my TV anyway, but never made my RPi crash yet.

Keep in mind that WLAN AC (or 5GHz WLAN at all) isn’t capable of bypassing the same distance as 2.4GHz just can (penetration of walls, signal loss because of water conduits etc.) - in my scenario it has to bypass 2 walls, but the overall distance to the router itself is only ~3,5m…

So it’ll most probably depend on your environment - but as far as my experiences go, that stick simply runs rockstable and quite fast (I think it almost exhausts the RPi2’s USB bandwith, but I’m going to replace my mSD-card soon and the PSU and test further (GOD, THIS PI IS SOO MUCH FUN TO HAVE :slight_smile: ) using OSMC with it - which makes me believe that Sam’s/OSMC’s driver compilation just went pretty fine :wink:

Thanks for the details. Few things you mention are interesting, your using a slightly higher rated PSU than me, mine is output 5V@2A. However I never have seen a coloured square in the top corner on the TV. I’ve looked out for it as well. Also tried a PSU with an output of 5V@3A. In fact the PSU output 5V@2A seems more stable… slightly!

I’m thinking about buying a PSU off ebay the same as yours rated 5.3V@2A. Maybe that might make the difference?

Have you enabled the extra power option to the USB ports (can’t remember exactly how it’s worded) in the my osmc > pi config menu?

Mine has to go through a wall and a floor and probably about 3m away from the router. The thing is I know it’s not my router because the same dongle in my Windows 7 media PC right next to the RPi2 performs at 433Mbit like it should - I get a consistent 20-25MB/s. That is rock solid all the time.

I’m going to change my PSU to the 5V/2A one offered by the RPi foundation these days, hoping that this funny square will eventually never appear again…

No, I didn’t enable USB extra power yet, but am going to try that also after I’ve moved to a faster mSD card (SanDisk Extreme 32GB, already lying on my desk, but didn’t find the time yet).

My experience concerning the WiFi’s signal strenght is that I had to carefully adjust the RPi’s position: even a slight move might lower or raise it, so in the end I did put a short and flexible USB extension between the RPi and the Edimax stick to be able to ‘play’ with its position relative to my router…

Anyway, due to the fact that the mSD I’m using right now cannot write more than ~17MB/s when plugged into the RPi, I’m hoping to gain some more speed after changing it and raising the USB power.

This would be the best course of action before you begin to explore other causes for poor WiFi performance.

If you feel adventurous, then check out the new Pi SD driver thread.

Sam

Right I’m going to buy a PSU 5V/2A one offered by the RPi foundation and see if that helps me.

Sam, what new Pi SD driver thread??