REAL basics for a new user

Try NTFS. AFAIK Linux ignores NTFS permissions. This is assuming you want to keep the ability to use it in Windows without any workarounds. If your not planning on using it anywhere other than OSMC/Linux just use ext4.

Folks…I’m doing something wrong, I think. I would like to have two USB memory sticks mounted at bootup on my Pi 3B running OSMC. If I’m not mistaken the underlying OS is Stretch? The new USB 3 stick is 32 GB formatted vFAT. The old/current is USB 3 16 GB formatted vFat. OSMC seems to automount the 32 GB stick so I do see it, but I want it to be mounted as indicated below.

I have followed my normal practice for installing a USB memory stick and mounting a USB stick:

  1. ls /dev to get the USB sticks device name: in my case a USB 3 32 GB; sdb and sdb1, the other USB 3 stick (16 GB) is sda and sda1 is mounted as /mnt/usbdrive.

  2. created a mount point folder: sudo mkdir /mnt/MediaLib

  3. mount the USB stick: sudo mount /dev/sdb1 /mnt/MediaLib

  4. List the elements on the new USB stick mount: sudo ls /mnt/MediaLib
    Media Pictures System Volume Information history061420.txt
    which is, in fact, the content of the sda1 (/mnt/usbdrive) folder and not that for the new USB stick. which should be,
    ’System Volume Information’ Video

  5. I have these two lines to the /etc/fstab to mount the USB sticks, the first is for the sda1 partition and is working, second one is apparently not working
    /dev/sda1 /mnt/usbdrive vfat defaults,dmask=000,fmask=111 0 3
    /dev/sdb1 /mnt/MediaLib vfat defaults,dmask=000,fmask=111 0 4

    The results are the same for the tests in item 4. above

At the same time I have tried again to attach my new 64GB USB 3.0 xFat stick and it still crashed the OS with a message it can’t find the sda1 device.

This should all ‘just work’ and the drive should be mounted in /media for you automatically.

I’m not sure I quite understand the use-case, I know you want these accessible via the network but did you want to have the ability to move the USB sticks into other computers too?

Thanks for your reply. My issues are two fold:
1, I like my USB mounted devices to be in my /mnt folder and not in the /media folder.
2. And second, as it is working now with the second device automounted into the /media folder, I can not seem to configure SAMBA to give me full access from my Windows 10 PC. I need to be able to write, read, delete and create folders, but now it hammers me for an id and pw. This is not the case for my other USB drive. I have edited the SAMBA config files as I also did for the /mnt/usbdrive mounted device. The README in the /media folder says:
me@MediaServer:~$ cat /media/README
#### Notice ####

This directory is for automounted drives. Empty directories here are purged on reboot.

If you wish to configure an /etc/fstab mount for a drive that is attached permanently, you should do so in the /mnt directory
which is what I want to do.

In general, if I have full access to the device, it will always be attached to the OSMC Pi.

What I can not figure out is why I can not seem to mount this USB memory stick in my usual way via the /etc/fstab file entry.

USB mounting problem solved. Stupid user (me) error.

The problem with the 64GB USB 3.0 xFat stick is still unsolved. I will post it as a separate question…RDK