RedBear IOT pHAT for WiFi and BT

I am still working on this but have been AFK for a few days. The slow build time on the Zero does not help. Will try and spend some time on it this evening.

Left it running for 12 hours over night and still no finished build :confused:

This will take ages and maybe needs swap on a pi1 or zero.

You can build a kernel for this platform on a pi2 or 3, too though if you have one.
Then install the package on the zero.

Make -j 3
Is just so much faster. :wink:

Also, if you need to build on the zero itself, make sure to stop kodi and other processes that are not needed to conserve memory and cpu time.

@mcobit thanks for the tip, it certainly is much faster, the build actually completed this time. I am left with three .deb files:


Installing the image file on the Zero (sudo dpkg -i rbp1-image-4.4.16-5-osmc.deb ) gives me the following error:

Hmm. There is a symbolic link /lib/modules/4.4.16-5-osmc/build
However, I can not read it: No such file or directory
Therefore, I am deleting /lib/modules/4.4.16-5-osmc/build

I copied over the whole osmc folder to the Zero in the hope that would provide me with everything I need but it did not work either. Back to being stuck unfortunately.

I was able to install the kernel file but that didn’t seem to make any difference to my setup, lsmod provides the same output from before.


That’s not an error.

Just reboot and run uname -a, and you should find yourself on the new kernel. It’s just a message saying you installed an image only, instead of headers or complete sources.

That is good to know. Thanks @sam_nazarko. Output of uname -a is Linux osmc 4.4.16-5-osmc #1 PREEMPT Sun Sep 11 20:22:46 UTC 2016 armv6l GNU/Linux so all looks well there.

Running ifconfig does not show the new device and lsmod seems to show things are mostly unchanged:

evdev                  13895  1 
8021q                  21672  0 
garp                    7807  1 8021q
stp                     2218  1 garp
llc                     5918  2 stp,garp
uinput                 10165  1 
sg                     23990  0 
ax88179_178a           24752  0 
uas                    17270  0 
snd_bcm2835            23591  0 
snd_pcm               115645  1 snd_bcm2835
snd_timer              28675  1 snd_pcm
bcm2835_thermal         2435  0 
snd                    79485  3 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         3823  0 
bcm2835_wdt             4197  0 
lirc_rpi                8473  3 
lirc_dev               11251  1 lirc_rpi
uio_pdrv_genirq         3846  0 
rc_core                25864  1 lirc_dev
uio                    10288  1 uio_pdrv_genirq
fuse                  111723  1 
ipv6                  433779  36

I think I need to do some further investigation into what configs need changing.

I got the same board today hoping to add btaudio to my rpi 2 running osmc.

No luck there.
If I got this correctly, the system as it is now does not support the board nor btaudio.
Although the btaudio has a beta version that can be installed somewhere on this forum.

Basically, being myself unable to recompile a kernel, lacking the time and knowledge, I have to wait. Thank you for your work on it

I have been told that we need to support the following in the kernel:

The IoT pHAT requires SDIO and UART as the interfaces to the host MCU.
For Bluetooth, you also need to enable Bluetooth HCI UART protocol H4
driver as module.

So I am going to have another pass at this and make sure the above are met. It won’t be for a week or so though.

Thanks for taking time making it work. its been helpful to someone like me without knowledge in linux.

No good progress on this I am afraid. Still unable to get the OS to correctly see the device. Modified and original patch files are available in Dropbox case anyone else wants to have a try/see what I have tried:

Also decided to run a dist upgrade to see if that made a difference, the latest version of OSMC does not pick it up either. dmesg does show a glimmer of hope:

[ 2.125220] 20201000.uart: ttyAMA0 at MMIO 0x20201000 (irq = 81, base_baud = 0) is a PL011 rev2 - I think that is the board.

cat /proc/device-tree/hat/product shows the correct info too.

All out of ideas and :tired_face:

Same issue on the Pi Zero. Any progress on including this in OSMC?

I do not have the hardware and it is still unclear what needs to be done to add support

I’ll buy you one if you like? They’re very handy

I don’t have a use for this, and as I don’t have a Pi Zero, it wouldn’t help me get this up and running.

Thank you for the offer though.

how about those of us that use the rpi2 this addon board gives us the rpi3 features.