Regress to older versions

Latest version seems to break my PVR functionality, lsusb lists my 3 tuners but tvheadend cannot access them. Tried a fresh install rather that an upgrade, no joy. Pre Isengard worked perfectly, is it still possible to download an image of osmc before the upgrade?

Installer still has June version, right?

Yes - still June

While I can understand people want to downgrade. If we don’t work out what’s wrong, we will never fix the issue, and you’ll be stuck on that version forever.

We definitely need some logs here. Are you using the OSMC TVHeadend?


Yep, using the app store TVHeadend. My wife is giving me grief about not being able to use PVR so kinda wanted to fix it quick, but I guess I could weather the storm and try to troubleshoot. Will get onto it tonight after kids are in bed.

Since you’re looking this way Sam, thanks for all the awesome work you’ve done on this and raspbmc. You are a legend mate. As are all the devs who have pitched in.

1 Like

ok, so sitting here browsing through files on the pi, don’t really know what I should be looking for though lol. can’t see anything relating to dvb in kodi log, is there a tvh log?


I don’t know why it made a difference, but I trialed plugging tuners into different usb ports and now they all appear in /dev/dvb/ as adapter0, adapter1 and adapter2. Likewise they are available in TVH, however the Muxes all come back as fail after scan. installed dvb-apps and ran: scan /usr/share/dvb/dvb-t/au-Melbourne >latest_channels.conf and got:

scanning /usr/share/dvb/dvb-t/au-Melbourne
using ‘/dev/dvb/adapter0/frontend0’ and ‘/dev/dvb/adapter0/demux0’
ERROR: cannot parse’[CHANNEL]


and so on and so forth, a few pages of error: cannot parse.

I know tuners can work, they were up last week. Don’t get what the issue now is.

By the by, I did regress to June image to see if that made a difference, ran into the same problem?? weird. Am now back to Isengard

solved here: DVB-T dongle not working after 2015-08-03 update - #12 by Spasmodean apparently newest kernel wouldn’t play nice with my tuners