Remote "Double-Clicks" Following April 2019 Update

Same issue here after the latest April update. My IrDa remote which worked fine befoer the update now results und multiple key presses while my Logitech wireless keyboard works fine. A solution would be much appreciated.

The below is what I get on a single press of the left key on the remote:

2019-04-26 11:30:40.155 T:1916294704   DEBUG: Keyboard: scancode: 0x6a, sym: 0x0113, unicode: 0x0000, modifier: 0x0
2019-04-26 11:30:44.871 T:1895822048   DEBUG: CLibInputKeyboard::ProcessKey - using delay: 250ms repeat: 33ms
2019-04-26 11:30:44.871 T:1280258784   DEBUG: Thread Timer start, auto delete: false
2019-04-26 11:30:44.901 T:1916294704   DEBUG: Keyboard: scancode: 0x69, sym: 0x0114, unicode: 0x0000, modifier: 0x0
2019-04-26 11:30:44.901 T:1916294704   DEBUG: HandleKey: left (0xf082) pressed, action is Left
2019-04-26 11:30:45.139 T:1916294704   DEBUG: Keyboard: scancode: 0x69, sym: 0x0114, unicode: 0x0000, modifier: 0x0
2019-04-26 11:30:45.139 T:1916294704   DEBUG: HandleKey: left (0xf082) pressed, action is Left
2019-04-26 11:30:45.165 T:1916294704   DEBUG: Keyboard: scancode: 0x69, sym: 0x0114, unicode: 0x0000, modifier: 0x0
2019-04-26 11:30:45.165 T:1916294704   DEBUG: HandleKey: long-left (0x100f082) pressed, action is Left
2019-04-26 11:30:45.198 T:1916294704   DEBUG: Keyboard: scancode: 0x69, sym: 0x0114, unicode: 0x0000, modifier: 0x0
2019-04-26 11:30:45.198 T:1916294704   DEBUG: HandleKey: long-left (0x100f082) pressed, action is Left
2019-04-26 11:30:45.207 T:1280258784   DEBUG: Thread Timer 1280258784 terminating
2019-04-26 11:30:45.215 T:1916294704   DEBUG: Keyboard: scancode: 0x69, sym: 0x0114, unicode: 0x0000, modifier: 0x0

Same problem here with two Vero units both with an FLIRC - both units are now unusable :frowning:

Could someone kindly explain to me what is the advantage of using FLIRC instead of the build in IR reciever of the Vero?
Not that this is a solution to your FLIRC issue but I would like to understand the reasoning of the FLIRC usage?

Flirc you can easily program your remote buttons to any function from any remote. Using the built in IR receiver, im guessing your limited to the Vero remote.

No, there is no relation between the Vero Remote (which is RF) and any IR codes that a IR Remote sends.

I have been using FLIRC since my RPI days. When I moved to Vero 4K, I just moved them over as they worked and were setup on my Harmony. However, I have just pulled them out, reconfigured Harmony to OSMC, Vero 4k and everything is now working - no double-clicking etc. :smile:

1 Like

Same here… I use an old Sony universal remote with FLIRC, and I’ve found that if I’m extremely quick with my button presses I can get it to only register a single press.

I wouldn’t be opposed to switching to the OSMC IR receiver, but I don’t see my remote in the list of remotes in My OSMC. Could someone point me to a post or wiki page that explains how to create a new lircd.conf file for my remote? Or… I guess it might be easier to set the universal remote to emulate one of the existing remotes in the list, then use keymap editor to fix any irregularities (?)

Thanks

I guess you might find one here
http://lirc-remotes.sourceforge.net/remotes-table.html

Most likely it’s the easiest to do that.

Hopefully we get an update on this soon.

Sam

Someone mentioned that this didn’t affect LE; so I’ve asked the LE guys about this.

  • FLIRC is handled in the same way it is on OSMC (by libinput) in Kodi v18; so there aren’t differences there.
  • One developer said that he had issues with the FLIRC repeating presses were resolved by a firmware update.

@dbmandrake has a FLIRC, so I’ve asked him to test with his Harmony and report back.

Sam

I’ve had a look at this with my Flirc and Harmony One remote and I’m not seeing an issue, however I know what it probably is. It’s not related to inter-key delay in the flirc - that has nothing to do with it.

Harmony remotes by default continue to repeat the IR code for quite a long time after you release the button. This can be adjusted on the following screens for the device that you have assigned to the Flirc profile:

image

image

From memory the default is either 2 or 3. I find with most devices (including my Xbox One) that the default repeats for too long, so long ago I reduced the repeat setting to zero as shown in the screenshots.

The repeat delay in Kodi is now 400mS - we’re not sure what it was before, it may have been controlled by settings in Linux itself, however I’m pretty sure it was more than 400mS.

If the remote continues to repeat the IR code for longer than the Kodi repeat delay you will get a duplicate press no matter how briefly you press the button on the remote.

So it’s a combination of Kodi having too short a repeat delay and the remote repeating the IR code for too long with a short button press.

For those using a Harmony remote you could try reducing the setting I’ve shown in the screenshot to zero for the “device” that your Flirc is configured as, this should solve the problem. If anyone tries this with their harmony remote can you please let me know what the repeat setting was set to by default (2 or 3 I think) so I can set mine this to test the problem further.

I’ve also asked @sam_nazarko if he could create a test build with Kodi’s repeat delay increased to 600mS to see if this will solve the problem without any changes on the remote side, as some remotes may not be able to have their repeat delays adjusted.

1 Like

I need the VID/PIDs of FLIRCs to make some changes.

Can affected users please:

  • Post the output of lsusb (install usb-utils first)
  • Confirm if they have FLIRC 1 or 2

I have the FLIRC 2. I don’t know how to do the first thing you ask, install usb-utils etc. I’m happy to go back through the upgrade and do what you need if you can post directions.

My remote is a remote used by a satellite TV vendor in the UK but it perfect for media boxes like Kodi / OSMC due to the buttons it contains, when mapped with FLIRC. It does mean however I can’t adjust the repeat time as mentioned a post above.

Remote here for anyone looking for a good option: https://accessories.sky.com/catalogue/products/sky-terabyte-remote-control

ok, I’ve upgraded to the latest release again.
Logged in to the OSMC box via putty and ran:
Sudo apt-get update
Sudo apt-get install usbutils
lsusb

the output is:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 20a0:0006 Clay Logic
Bus 001 Device 002: ID 0bda:8153 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have 1 USB extender cable + FLIRC 2 plugged in, plus 1 USB > Ethernet adaptor

When I remove the USB extender cable nothing changes on the lsusb output

That’s it.

I try to reproduce the problem, but i am not able to.

my setup:

  • RPi2
  • just installed 2019.04-1 on a fresh SD card
  • FLIRC Gen1 Firmware 3.7.0 (FLIRC software 3.22.2 wants to update to 3.9.00)
  • setup 3 years ago with FLIRC Software 1.4.3 and doing clear config and erase all (no further config)
  • Harmony Elite with profile FLIRC Kodi
  • @DBMandrake in the new config software is a reset to default button and that one sets min repeate rate to 1
  • FLIRC USB id Bus 001 Device 005: ID 20a0:0004 Clay Logic

Should i test something else except updating the FLIRC firmware and see if the new one hast the problem? Does anybody know how to downgrade FLIRC firmware, so that i can go back to 3.7.0, then i will test the latest one.

Edit: Same on my Vero 4k+. I can not reproduce.

@DanOnline @steamship @JJK9 @new_account @darekk @PhilC @dnwhoop02 and anyone else having problems with unwanted repeats after the last update.

We think we’ve identified the cause and a potential fix for this problem. If you want to try the fix ahead of time and give feedback as to whether it fixes it for you please try the following:

Via SSH first install the ir-keytable package:

sudo apt-get update
sudo apt-get install ir-keytable

Next create a udev rule file by creating a new blank file in nano:

sudo nano /etc/udev/rules.d/70-input-repeat.rules

Then copy and paste the following into nano:

ACTION=="add", SUBSYSTEM=="input", KERNEL=="event[0-9]*", GOTO="start"
GOTO="end"
LABEL="start"

# don't change eventlircd device settings
ATTRS{name}=="lircd", GOTO="end"

# don't change settings of rc remotes
SUBSYSTEMS=="rc", GOTO="end"

# set default repeat delay to 500ms like rc remotes
RUN+="/usr/bin/ir-keytable --delay=500 --period=50 --device=$devnode"

LABEL="end"

Save (CTRL-X then Y) then reboot. This should change the repeat delay and repeat rate (period) for any keyboard-like devices including flirc.

The repeat delay and period can be customised by editing this file and rebooting, however I think the suggested default of 500 and 50 should be fairly optimal. Please let us know whether this fixes the problem for you.

(For reference the default OS values before applying this change are 250 ms for the delay and 33 ms for the period, so a much shorter repeat delay and a faster repeat rate)

1 Like

That’ll be why you’re not seeing a problem. I tried increasing my harmony to 3, which started causing the issue on almost every press, but with it set to 0 (my setting) or 1 (your default) I didn’t see a problem.

From what you say it looks like 1 is the default in the new harmony software for new configurations - in the old software it was (years ago when I set up my remote) definitely 2 or 3 as I always found I had to reduce it on most of my devices, not just Flirc.

In any case we found that the new default repeat delay was only 250ms - which IMHO is far too short. This default actually comes from the Linux OS itself, probably in the source code for the keyboard device driver in the kernel, however we can override it as in my previous post.

Even though you’re not having a problem you might want to try the suggested fix to ensure that your remote still works well. (Mine does, both set to 0 or 3) What you should notice after applying the fix is that there is an obvious increase in the delay between when you press the button and it starts repeating, from 250ms to 500ms.

Testing this by pressing and holding up or down on a list of Movies/TV Shows is probably the best way to notice the difference.

Guys…

You’ve nailed it with the above. Perfect and back to how it was in previous version of Kodi / OSMC.

Many thanks, amazing support as always.

I haven’t updated my libreelec build to Leia yet, as I was worried I’d have the same issue. Can I apply the same fix to them if it has the same key repeat issue?