RPi isn't working with Rapid IPTV streams


The issue in short: same IPTV stream which works with VLC on Windows
, and works with Kodi on Android is not works with Rpi.
For the log: all devices are in the same network, using the same account
, conecting to the same stream for test.

What you were doing when this issue occurred:
I have contacted with Rapid IPTv asking for a check of any blockage of the service.
Because the demo account supports VLC player only, I was assuming they may out filtering rpi
with useragent filter on their apache/tomcat/iis.
The conducted a log check based on my IP address while i was keep trying multiple times,
the result was there is no block on the connection on their side.
(according to their techsupport).
I have also purchased Mpeg2, and VC1 license to be sure that is not the issue. It wasn’t.

**Whether you can replicate this issue on demand. **
**If you can, then please provide some steps on how an OSMC developer **
can reproduce the same issue.

To reproduce the issue you need to setup the Rapid IPTV service.
(not a demo account, but at least the one month subscription).
Once the IPTV Simple Client and Live TV configured all the channels were recognized
, EPG works as well.
When I start to play i see the “loading circle” for about a second, then nothing.
No error message visible, so I am not sure is the debug will actualy show anything or not.
None of the streams are playing, neither the VDO files.

I can replicate the issue on demand, and I am also to provide any kind of logs, just let me know
which logs I should give, as I am not really sure this is really a problem or RPi or not.

The device you are currently running OSMC on:
Raspberry Pi details:
Rpi 3 , 293Mb free memory, with Open Source Media Center running Kodi 16.
OMSC 2016.08.01. kernel linux 4.4.16-4-osmc
CPU ARMv7 rev4 (v71)
HW: BCM2709
Rev: a02082
PVR IPTV Simple Client version 1.12.14

What peripherals are attached to the device?
TV connected via HDMI, network connected via LAN cable, using tv’s remote control over HDMI 1.3

Has this issue been introduced by a new version of OSMC?
When did the issue first appear and can you recall a time when it was not present?
This is a new subscription, i can’t neider confirm or deny whether this was working earlier or not.

My logs :

Problem in details:

I bought a iptv package from Rapid IPTV. The all streams and VDO work on VLC (Windows PC)
, and with Kodi (16.1) for Android.
But I cant seem to get it to work on my Raspberry pi 3 with OSMC installed on it.

I bought and received the MPEG2 and VC1 licences and entered it into the Rpi.
I have checked them, and they are active,but this has not solved my problem.

I use the simple iptv pvr addon that comes with OSMC and enter my m3u link.
It loads all the channels and I can see them in the live tv list.

When I try to play a channel a “loading circle” appears for a second or two and then disappears.
None of streams starts.
I have tested RPi with free stream sources and they are all working fine only this providers streams got issues
, but all of their streams.

I was able to check on my firewall that by the time i start to play a stream there is a short connection
probably an intialization, then the rpi disconnects.

Same stream works from Android (Kodi 16.1), and from (PC by using latest VLC player).

When I start to play I see the “loading circle” for about a second, then nothing.
No error message visible, so I am not sure is the debug will actualy show anything or not.

please let me know what other test should i do , and i am happy to provide anything
to be able to sort this problem.

Thank you in advance!

PS I’m a total beginner on Linux

i have same problem bought licences but when i launch stream cpu goes to 99%

Is it possible at least to tell me whether it will be anyone who will actually check my post ?

In worst case if you give me the source code i will find out what causing this, as I did not see any movement with this post at all.

I wonder are there any developers left for OSMC Rpi device.

@emarosvari sry this is not an OSMC Issue there has been questions on Rapid IPTV before and @sam_nazarko said that exact thing in this post

so please contact Rapid IPTV for support

If you check the post I wrote down that I did contacted with Rapid IPTV. They state that there are no block on their side.

The stream what they provide works on Windows VLC, works with Kodi on Android 4.4, works with Synology NAS using DVBLink (this way works with OSMC as well), but with the IPTV Simple Client it isn’t.

I have event tried to trace down what could be the issue. All i know the Rpi connects with the source, gets a few bytes, and disconnects.

I am happy to provide any log what may needed but I do not know how to continue. I doubt that this is a Rapid IPTV issue, as this happens on OSMC with Raspberry Pi.

The stream they provide looks alright, standard MPEG2 stream.

Well here is the deal as @actiona also said in the same thread, how can any provide give access so cheap to every premium channel out there, there is a question of legality here thats why your thread hasnt gotten alot of attention.

try other legal streams that provide mpeg 2 stream too see if there is the same issue there, my guess is that you wont receive support here for a rouge streaming site.

ps. and its probly not OSMC that has the issue its Kodi

If you catch this from the ethical side, then yes, it may possible that this service is not going to be a long solution. But that is not my point. Let put it in a format where there is a stream which isn’t working. Let’s say there are no error message, no feedback about the cause. It’s just doesn’t work.
How to check it? How to find out whether this is a bug in the code, or a system error, or a service error ?

I have used the google to find some available .ts sources, and they were working with the Rpi. But this not event starting.

Which even further confirms the point that the problem is not with OSMC.

I love this attitude on this forum. Really. It reminds me to a much much larger company’s help desk.

My question was how can I be sure that this is not a bug? How to make any further logs? or how to test it?

Like if i would be able to change the “useragent” of the connection to emulate a vlc player and if that would be work then i can go back to them state that “hey its your fault”.

At the moment both side says its not us, all works fine. Well obviously it isn’t, and as I read about this on the internet i think I am the only one so far who actually posted any logs regarding this. I am the only one who provided step by step description how to reproduce the case. But I really do not see anyone who actually want to try it.

If it would be my code, i could do a debug, and maybe I should start to learn it as it would take less time to solve this problem than to wait someone who is actually checking what i say, and not just copy and past some zen saying.

Have a nice day!

again if the IPTV stream was working for other streams and not for that stream then logically it must be an issue with the stream.

from what ive seen when googling the “provider” ive seen many users with issues from that “provider” since i dont have an acc its hard to see if that is a fact but my mpeg2 stream works without issues although they are from legit providers.

Hm. I’m not sure whether your last post is meant to be sattire or you didn’t think it through fully.

If you can show me how to replicate it step by step here, I’ll take a look. But I don’t have an account with this company.

You say that you want us to debug, fine. But do you expect us to pay a subscription fee for this service to look at an unconfirmed problem? Your contract is with them, not us. If they’ve promised support for OSMC or Kodi, it’s on them to get it to work. I don’t have the time, money, or patience to work with every pirate stream provider to help them sell more subscriptions.

If you’re forking over cash, take it up with them first. I’m not sure why we should have to pay a subscription to prove it’s not an OSMC issue but they can’t download a free copy of OSMC and check the issue themselves.

It’s also worth trying a Krypton test build and seeing if this helps

At the moment I am in a position, where both side saying it’s nothing to do with their system. I do have an account, and I said I am happy to create any kind of logs what may needed to find where is the problem. I would be happy if it turns out that its not OSMC which got problem. Then i would have something in my hand proving that it’s their service. But at the moment all i can say that yes i see a circle for a short periode of time, then nothing.
Well at this point it could be anything.
And I do admit it seems that if it works with other streams but not with this one it could really mean that its their fault. However it may possible that there is a problem, and would be visible from the logs, if someone would check it, or tell it to me how to do it.
I am not asking help because its easier to pass over a problem. I am asking help because I got to a point where i can’t do more without external help.

Try a Krypton build. There is better handling of streams that redirect in this version

Before I have reported this issue, i did a long long search checking from linux side, checking from service provider side, checking other entries which may help. Go and link from this site any post which is related with IPTV, with this IPTV provider, where you can find any attached logs, or proper steps how to reproduce the problem.

I did not say you should debug it, i was asking what additional logs can i provide, how to do it, and how to help to solve this issue. This isn’t the same thing. I was and I am really open for any help just want to know what is the actual problem. I am not expecting any of you to run, and buy a license. But I am sure if the problem escalates deeply enough i may be able to ask them to provide a test subscription to test with it.
I do not want you or anyone to help with any pirate subscription, or service to grow or work.
Just tell me honestly your are 100% sure this isn’t the problem of OSMC, this isn’t some kind of strange software bug. Then I am happy and find another way, or give up.

If i would worry about cash they are already offered in the first place to pay back my full subscription. And to be honest I do not care about it. I just care that their service works on Synology with DVBLink Sever, and using DVBLink on OSMC. But if I use IPTV Simple Client, it just doesn’t work. So again the same stream with IPTV Simple Client isnt’ working , with DVBLink it works. I checked my traffic, in both PVR my Rpi is going out to get the stream, so DVBLin server isn’t converting the stream (i ticked off that function). Also the same stream works on Android with Kodi 17 with same IPTV Simple Client PVR. So i pretty much been able to point out that Rpi with Kodi could be the issue. But as I can’t see the code, can’t do logs in a depth which may be needed. So without these it could be anything.

I have found this link https://discourse.osmc.tv/t/testing-kodi-17-krypton-builds-for-raspberry-pi-continued/14628 is this the right one to follow for that?

Also should i jump on the beta, or should i wait to see is there anything will happen?

Here we go, Sam now has suggested twice that you try Krypton on OSMC as it has better stream handling.

I can take a look at the stream if you want and see if there is an issue.

Thanks, I will give a go with Kodi 17 , after all it’s qite pointless to test the old version if the new is coming and solves my problem.

I let you know about the result.