RPI3B+ Audio dropouts when playing audio

Hi, this fix was working for me too. Is there a way to reinstall it ?

There is a potential new fix, which is I’ll make available for testing soon.

Ok thank you !

Hi, do you have an idea when the potential fix would be available for testing ?

Thank you for your work.

I’ll make some testing in a bit when I get some time,



I found I also had an audio dropout problem on a RPi1B about a month ago (the time of Sam’s penultimate message), when I played some music for the first time in ages (mp3 stored on NAS, accessed via samba, with library database also on NAS, connected by wired ethernet). Since there appeared to be a potential fix available soon, I decided wait and see if that resolved the problem before investigating further. However, since no fix has appeared, i am now thinking of reverting to a previous version of OSMC using one of my SD card backups. So I wondered if anyone knew which version introduced this problem, to save me the bother of working backwards through each of my backups in turn until i find the one that works.

Thanks for your help.

I have to admit that as it stands mp3/m4a audio playback is currently unusable for me.

So far it’s narrowed down to:
-mp3/m4a file playback (FLAC very very rarely as well)
-does not occur when played back locally from USB stick
-does not occur for movies or other video playback
-occured on both RPi 3 and 3B+
-occured since at least March 2018 but potentially before

If it’s a hardware issue with my setup then why do all the much higher bitrate files play back flawlessly and why has this identical setup worked flawlessly for a few years before this?

I had very similar issues when I first bought the vero4k changing the audio mode from best match to fixed did the trick for me. Make sure you have expert level settings enabled.

Thanks for the suggestion k2u3 but sadly it did not work for me. On my setup, Audio - Output Configuration was Optimised (although I don’t know why - I have never set it to the best of my knowledge). Changing it to Fixed appeared to make the problem slightly worse (including a sad face crash), whilst changing it to Best Match (which is the OSMC recommendation) appeared to make it slightly better. However, my testing was both extremely limited and subjective, so I would not read anything significant into these apparent differences. The important point is that audio dropouts still occurred at all settings.

So, based on james4 reply, I will next test my March 2018 SD card backup and then work forwards or backwards from there and report back in the fullness of time - unless Sam comes up with a fix in the meanwhile.

Had similar problem in my time with USB disk hooked to the RPI directly and HDMI connection through AVR. Music playback HDMI signal (drops) - #8 by shamael . The issue was only for mp3/flac playback never during movies.

My setup changed a lot so not able to test it back in same conditions but it remained unsolved in its time for me. I ended with a samba share on the RPI and the AVR reading it directly.

I have tested some of my various SD card backups with the following results -

Current system: OSMC = 2018.07-1; Kernel = 4.14.34-4-osmc; Dropouts = Yes
20/3/18 backup: OSMC = 2018.03-2; Kernel = 4.14.26-2-osmc; Dropouts = Yes
24/1/18 backup: OSMC = 2017.12-1; Kernel = 4.9.29-13-osmc; Dropouts = No
06/2/18 backup: OSMC = 2017.18-1; Kernel = 4.9.29-17-osmc; Dropouts = No

This confirms james4’s suggestion that the problem arose in March 2018 and indicates that it is likely to be related to the change of kernel from 2.9 to 2.14, as suggested by Ronnick in post 11. Therefore, I will try downgrading the kernel next week, following Sam’s instructions in this thread Playback Video - sound stuttering after March 5th Update, which is presumably a slightly different manifestation of the same underlying cause. Whilst, as Ronnick points out, this is not a good solution, until a proper fix is available I think it is preferable to have an out of date system that works properly than an up to date on that doesn’t.

PS Since I have these backups, I could relatively easily provide logs under identical conditions for a working and a non-working system, if this would help the developers resolve the issue. However, since a working fix has previously been provided on both these threads and then reverted, I suspect they probably know what the problem is, just not how to resolve it without causing other problems elsewhere. Is this correct?

1 Like

It should be fixed in the next update at last

1 Like

Brilliant - many thanks Sam (not just from me but from everyone with this problem I expect)! In that case I won’t bother with downgrading the kernel until I have tried the update. Any ideas on an approximate release date?

When it’s ready



Thanks for your patience. Things should now be ready for testing.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.



Hi Sam,

Thanks for having another crack at this, I’m sorry to say that I am still having intermittent drop outs after applying the update.

Would you like any fresh logs etc?

Many thanks,

No. Unfortunately I don’t have a solution for this I’m afraid.

Some limited testing, but so far no dropouts - so a good improvement.

I have only done limited testing (20 tracks from the album where I first discovered the problem), but experienced no dropouts after the update. Previously, i was getting multiple dropouts near the start of every track except the first. Therefore, this update appears to fix the problem for me.

Many thanks Sam (and the rest of the developers) for sorting this out and for all your hard work on OSMC in general.


I’m here in 2021… And still having problems on an ALLO USBridge Sig. based on a CM3+ module. All this running with a linear powersupply. OS is OSMC with Kodi 18.9 on kernel 3.19.122-2osmc now.

The problem is only audible on HIFI speakers though… TV speakers not good enough to hear it. I have tried two different amps and two sets of speakers… It makes no difference.

The problem persists if I run audio via HDMI to DAC or clean USB to DAC… It makes no difference.

I have also tried Volumio… It did not solve the problem either.
Also tried the fix provided by sam_nazarko. No difference.

The problem is still here… How can this be? !

I need audio and video playback… And HDMI-CEC…
Is a new RPI4 or ASUS Thinkerboard S my best options to fix this? Opinions, anyone?