Samba access to raspberry impossible from mac osX since last update


Since the last update (i think) i can’t access my raspberry whith samba protocole ONLY from my mac. The big mistery is that I still get a samba access fom windows or even android (with es explorer).

My raspberry have a static IP wich is and when i try to connect from OSX with the command smb:// it first connect and prompt me to identify. Once i did it i always get the error that the connexion to the server has failed.

It used to work very well before and i didn’t change anything on my mac (no firewall, etc…). And, like I said, there is no problem from windows or android. It look likes there is a specific problem with OSX (el capitan) and the samba server. I check the smb.conf file but nothing has changed since the update.

So i’m totally stuck, i even try to make a fresh installation of OSX and the problem is still the same…

I really don’t understand how people

  1. Can not use the search function of the forum
  2. Even can not see a thread that is just 6 threads below their own listed

Please stop opening new threads for a topic that is already well discussed.

perhaps because you don’t read my post carrefully.

  1. I used the search function and found the thread you mention

  2. It’s not the same problem

people seem to report that they have an issue to access SMB shares (without username and password) that they have running on their NAS or Windows PC from their OSMC Box

in my case i have a problem to access the raspberry share from my computer and ONLY from my mac

It’s not a samba client problem it’s a samba server problems

Same topic (maybe the other thread), but with the security update on the 14th both the client and server have been updated with new security features that break communication with older clients.

Ok thx,

So i guess that the samba client on OSX el capitan is not compatible with the april security update on OSMC samba server.

But i’m surprised that nobody mention this specific problem on the forum.

hope that an update will fix this problem