Samba server access

i try to access to osmc without succes
i did read somes topics, did some tests but it isn’t OK (for ex, set protocol SMBv1 on osmc)

  • on my oppo bluray player, osmc is deplayed. When i try to access, with user/pass osmc:osmc, it tells user/pass wrong
  • on my PC, osmc is’nt event displayed

via ssh on PC, osmc@osmc:~$ sudo systemctl status samba

  • samba.service - Samba Server
    Loaded: loaded (/lib/systemd/system/samba.service; enabled; vendor preset: enabled)
    Active: active (exited) since Sat 2020-04-18 10:20:17 CEST; 1h 34min ago
    Process: 406 ExecStart=/etc/init.d/samba.distributed start (code=exited, status=0/SUCCE
    Main PID: 406 (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/samba.service

Apr 18 10:19:53 osmc systemd[1]: Starting Samba Server…
Apr 18 10:20:16 osmc samba.distributed[406]: Starting nmbd (via systemctl): nmbd.service.
Apr 18 10:20:17 osmc samba.distributed[406]: Starting smbd (via systemctl): smbd.service.
Apr 18 10:20:17 osmc systemd[1]: Started Samba Server.

please help me
thanks a lot

Are you using Win10 or which OS?
If Win10 what happen if you type \\<IP of OSMC>\ into Explorer?

yes, it is win 10


=> i just tried on another pc win 7. Same result :frowning:

Please log into OSMC via ssh and do following:

  1. sudo apt-get install smbclient
  2. sbmclient -L

i get the following output
and i have still the same problem

osmc@osmc:~$ smbclient -L
Enter osmc’s password:
Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.16-Debian]

    Sharename       Type      Comment
    ---------       ----      -------
    osmc            Disk      OSMC Home Directory
    IPC$            IPC       IPC Service (Samba 4.5.16-Debian)
    XYZXYZXYZ_UBS3  Disk      Auto-mount Volume

Domain=[WORKGROUP] OS=[Windows 6.1] Server=[Samba 4.5.16-Debian]

    Server               Comment
    ---------            -------
    LIVEBOX              Livebox
    OSMC                 Samba 4.5.16-Debian

    Workgroup            Master
    ---------            -------
    WORKGROUP            LIVEBOX

Well at least we know it works on OSMC

On the windows machine open cmd and run net view \\

c:\Temp>net view \
L’erreur système 53 s’est produite.

Le chemin réseau n’a pas été trouvé.

the same with c:\Temp>net view

sorry, i am on a french pc :slight_smile:

Ok, we have seen that before. Seems people had success after clearing the info in credential manager.
Start > Control Panel > User Accounts > Credential Manager
Also can you try in explorer \\\osmc

Or you can try in cmd

net use * /del
net use \\\osmc /user:osmc

i am reading this post, Issue with smb after change of ip - #5 by ildave
in which, there are your messages
ok, i will try it and let you feedback

it is ok now


i will see if it is Ok from my Oppo player

it is still KO on my OPPO
i see osmc but i get error when access
i tried osmc:osmc and osmc+without pass


any idea?

unless you changed it it’s osmc:osmc (you can try from your Win10)

With the OPPO it might be a SMB version problem. Do you know which SMB versions the OPPO supports?

unfortunately i don’t know what version
i will ask OPPO about it

i found on net: “they only support SMB v2” but i am not sure :slight_smile:

I do nfs sharing from this post Sharing attached USB storage in OSMC using NFS – Endpoint 101
and my OPPO can access mounted disk on osmc now :slight_smile:
thanks a lot for your helps

they tell me that the player can only support SMB1.

Ok, but even that should work with OSMC. But if you switched to NFS than better anyhow.

1 Like