Samba Share Access from Mac Mini Server

Hi there!

I am the happy owner of a Mac Mini running Kodi App. However I also have a Raspberry Pi in another room. Here I wish to stream my files directly from the Mac Mini.

Therefore I have made a “Sharing” through Mac OS System Preferences and added my HDD here, which is attached to the Mac Mini.

Now I am able to see the HDD, when I add the smb path to OSMC. However all files in the folders are showing as 0 bytes and the Library Updater are not able to read the files.

I have applied full permissions through the Sharing inside the Mac OS Preferences.

Anyone who can help me?

I am running OSMC 2020.11-1.

Looking forward to hear from you! :slight_smile:

Maybe try kernel based mounts (fstab or autofs)

Hi Fzinken! Always nice to hear from you! :slight_smile:

I have actually also tried this without any luck… Which is actually really weird because I have tried the guide here: Configuring fstab based Samba share mounts

I am able to connect to the server using smbclient.

This is what I have tried to insert into fstab with a credentials file.

// /home/User/HDD cifs x-systemd.automount,noauto,rw,iocharset=utf8,credentials=/home/osmc/.credentials,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0 0 0

The mount doesn’t work however sudo mount -a gives no errors.

Could be a samba version issue. Check with smclient -d -L which negotiated dialect is shown.

Or first just try without vers=3.0 in the fstab entry

Mhmm not so sure what this means. (I have blurred out my fullname why black fields at Username) :slight_smile:

Actually I forgot one number in my command (while you didn’t added it at all).

Execute smclient -d5 -L

Also my Mac Mini Username has white spaces.
In the credentials configuration - is it fine like this:
username=‘Something something’ ?
Or should it be like:
username=Something\040something ?

Actually the Share name is LaCie P9237 and not LaCie as you have written in fstab!
If you use that share name watchout that you have to escape the space in fstab.

Negotiated dialect: negotiated dialect[SMB3_02] against server[]

Ok, than you vers should be ok (but also can leave it out). Then the error is just wrong share name.

Not sure, try it out after you correct the Share name

Like this?

//\040P9327 /home/Frederik/HDD cifs x-systemd.automount,noauto,rw,iocharset=utf8,credentials=/home/osmc/.credentials,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770

P9237 ya…


Sadly nothing gets mounted after a reboot :frowning:

(Tried both ways to insert the credentials with whitespace and \040)

Any way we can debug this further? :+1:

I just checked the log.

This is the output, when I tries to connect to the server.

Aug 01 17:49:17 osmc kernel: Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
Aug 01 17:49:17 osmc kernel: CIFS VFS: Send error in SessSetup = -13
Aug 01 17:49:17 osmc kernel: CIFS VFS: cifs_mount failed w/return code = -13


This would suggest there is is an issue with credentials file, please double check the contents of:


Also please provide the output of:

sudo mount -v /home/Frederik/HDD

Thanks Tom.

Hi there.

I guess you are right about the credentials file. My issue might be, that my Mac Mini has a username with white spaces. I have tried to use \040 as whitespace instead and I am not sure if it works.

The output for sudo mount -v /home/Frederik/HDD is:

mount: /home/Frederik/HDD: cant find in /etc/fstab.


Have you consider creating a new user, without spaces; just to be used for the the share?

Please issues the following link and provide the given link:

cat /etc/fstab | paste-log

Thanks Tom.