Select WiFi interface

Hi OSMC Community,

I use OSMC on my Raspberry Pi 3 Model B. The Raspberry Pi have an onboard WiFi interface. But this one is to slow for my usage. So I add an USB WiFi dongle, which is much faster. This dongle works fine under raspbian and is also detected under OSMC. But when I now go to the OSMC WiFi Settings and try to connect to my WiFi named MyWiFi (wlan1) the connection will be established trough the wlan0 interface.

Is there any way to disable the onboard wlan0 interface or an other solution for that issue?

Regards

Same question was just asked 7 days ago, search is your friend

http://forum.kodi.tv/showthread.php?tid=281325 Not 100% sure this will work on OSMC but it should,

attn @sam_nazarko

1 Like

That will work.

Can also put dtoverlay=sdhost in /boot/config.txt.