Since Matrix update playing from network gets error


since the Matrix update I get an error message on my Vero4k+ if I try playing a file from my NSF share.
This is because the HDD needs some seconds to spin up.
Probably Kodi/OSMC has decreased the waiting time before the message gets out?!

Where can I increase the waiting time?


Shouldn’t be a change in waiting time. Kodi version hasn’t changed between last update. What version were you on before?

Some logs should help.

The issue comes with the big update from Leia to Matrix. Not with the last update.

Thanks for clarifying. How are your shares mounted? You could try an OS level mount.

It’s not mounted in the system way. Only added via kodi source.
Mount with fstab will not fix the problem, the hdd spins down after 30 minutes.
If you try to watch something after the spin down you will get the error message. then you have to wait 2-3 seconds more, start it again and it’s fine.
Is it not possible to increase this waiting time?

In the My OSMC add-on network section there is an option for this. There is also an option in Kodi’s settings>system>power settings. If one doesn’t work for you the other may.

Thanks for the hint, unfortunately it doesn’t help.
I tried both options, separately and together.

Any other options?

You can try to use customized file


and there configure a larger timeout like


tried the advancedsettings.xml but doesent work at the first try.
But Sam fixed it at the 19.4 release!