Skin changes lost after a reboot

Following… :slight_smile:

Unfortunately, @sam_nazarko will be away for a few days. I’m sure he will publish this fix ASAP.

I cannot install the updates yet but I noticed that the devel repo has been updated. I assume that the patch has been included?

EDIT: installed the new OSMC version. Will test later.

Hello, All! 1st post and 1st things 1st. Sam, /bow. OSMC is amazing very impressed!

Today this same problem happened to me as well. I tried a reboot from the web UI as pandoki was playing. I run a USB sound card as well. Both the skin and sound card were set back to default. I’ve only noticed this on a reboot. Every other time I’ve tried shutting down, pulling power, and reconnecting power its worked flawlessly. Admittedly, I’m pretty noobish when it comes to all this but I’m happy to help however I can.

i disabled debug logs yesterday in all 5 rpi3 i have and today on 4 of them i had a complete reset of everything. damn.

I also get the kodi cannot connect to json-rpc message on all of them.

I just disabled logs yesterday ffs

and after another restart in all of them i got skin settings reset as well. #R@#R@#

According to Sam the fix is currently only ready for the Vero3: Vero 4K - settings reseted after reboot - #14 by sam_nazarko

I guess that I was just lucky that my Pi2’s settings survived two reboots.

It’s available for Vero 1, Vero 2, Vero 4K, PC (internal testing) and Apple TV. RBP requires more changes due to some updates in userland, but I will get it built soon.

1 Like

It’s ready for Raspberry Pi now. Please let me know if this issue is resolved.

Sam

Thanks for the efforts @sam_nazarko. Will report if something goes wrong

I just installed it (remotely) via SSH but the apt-get dist-upgrade command seems to run without any installing anything:

osmc@osmc-keuken:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following package was automatically installed and is no longer required:
libjasper1
Use ‘apt-get autoremove’ to remove it.
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Maybe it’s because I did a manual upgrade earlier this morning via the GUI?

Yes. It’s been in the repository for a few hours.

I will do a couple of reboots and hopefully the problem is resolved. I guess this will take some time to be 100% sure as my last reboots without the fix also kept the menu settings.

thanks for all the work on fixing this!

Same here with confluence skin. Online-update on Apr. 2nd did not improve anything.
Looks like the libreELEC dudes have similar problems. I’ll switch one of my boxes over to LE, to see differences - or not.

@Laser_Man have you tested with today’s update to jessie-devel?

We’ve had some good reports.

Sam

Hi Sam,
just did
apt-get -y update
apt-get -y upgrade
reboot

… but System info still tells me, Kodi was compiled on March, 22nd. Ist this okay?

cheers,
Laser_Man

Don’t run apt-get upgrade. That will break your system and you’ll need to reinstall.
If you have run this, you need to reinstall. You should’ve actually received a warning preventing you from doing this; but on older versions of OSMC this won’t show up.

The Kodi build on Raspberry Pi should show 10th April. The Kodi build on 22nd March is still affected by the issue.

i have also added the:

deb http://apt.osmc.tv jessie-devel main

on my sources.list

I have executed now the SSH command and i obtain about 50MB of updates… wait installation and reboot to see what’s appened…

this is the list founded:

armv7-connman-osmc mediacenter-addon-osmc rbp-bootloader-osmc rbp-userland-osmc rbp2-libcec-osmc rbp2-mediacenter-osmc

Just tested this. The apt-get -y upgrade runs fine without warnings on an updated system, but not apt-get upgrade.
Guess the system does not check on the -y switch.

Looks like we will need to add that. Thanks for letting me know.

I’m having the same issue with my RP3. I’ve read the thread and I’m a bit confused. Is there an update I have to run manually or was there a patch that was pushed down via automatic update?

I am very new the the RP3 and Linux in general. Very basic knowledge.